source: projects/specs/trunk/i/iproute/iproute-vl.spec @ 8524

Revision 8524, 16.6 KB checked in by tomop, 10 years ago (diff)

iproute-3.14.0-1

Line 
1##%define date_version 070710
2%define cbq_version v0.7.3
3
4Summary: Advanced IP routing and network device configuration tools
5Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
6Name: iproute
7Version: 3.14.0
8Release: 1%{?_dist_release}
9Group: Applications/System
10Source: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.gz
11URL: http://kernel.org/pub/linux/utils/net/%{name}2/
12Source1: cbq-0000.example
13Source2: avpkt
14Patch0: man-pages.patch
15Patch1: iproute2-3.4.0-kernel.patch
16Patch2: iproute2-3.11.0-optflags.patch
17Patch3: iproute2-3.9.0-IPPROTO_IP_for_SA.patch
18Patch4: iproute2-example-cbq-service.patch
19Patch5: iproute2-2.6.35-print-route.patch
20Patch6: iproute2-3.12.0-lnstat-dump-to-stdout.patch
21# from RawHide <http://thread.gmane.org/gmane.linux.network/284101>
22Patch7: iproute2-3.11.0-tc-ok.patch
23Patch8: iproute2-3.11.0-rtt.patch
24Patch9: iproute2-3.12.0-lnstat-interval.patch
25
26# VINE
27Patch100: iproute2-3.14.0-platex.patch
28
29License: GPLv2+ and Public Domain
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
31BuildRequires: bison flex
32BuildRequires: iptables-devel >= 1.4.10, libdb-devel
33BuildRequires: texlive-collection-latexrecommended
34BuildRequires: linuxdoc-tools pkgconfig psutils
35Requires: iptables >= 1.4.10
36
37%description
38The iproute package contains networking utilities (ip and rtmon, for
39example) which are designed to use the advanced networking
40capabilities of the Linux 2.4.x and 2.6.x kernel.
41
42%description -l ja
43このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
44ネットワーク技術を使うように設計された、ネットワーキングユーティリ
45ティ(ip, rtmon等々)が収録されています。
46
47%package doc
48Summary: ip and tc documentation with examples
49Summary(ja): ip, tcのドキュメントとサンプル
50Group: Applications/System
51License: GPLv2+
52
53%description doc
54The iproute documentation contains howtos and examples of settings.
55
56%package devel
57Summary: Libraries, includes, etc. to develop iptables
58Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
59Group: Development/Libraries
60Requires: %{name} = %{version}
61
62%description devel
63Libraries, include files, etc you can use to develop iproute2.
64
65
66%prep
67%setup -q -n iproute2-%{version}
68%patch0 -p1
69%patch1 -p1 -b .kernel
70%patch2 -p1 -b .opt_flags
71%patch3 -p1 -b .ipproto
72%patch4 -p1 -b .fix_cbq
73%patch5 -p1 -b .print-route
74%patch6 -p1 -b .lnstat-dump-to-stdout
75%patch7 -p1 -b .tc_ok
76%patch8 -p1 -b .rtt
77%patch9 -p1 -b .lnstat-interval
78sed -i 's/^LIBDIR=/LIBDIR?=/' Makefile
79
80%patch100 -p1 -b .platex
81
82%build
83export LIBDIR=/%{_libdir}
84export IPT_LIB_DIR=/%{_lib}/xtables
85./configure
86make %{?_smp_mflags}
87make -C doc
88
89%install
90[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
91
92mkdir -p \
93    %{buildroot}%{_includedir} \
94    %{buildroot}/sbin \
95    %{buildroot}%{_sbindir} \
96    %{buildroot}%{_mandir}/man3 \
97    %{buildroot}%{_mandir}/man7 \
98    %{buildroot}%{_mandir}/man8 \
99    %{buildroot}%{_libdir}/tc \
100    %{buildroot}%{_sysconfdir}/iproute2 \
101    %{buildroot}%{_sysconfdir}/sysconfig/cbq
102
103for binary in \
104    ip/ifcfg \
105    ip/ip \
106    ip/rtmon \
107    tc/tc
108    do install -m755 ${binary} %{buildroot}/sbin/
109done
110
111install -m755 examples/cbq.init-%{cbq_version} %{buildroot}/sbin/cbq
112
113for binary in \
114    bridge/bridge \
115    genl/genl \
116    ip/routef \
117    ip/routel \
118    ip/rtpr \
119    misc/arpd \
120    misc/ifstat \
121    misc/lnstat \
122    misc/nstat \
123    misc/rtacct \
124    misc/ss
125    do install -m755 ${binary} %{buildroot}%{_sbindir}
126done
127
128cd %{buildroot}%{_sbindir}
129    ln -s lnstat ctstat
130    ln -s lnstat rtstat
131cd -
132
133# Libs
134install -m644 netem/*.dist %{buildroot}%{_libdir}/tc
135install -m755 tc/m_xt.so %{buildroot}%{_libdir}/tc
136cd %{buildroot}%{_libdir}/tc
137    ln -s m_xt.so m_ipt.so
138cd -
139
140# libnetlink
141install -m644 include/libnetlink.h %{buildroot}%{_includedir}
142install -m644 lib/libnetlink.a %{buildroot}%{_libdir}
143
144# Manpages
145iconv -f latin1 -t utf8 man/man8/ss.8 > man/man8/ss.8.utf8 &&
146    mv man/man8/ss.8.utf8 man/man8/ss.8
147install -m644 man/man3/*.3 %{buildroot}%{_mandir}/man3
148install -m644 man/man7/*.7 %{buildroot}%{_mandir}/man7
149install -m644 man/man8/*.8 %{buildroot}%{_mandir}/man8
150
151# Config files
152install -m644 etc/iproute2/* %{buildroot}%{_sysconfdir}/iproute2
153for config in \
154    %{SOURCE1} \
155    %{SOURCE2}
156    do install -m644 ${config} %{buildroot}%{_sysconfdir}/sysconfig/cbq
157done
158
159
160%clean
161[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
162
163
164%files
165%dir %{_sysconfdir}/iproute2
166%doc COPYING
167%doc README README.decnet README.iproute2+tc README.distribution README.lnstat
168%{_mandir}/man7/*
169%{_mandir}/man8/*
170%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
171/sbin/*
172%{_sbindir}/*
173%dir %{_libdir}/tc/
174%{_libdir}/tc/*
175%dir %{_sysconfdir}/sysconfig/cbq
176%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
177
178%files doc
179%doc COPYING
180%doc doc/*.ps
181%doc examples
182
183%files devel
184%doc COPYING
185%{_mandir}/man3/*
186%{_libdir}/libnetlink.a
187%{_includedir}/libnetlink.h
188
189
190%changelog
191* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.14.0-1
192- new upstream release.
193- replaced Patch100.
194
195* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.38-1
196- update to 2.6.38.1
197- build with iptables-1.4.10
198- add BR: iptables-devel
199
200* Mon Apr 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-5
201- don't build/include documents. (almost same as man pages...)
202- remove BR: texlive ,linuxdoc-tools
203
204* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.6.31-4
205- rebuilt with rpm-4.8.1-3
206
207* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
208- rebuilt with gcc-4.4.3-3 on ppc
209
210* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
211- rebuilt with rpm-4.8.0-3 (on ppc)
212
213* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
214- new upstream release
215  - import patches from fedora package
216- build with db4-4.8
217
218* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
219- updated to 2.6.25 based on 2.6.25-1 from Fedora
220- build with db4-4.6.21
221- keep Patch100 from 2.6.16-1vl5
222-changelogs for previous Vine package as follows:
223  - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
224  - apply new versioning policy.
225
226  - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
227  - updated to 2.6.16 and merged several patches from FC 2.6.16-6
228    (Patch10 not applied until VineSeed kernel goes higher versions)
229  - rebuilt with new toolchain and db4-4.3.x
230
231  - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
232  - added Patch5 to make documents without errors
233
234  - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
235  - update to 2.6.15-060110
236
237  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
238  - added BuildRequires: linuxdoc-tools
239
240  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
241  - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
242
243  - Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
244  - new upstream release
245  - changed Group: of devel package
246  - applyed patches from Fedora development
247    - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
248    - Took tons of manpages from debian, much more complete (#123952).
249  - added Japanese translation from spec translation project :-)
250
251  - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
252  - 2.2.4-14vl2
253  - rename package name iproute to iproute2
254  - rebuild development version
255
256* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
257- update
258- remove patch for backward compatibility
259- add patch for AEAD compatibility
260
261* Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
262- add creating ps file again. Fix was done in texlive
263
264* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
265- rebuild without tetex files. It isn't working in rawhide yet. Added
266        new source for ps files.
267- #431179 backward compatibility for previous iproute versions
268
269* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
270- rebuild with fix tetex and linuxdoc-tools -> manual pdf
271- clean unnecessary patches
272- add into spec *.so objects, new BR linux-atm-libs-devel
273
274* Wed Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
275- new version from upstrem 2.3.23
276
277* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
278- move files from /usr/lib/tc to /usr/share/tc
279- remove listing files twice
280
281* Thu Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
282- package review #225903
283
284* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
285- rebuild for new db4
286
287* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
288- upgrade to 2.6.22
289
290* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
291- fix broken tc-pfifo man page (#232891)
292
293* Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
294- upgrade to 2.6.20
295
296* Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
297- upgrade to 2.6.19
298
299* Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
300- fix snapshot version
301
302* Fri Dec  1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
303- spec file cleanup
304- one more rebuilt against db4
305
306* Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
307- fix defective manpage for tc-pfifo (#215399)
308
309* Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
310- rebuilt against new db4
311
312* Tue Oct  3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
313- upgrade to upstream 2.6.18
314- initcwnd patch merged
315- bug fix for xfrm monitor
316- alignment fixes for cris
317- documentation corrections
318       
319* Mon Oct  2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
320- fix ip.8 man page, add initcwnd option
321
322* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
323- rebuilt for unwind info generation, broken in gcc-4.1.1-21
324
325* Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
326- fix crash when resolving ip address
327
328* Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
329- add LOWER_UP and DORMANT flags (#202199)
330- use dist tag
331
332* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
333- rebuild
334
335* Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
336- improve handling of initcwnd value (#179719)
337
338* Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
339- fix BuildRequires: flex (#193403)
340
341* Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
342- upgrade to 2.6.16-060323
343- don't hardcode /usr/lib in tc (#186607)
344
345* Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
346- own /usr/lib/tc (#181953)
347- obsoletes shapecfg (#182284)
348
349* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
350- bump again for double-long bug on ppc(64)
351
352* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
353- rebuilt for new gcc4.1 snapshot and glibc changes
354
355* Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
356- upgrade to 2.6.15-060110
357
358* Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
359- rebuilt
360
361* Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
362- remove backup of config files (#175302)
363
364* Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
365- use tc manpages and cbq.init from source tarball (#172851)
366
367* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
368- new upstream source
369
370* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
371- add warning to ip tunnel add command (#128107)
372
373* Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
374- update from upstream (appears to fix #170111)
375
376* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
377- update from upstream
378- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
379
380* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
381- add RPM_OPT_FLAGS
382
383* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
384- forget to apply the patch :(
385
386* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
387- make ip help work again (#168449)
388
389* Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
390- upgrade to ss050901 for 2.6.14 kernel headers
391
392* Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
393- added /sbin/cbq script and sample configuration files (#166301)
394
395* Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
396- upgrade to iproute2-050816
397
398* Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
399- update to snapshot for 2.6.13+ kernel
400
401* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
402- removed useless initvar patch (#150798)
403- new upstream source
404
405* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
406- update to iproute-2.6.11
407
408* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
409- gcc4 rebuilt
410
411* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
412- update to iproute-2.6.10
413
414* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
415- added arpd into sbin
416
417* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
418- debug info removed from makefile and from spec (#140891)
419
420* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
421- source file updated from snapshot version
422- endian patch adding <endian.h>
423
424* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
425- added installation of netem module for tc
426
427* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
428- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
429
430* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
431- updated to iproute-2.6.9, spec file change, patches cleared
432
433* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
434- rebuilt
435
436* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
437- Took tons of manpages from debian, much more complete (#123952).
438
439* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
440- rebuilt
441
442* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
443- Built security errata version for FC1.
444
445* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
446- Fixed -f option for ss (#118355).
447- Small description fix (#110997).
448- Added initialization of some vars (#74961).
449- Added patch to initialize "default" rule as well (#60693).
450
451* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
452- rebuilt
453
454* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
455- Security errata for netlink (CAN-2003-0856).
456
457* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
458- Updated to latest version. Used by other distros, so seems stable. ;-)
459- Quite a few patches needed updating in that turn.
460- Added ss (#107363) and several other new nifty tools.
461
462* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
463- rebuilt
464
465* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
466- rebuilt
467
468* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
469- rebuilt
470
471* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
472- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
473
474* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
475- remove flags patch at author's request
476
477* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
478- automated rebuild
479
480* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
481- Don't forcibly strip binaries
482
483* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
484- Fixed missing diffserv and atm support in config (#57278).
485- Fixed inconsistent numeric base problem for command line (#65473).
486
487* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
488- Added patch to fix crosscompiling by Adrian Linkins.
489
490* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
491- Update to latest stable release 2.4.7-now-ss010824.
492- Added simple man page for ip.
493
494* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
495- allow setting of allmulti & promisc flags (#48669)
496
497* Mon Jul 02 2001 Than Ngo <than@redhat.com>
498- fix build problem in beehive if kernel-sources is not installed
499
500* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
501- updated to iproute2-2.2.4-now-ss001007.tar.gz
502- bzip2 source tar file
503- "License" replaces "Copyright"
504- added "BuildPrereq: tetex-latex tetex-dvips psutils"
505- rebuilt for 7.2
506
507* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
508- use the system headers - the included ones are broken
509- ETH_P_ECHO went away
510
511* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
512- test for specific KERNEL_INCLUDE directories.
513
514* Thu Oct 12 2000 Than Ngo <than@redhat.com>
515- rebuild for 7.1
516
517* Thu Oct 12 2000 Than Ngo <than@redhat.com>
518- add default configuration files for iproute (Bug #10549, #18887)
519
520* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
521- fix include-glibc/ to cope with glibc 2.2 new resolver headers
522
523* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
524- automatic rebuild
525
526* Sun Jun 18 2000 Than Ngo <than@redhat.de>
527- rebuilt in the new build environment
528- use RPM macros
529- handle RPM_OPT_FLAGS
530
531* Sat Jun 03 2000 Than Ngo <than@redhat.de>
532- fix iproute to build with new glibc
533
534* Fri May 26 2000 Ngo Than <than@redhat.de>
535- update to 2.2.4-now-ss000305
536- add configuration files
537
538* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
539- strip binaries
540
541* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
542- first build
Note: See TracBrowser for help on using the repository browser.