source: projects/specs/trunk/i/ipchains/ipchains-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Tools for managing Linux kernel packet filtering capabilities.
2Name: ipchains
3Version: 1.3.10
4Release: 1%{?_dist_release}
5License: GPL
6Obsoletes: ipfwadm ipchains-scripts
7Group: System Environment/Base
8Source0: http://netfilter.filewatcher.org/ipchains/ipchains-%{version}.tar.gz
9Source1: http://netfilter.filewatcher.org/ipchains/ipchains-scripts-1.1.2.tar.gz
10Source2: http://netfilter.filewatcher.org/ipchains/HOWTO.sgml
11Source3: ipchains.init
12Patch0: ipchains-1.3.10-nonroot.patch
13Patch1: ipchains-1.3.10-fixman.patch
14Patch2: ipchains-1.3.9-return.patch
15Patch3: ipchains-1.3.10-libipfwc.patch
16Buildroot: %{_tmppath}/%{name}-root
17Prereq: /sbin/chkconfig
18BuildPrereq: perl, sgml-tools
19Requires: sh-utils
20
21%description
22Linux IP Firewalling Chains is an update to (and hopefully an
23improvement upon) the Linux kernel packet filtering code. Ipchains
24allows you to set up firewalls and IP masquerading, etc.
25
26Install ipchains if you need to set up firewalling for your network.
27
28%prep
29%setup -q -a 1
30%patch0 -p1 -b .nonroot
31%patch1 -p1 -b .fixman
32%patch2 -p1 -b .return
33%patch3 -p0 -b .libipfwc
34install -m644 %{SOURCE2} .
35
36%build
37make clean
38make COPTS="$RPM_OPT_FLAGS"
39sgml2html HOWTO.sgml
40sgml2txt HOWTO.sgml
41%{__perl} -pi -e 's/.//g' HOWTO.txt
42
43%install
44rm -rf %{buildroot}
45mkdir -p %{buildroot}/{sbin,%{_mandir}/man{4,8}}
46
47make install SBIN=%{buildroot}/sbin MANDIR=%{buildroot}/%{_mandir}
48cp ipchains-scripts-1.1.2/{ipchains-restore,ipchains-save} %{buildroot}/sbin
49cp ipchains-scripts-1.1.2/ipfwadm-wrapper %{buildroot}/sbin/ipfwadm
50ln -sf ipfwadm %{buildroot}/sbin/ipfwadm-wrapper
51cp ipchains-scripts-1.1.2/{ipchains-restore.8,ipchains-save.8,ipfwadm-wrapper.8} %{buildroot}/%{_mandir}/man8
52
53install -d -m 755 %{buildroot}/etc/rc.d/init.d
54install -m 755 %{SOURCE3} %{buildroot}/etc/rc.d/init.d/ipchains
55
56strip %{buildroot}/sbin/ipchains
57
58%clean
59rm -rf %{buildroot}
60
61%post
62#/sbin/chkconfig --add ipchains
63
64%preun
65if [ $1 = 0 ] ; then
66        /sbin/chkconfig --del ipchains
67fi
68
69%files
70%defattr(-,root,root)
71%doc *.html *.sgml *.txt
72%doc COPYING README ipchains-quickref.ps
73%attr(755,root,root) %config /etc/rc.d/init.d/ipchains
74/sbin/*
75%{_mandir}/man*/*
76
77%changelog
78* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.10-1vl5
79- applied new versioning policy
80- added ipchains-1.3.10-libipfwc.patch
81
82* Sun Sep 22 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.10-0vl3
83- do not chkconfig --add in the %%post section
84  (kernel >= 2.4 and iptables would be default for Vine)
85
86* Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 1.3.10-0vl2
87- use ipchains.init with i18n support (packed in 1.3.10-8)
88
89* Thu Aug 16 2001 <sagami@vinelinux.org>
90- 1.3.10-0vl1: sources/patches/spec are taken from 1.3.10-8
91- rewrite ipchains.init w/o i18n support
92
93* Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
94- fix stupid typo in the preun script
95
96* Tue Feb 01 2000 Cristian Gafton <gafton@redhat.com>
97- add the initscript from joshua
98- remove uselss define version
99- add %post and %preun
100
101* Mon Sep 20 1999 Bill Nottingham <notting@redhat.com>
102- strip binary
103
104* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
105- nuke backspaces in HOWTO.txt (#4249).
106
107* Mon May 31 1999 Jeff Johnson <jbj@redhat.com>
108- update to 1.3.9.
109
110* Tue May 25 1999 Michael K. Johnson <johnsonm@redhat.com>
111- new ipchains-scripts release 1.1.2
112- ipfwadm-wrapper should be called ipfwadm with symlink to old name
113  (users can install old ipfwadm as ipfwadm.real if they wish)
114
115* Tue Mar 23 1999 Bill Nottingham <notting@redhat.com>
116- obsolete phantom ipchains-scripts package that's been floating around...
117
118* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
119- auto rebuild in the new build environment (release 2)
120
121* Tue Nov 17 1998 Preston Brown <pbrown@redhat.com>
122- initial cut.
Note: See TracBrowser for help on using the repository browser.