source: projects/specs/trunk/i/install-assist-LibreOffice/install-assist-LibreOffice-vl.spec @ 5427

Revision 5427, 7.9 KB checked in by munepi, 12 years ago (diff)

updated install-assist-LibreOffice?

Line 
1%define pkgname LibreOffice
2%define version 3.4.5
3%ifarch %{ix86}
4%define uarch   x86
5%define pkgarch x86
6%define rpmarch i586
7%endif
8%ifarch x86_64
9%define uarch   x86_64
10%define pkgarch x86-64
11%define rpmarch x86_64
12%endif
13
14%define baseurl \{http://download.documentfoundation.org,http://mirrors.vinelinux.org\}/libreoffice/stable/%{version}/rpm/%{uarch}
15%define dlurl \\\
16        %{baseurl}/LibO_%{version}_Linux_%{pkgarch}_install-rpm_en-US.tar.gz \\\
17        %{baseurl}/LibO_%{version}_Linux_%{pkgarch}_langpack-rpm_ja.tar.gz \\\
18        %{baseurl}/LibO_%{version}_Linux_%{pkgarch}_helppack-rpm_ja.tar.gz
19
20Summary:        Package to assist installation of %{pkgname}
21Summary(ja):    %{pkgname} のインストールを補助するパッケージ
22Name:           install-assist-%{pkgname}
23Version:        %{version}
24Release:        1%{?_dist_release}
25License:        LGPLv3
26Group:          Applications/Productivity
27
28ExclusiveArch:  %{ix86} x86_64
29# Requires(posttrans) not yet implemented. So we use (post) instead.
30Requires(post): self-build-setup >= 0.9.0
31Requires:       glibc >= 2.5
32Requires:       gtk2 >= 2.10.4
33Requires:       libgnome >= 2.16
34#Requires:      libgail-gnome >= 1.8.6
35Requires:       at-spi >= 1.7
36
37# Needs JAVA VM <BTS:1168>
38Requires:       java-1.6.0
39
40# We have to specify previous version with "Conflicts:"
41# to make smart upgrading. See [VineSeed:20565].
42# Conflicts:    openoffice.org-core <= 2.4.1-5vl5
43Obsoletes:      openoffice.org < 3.0
44Obsoletes:      openoffice.org-base < 3.0
45Obsoletes:      openoffice.org-calc < 3.0
46Obsoletes:      openoffice.org-core < 3.0
47Obsoletes:      openoffice.org-devel < 3.0
48Obsoletes:      openoffice.org-draw < 3.0
49Obsoletes:      openoffice.org-emailmerge < 3.0
50Obsoletes:      openoffice.org-graphicfilter < 3.0
51Obsoletes:      openoffice.org-headless < 3.0
52Obsoletes:      openoffice.org-i18n < 3.0
53Obsoletes:      openoffice.org-impress < 3.0
54Obsoletes:      openoffice.org-libs < 3.0
55Obsoletes:      openoffice.org-math < 3.0
56Obsoletes:      openoffice.org-pyuno < 3.0
57Obsoletes:      openoffice.org-sdk < 3.0
58Obsoletes:      openoffice.org-sdk-doc < 3.0
59Obsoletes:      openoffice.org-testtools < 3.0
60Obsoletes:      openoffice.org-writer < 3.0
61Obsoletes:      openoffice.org-xsltfilter < 3.0
62# Conflicts:    ooobasis3.1-core01 openoffice.org3.1-freedesktop-menus
63# Conflicts:    ooobasis3.2-core01 openoffice.org3.2-freedesktop-menus
64# Conflicts:    openoffice.org-ure
65Obsoletes:      openoffice.org3 < 3.3
66Obsoletes:      openoffice.org3-ja < 3.3
67Obsoletes:      ooobasis3.1-ja < 3.3, ooobasis3.2-ja < 3.3
68Obsoletes:      ooobasis3.1-ja-base < 3.3, ooobasis3.2-ja-base < 3.3
69Obsoletes:      ooobasis3.1-ja-calc < 3.3, ooobasis3.2-ja-calc < 3.3
70Obsoletes:      ooobasis3.1-ja-draw < 3.3, ooobasis3.2-ja-draw < 3.3
71Obsoletes:      ooobasis3.1-ja-help < 3.3, ooobasis3.2-ja-help < 3.3
72Obsoletes:      ooobasis3.1-ja-impress < 3.3, ooobasis3.2-ja-impress < 3.3
73Obsoletes:      ooobasis3.1-ja-math < 3.3, ooobasis3.2-ja-math < 3.3
74Obsoletes:      ooobasis3.1-ja-res < 3.3, ooobasis3.2-ja-res < 3.3
75Obsoletes:      ooobasis3.1-ja-writer < 3.3, ooobasis3.2-ja-writer < 3.3
76Obsoletes:      ooobasis3.1-images < 3.3, ooobasis3.2-images < 3.3
77Obsoletes:      ooobasis3.1-core01 < 3.3, ooobasis3.2-core01 < 3.3
78Obsoletes:      ooobasis3.1-core02 < 3.3, ooobasis3.2-core02 < 3.3
79Obsoletes:      ooobasis3.1-core03 < 3.3, ooobasis3.2-core03 < 3.3
80Obsoletes:      ooobasis3.1-core04 < 3.3, ooobasis3.2-core04 < 3.3
81Obsoletes:      ooobasis3.1-core05 < 3.3, ooobasis3.2-core05 < 3.3
82Obsoletes:      ooobasis3.1-core06 < 3.3, ooobasis3.2-core06 < 3.3
83Obsoletes:      ooobasis3.1-core07 < 3.3, ooobasis3.2-core07 < 3.3
84Obsoletes:      ooobasis3.1-base < 3.3, ooobasis3.2-base < 3.3
85Obsoletes:      ooobasis3.1-calc < 3.3, ooobasis3.2-calc < 3.3
86Obsoletes:      ooobasis3.1-draw < 3.3, ooobasis3.2-draw < 3.3
87Obsoletes:      ooobasis3.1-impress < 3.3, ooobasis3.2-impress < 3.3
88Obsoletes:      ooobasis3.1-math < 3.3, ooobasis3.2-math < 3.3
89Obsoletes:      ooobasis3.1-writer < 3.3, ooobasis3.2-writer < 3.3
90Obsoletes:      openoffice.org3-base < 3.3
91Obsoletes:      openoffice.org3-calc < 3.3
92Obsoletes:      openoffice.org3-draw < 3.3
93Obsoletes:      openoffice.org3-impress < 3.3
94Obsoletes:      openoffice.org3-writer < 3.3
95Obsoletes:      openoffice.org3-math < 3.3
96Obsoletes:      ooobasis3.1-gnome-integration < 3.3, ooobasis3.2-gnome-integration < 3.3
97Obsoletes:      ooobasis3.1-ja-binfilter < 3.3, ooobasis3.2-ja-binfilter < 3.3
98Obsoletes:      ooobasis3.1-binfilter < 3.3, ooobasis3.2-binfilter < 3.3
99Obsoletes:      ooobasis3.1-graphicfilter < 3.3, ooobasis3.2-graphicfilter < 3.3
100Obsoletes:      ooobasis3.1-javafilter < 3.3, ooobasis3.2-javafilter < 3.3
101Obsoletes:      ooobasis3.1-ooofonts < 3.3, ooobasis3.2-ooofonts < 3.3
102Obsoletes:      ooobasis3.1-pyuno < 3.3, ooobasis3.2-pyuno < 3.3
103Obsoletes:      ooobasis3.1-ooolinguistic < 3.3, ooobasis3.2-ooolinguistic < 3.3
104Obsoletes:      openoffice.org-ure <= 1.6.1
105Obsoletes:      openoffice.org3.1-freedesktop-menus < 3.3, openoffice.org3.2-freedesktop-menus < 3.3
106
107Obsoletes:      install-assist-Go-oo < 3.3
108
109Obsoletes:      libobasis3.3-core01 < 3.4
110Obsoletes:      libreoffice3-ure <= 1.7.0
111Obsoletes:      libreoffice3.3-freedesktop-menus < 3.4
112# Obsoletes:    libobasis3.4-core01 < 3.5
113# Obsoletes:    libreoffice3.4-ure < 3.5
114# Obsoletes:    libreoffice3.4-freedesktop-menus < 3.5
115
116Packager:       kazutaka, munepi
117
118%description
119LibreOffice is the free power-packed Open Source personal productivity
120suite for Windows, Macintosh and Linux, that gives you six feature-rich
121applications for all your document production and data processing needs:
122Writer, Calc, Impress, Draw, Math and Base.
123
124If you install this package, it automaticaly downloads
125required files to install %{pkgname}.
126And the downloaded files are automatically installed if
127installation is executed by apt-get command or synaptic
128package manager.
129
130%description -l ja
131LibreOffice は自由でかつオープンソースのオフィススイートです。
132Windows、Macintosh、Linux を始めとする多くのプラットフォームで動作します。
133文書の作成やデータの処理のお役に立ちます豊富な機能を備えた6つの
134アプリケーションを提供します:
135Writer、Calc、Impress、Draw、Math、Base です。
136
137このパッケージをインストールすると、自動的に %{pkgname}
138のインストールに必要な rpm ファイルをダウンロードします。
139また apt-get コマンドや synapticパッケージマネージャから実行
140した場合は、ダウンロードした rpm ファイルのインストールも自
141動的に行います。
142
143%posttrans
144#set -x
145## setup
146. /etc/self-build.conf
147tmp=$(mktemp -d ${TEMP_DIR}/%{name}.XXXXXX)
148QUEDIR=/var/cache/self-build
149[ ! -d ${QUEDIR} ] && %__mkdir_p ${QUEDIR}
150
151(cd ${tmp}
152    ## If exists cached tarballs, copy them into ${tmp}
153    if [ "${CACHE_DOWNLOADED_FILES}" = "yes" ]; then
154       for i in %{dlurl}; do
155           [ -f ${QUEDIR}/$(basename $i) ] && %__cp -af ${QUEDIR}/$(basename $i) ${tmp}; done
156    fi
157    ## download the official built tarballs
158    wget -N %{dlurl}
159
160    ## extract them
161    for i in %{dlurl}; do %__tar xf $(basename $i); done
162
163    ## copy including rpms
164    %__cp -af $(find -name "*.%{rpmarch}.rpm") ${QUEDIR}
165    %__cp -af $(find -name "*freedesktop-menus*.rpm") ${QUEDIR}
166
167    if [ "${CACHE_DOWNLOADED_FILES}" = "yes" ]; then
168       for i in %{dlurl}; do
169           [ -f ${QUEDIR}/$(basename $i) ] || %__cp -af $(basename $i) ${QUEDIR};
170       done
171    fi
172)
173%__rm -rf ${tmp}
174
175%files
176
177%changelog
178* Tue Jan 17 2012 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.5-1
179- new upstream release
180
181* Wed Nov  9 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.4-1
182- new upstream release
183
184* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.3-2
185- dropped Requires: libgail-gnome >= 1.8.6
186
187* Sat Sep 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.3-1
188- new upstream release
189
190* Tue Aug 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.2-1
191- new upstream release
192
193* Fri Jul 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.1-2
194- added Requires: java-1.6.0 <BTS:1168>
195
196* Wed Jul 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.1-1
197- new upstream release
198
199* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.4.0-1
200- new upstream release
201
202* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.3.2-1
203- initial build
Note: See TracBrowser for help on using the repository browser.