source: projects/specs/trunk/i/inn/inn-vl.spec @ 521

Revision 521, 19.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The InterNetNews (INN) system, an Usenet news server.
2Name: inn
3Version: 2.4.3
4Release: 0vl1
5License: GPL
6Group: System Environment/Daemons
7Source0: ftp://ftp.isc.org/isc/inn/inn-%{version}.tar.gz
8Source2: inn-default-distributions
9Source4: inn-cron-expire
10Source5: inn-cron-rnews
11Source7: inn-cron-nntpsend
12Source8: innd.init
13Source10: inn-faq.tar.gz
14Patch:  inn-2.4.3.rh.patch
15Patch2: inn-2.4.1.perl.patch
16Patch3: inn-2.4.1.headusage.patch
17Patch4: inn-2.4.1.pie.patch
18Patch6: inn-2.4.1.posix.patch
19Patch7: inn-2.4.3.warn.patch
20Patch8: inn-2.4.2-makedbz.patch
21
22Buildroot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: perl python db4-devel byacc pam-devel e2fsprogs-devel
24Prereq: /sbin/chkconfig, grep, coreutils, sed
25Requires: bash >= 2.0, cleanfeed, inews
26
27%description
28INN (InterNetNews) is a complete system for serving Usenet news and/or
29private newsfeeds.  INN includes innd, an NNTP (NetNews Transport
30Protocol) server, and nnrpd, a newsreader that is spawned for each
31client.  Both innd and nnrpd vary slightly from the NNTP protocol, but
32not in ways that are easily noticed.
33
34Install the inn package if you need a complete system for serving and
35reading Usenet news.  You may also need to install inn-devel, if you
36are going to use a separate program which interfaces to INN, like
37newsgate or tin.
38
39%package devel
40Summary: The INN (InterNetNews) library.
41Summary(ja): ¥¤¥ó¥¿¡¼¥Í¥Ã¥È¥Ë¥å¡¼¥¹¥é¥¤¥Ö¥é¥ê
42Group: Development/Libraries
43Requires: inn = %{version}
44
45%description devel
46The inn-devel package contains the INN (InterNetNews) library, which
47several programs that interface with INN need in order to work (for
48example, newsgate and tin).
49
50If you are installing a program which must interface with the INN news
51system, you should install inn-devel.
52
53%package -n inews
54Summary: Sends Usenet articles to a local news server for distribution.
55Group: Applications/Internet
56
57%description -n inews
58The inews program is used by some news programs (for example, inn and
59trn) to post Usenet news articles to local news servers.  Inews reads
60an article from a file or standard input, adds headers, performs some
61consistency checks and then sends the article to the local news server
62specified in the inn.conf file.
63
64Install inews if you need a program for posting Usenet articles to
65local news servers.
66
67%prep
68%setup  -q  -a 10
69%patch  -p1 -b .rh
70%patch2 -p1 -b .perl
71%patch3 -p1 -b .headusage
72%patch4 -p1 -b .pie
73%patch6 -p1 -b .posix
74%patch7 -p1 -b .warn
75%patch8 -p1 -b .makedbz
76
77perl -pi -e 's/LOCK_READ/LLOCK_READ/' `find . -type f`
78perl -pi -e 's/LOCK_WRITE/LLOCK_WRITE/' `find . -type f`
79
80%build
81export DEFINE_INN_FLAGS="-D_XOPEN_SOURCE=600 -D_BSD_SOURCE -DHAVE_ET_COM_ERR_H"
82
83%ifarch s390 s390x
84export CFLAGS="$RPM_OPT_FLAGS $DEFINE_INN_FLAGS -fPIC -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
85%else
86export CFLAGS="$RPM_OPT_FLAGS $DEFINE_INN_FLAGS -fpic -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
87%endif
88
89#export CFLAGS="$RPM_OPT_FLAGS -I/usr/include/db1"
90with_tmp_path=/var/lib/news/tmp ./configure --prefix=/usr/lib/news  \
91        --sysconfdir=/etc/news --mandir=%{_mandir} \
92        --with-log-dir=/var/log/news --with-spool-dir=/var/spool/news\
93        --with-db-dir=/var/lib/news --with-run-dir=/var/run/news \
94        --with-etc-dir=/etc/news --with-tmp-dir=/var/lib/news/tmp \
95        --with-perl --with-python --enable-shared --enable-uucp-rnews \
96        --enable-pgp-verify --with-sendmail=/usr/sbin/sendmail \
97        --with-news-user=news --with-news-group=news --with-news-master=news \
98        --enable-ipv6 \
99        %{_target_platform}
100
101# XXX don't include <db1/ndbm.h> to avoid linking with -ldb1.
102perl -pi -e 's/HAVE_DB1_NDBM_H/XXX_HAVE_DB1_NDBM_H/' ./include/config.h
103
104make
105
106%install
107rm -rf $RPM_BUILD_ROOT
108mkdir -p $RPM_BUILD_ROOT
109make install DESTDIR=$RPM_BUILD_ROOT
110
111#Shift libs to the right place
112if [ "/usr/lib" != "%{_libdir}" ]; then
113    mkdir -p $RPM_BUILD_ROOT%{_libdir}/news/lib
114    mv $RPM_BUILD_ROOT/usr/lib/news/lib/*.a $RPM_BUILD_ROOT%{_libdir}/news/lib
115fi
116
117# -- Install man pages needed by suck et al.
118mkdir -p $RPM_BUILD_ROOT/usr/include/inn
119for f in clibrary.h config.h dbz.h libinn.h storage.h
120do
121    install -c -m 0644 ./include/$f $RPM_BUILD_ROOT/usr/include/inn
122done
123for f in defines.h system.h
124do
125    install -c -m 0644 ./include/inn/$f $RPM_BUILD_ROOT/usr/include/inn
126done
127
128#for f in clibrary.h configdata.h config.h dbz.h libinn.h autoconfig.h storage.h
129#do
130#    install -c -m 0644 ./include/$f $RPM_BUILD_ROOT/usr/include/inn
131#done
132
133mkdir -p $RPM_BUILD_ROOT/etc
134mv $RPM_BUILD_ROOT/usr/lib/news/bin/rc.news $RPM_BUILD_ROOT/etc
135
136touch     $RPM_BUILD_ROOT/var/lib/news/subscriptions
137chmod 644 $RPM_BUILD_ROOT/var/lib/news/subscriptions
138
139install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/var/lib/news/distributions
140
141mkdir -p $RPM_BUILD_ROOT/etc/cron.{hourly,daily}
142install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.daily/inn-cron-expire
143install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.hourly/inn-cron-rnews
144install %{SOURCE7} $RPM_BUILD_ROOT/etc/cron.hourly/inn-cron-nntpsend
145
146mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
147install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/innd
148
149touch $RPM_BUILD_ROOT/var/lib/news/history
150#LD_LIBRARY_PATH=$RPM_BUILD_ROOT/usr/lib $RPM_BUILD_ROOT/usr/bin/makedbz -i \
151#       -f $RPM_BUILD_ROOT/var/lib/news/history
152#chmod 644 $RPM_BUILD_ROOT/var/lib/news/*
153
154cat > $RPM_BUILD_ROOT/etc/news/.profile <<EOF
155PATH=\$PATH:/usr/lib/news/bin
156export PATH
157EOF
158
159# we get this from cleanfeed
160rm -f $RPM_BUILD_ROOT/usr/lib/news/bin/filter/filter_innd.pl
161
162#Fix perms in sample directory to avoid bogus dependencies
163find samples -name "*.in" -exec chmod a-x {} \;
164
165mkdir -p $RPM_BUILD_ROOT/usr/bin
166ln -sf ../lib/news/bin/inews $RPM_BUILD_ROOT/usr/bin/inews
167ln -sf ../lib/news/bin/rnews $RPM_BUILD_ROOT/usr/bin/rnews
168
169#Build filelist
170rm -rf $RPM_BUILD_ROOT/usr/lib/news/include
171echo "%defattr(-,news,news)" > files.list
172find $RPM_BUILD_ROOT -type f -or -type l | \
173  sed -e "s|$RPM_BUILD_ROOT||g" | \
174  sed 's|^/etc/cron|%config(noreplace) %attr(-,root,root) &|' | \
175  sed 's|^/etc/rc.d|%config(noreplace) %attr(-,root,root) &|' | \
176  sed 's|^/etc|%config(noreplace) &|' | \
177  sed 's|^/etc/news|%config(noreplace) %attr(0640,news,news) &|' | \
178  sed 's|^/var/lib/news/|%config(noreplace) &|' | \
179  sed 's|.*innshellvar|%config &|' | \
180  sed 's|/var/log/news|%ghost &|' | \
181  sed 's|/usr/lib/news/bin/inndstart$|%attr(4550,root,news) /usr/lib/news/bin/inndstart|' | \
182  sed 's|/usr/lib/news/bin/startinnfeed$|%attr(4550,root,news) /usr/lib/news/bin/startinnfeed|' | \
183  sed 's|/usr/lib/news/bin/rnews$|%attr(4550,uucp,news) /usr/lib/news/bin/rnews|' > files.list
184#  echo "/usr/lib/news/bin/filter/*.pyc" >> files.list
185#  echo "/usr/lib/news/bin/filter/*.pyo" >> files.list
186  (echo "%defattr(-,news,news)" ; grep -v inews files.list | \
187  egrep -v "\.(h|so|a|la)$" | \
188  grep -v "news/inn.conf" | \
189  grep -v "/man/") > files.main
190  echo "%defattr(-,root,root)" > files.devel
191  egrep "\.(h|so|a|la)$" files.list >> files.devel
192
193%clean
194rm -rf $RPM_BUILD_ROOT
195rm -f files.list files.main files.devel files.inews
196
197%post
198/sbin/chkconfig --add innd
199su news -c '/usr/lib/news/bin/makedbz -i -o'
200
201umask 002
202touch /var/log/news/news.notice
203touch /var/log/news/news.crit
204touch /var/log/news/news.err
205chown -R news:news /var/log/news*
206
207%triggerpostun -- inn < 2.3.0
208service innd stop > /dev/null 2>&1
209exit 0
210
211%triggerin -- sysklogd
212if [ -f /etc/syslog.conf ]; then
213  if ! grep -q INN /etc/syslog.conf; then
214    sed 's/mail.none;/mail.none;news.none;/' < /etc/syslog.conf > /etc/syslog.conf.inn
215    mv /etc/syslog.conf.inn /etc/syslog.conf
216
217    echo '' \
218       >> /etc/syslog.conf
219    echo '#' \
220       >> /etc/syslog.conf
221    echo '# INN' \
222       >> /etc/syslog.conf
223    echo '#' \
224       >> /etc/syslog.conf
225    echo 'news.=crit                                        /var/log/news/news.crit'   >> /etc/syslog.conf
226    echo 'news.=err                                         /var/log/news/news.err'    >> /etc/syslog.conf
227    echo 'news.notice                                       /var/log/news/news.notice' >> /etc/syslog.conf
228    fi
229  if [ -f /var/run/syslog.pid ]; then
230    kill -HUP `cat /var/run/syslog.pid` 2> /dev/null ||:
231  fi
232fi
233
234%preun
235if [ $1 = 0 ]; then
236    service innd stop > /dev/null 2>&1
237    /sbin/chkconfig --del innd
238    if [ -f /var/lib/news/history.dir ]; then
239       rm -f /var/lib/news/history.*
240    fi
241fi
242
243%postun
244if [ "$1" -ge 1 ]; then
245    service innd condrestart > /dev/null 2>&1
246fi
247exit 0
248
249%files -f files.main
250%defattr(-,news,news)
251%dir /usr/lib/news/bin/control
252%dir /usr/lib/news/bin/filter
253%dir /usr/lib/news/bin/rnews.libexec
254%dir /usr/lib/news/bin/auth
255%dir /etc/news
256%dir /var/spool/news
257%dir /var/spool/news/archive
258%dir /var/spool/news/articles
259%dir /var/spool/news/incoming
260%dir /var/spool/news/incoming/bad
261%dir /var/spool/news/innfeed
262%dir /var/spool/news/outgoing
263%dir /var/spool/news/overview
264%dir /var/log/news
265%dir /var/log/news/OLD
266%dir /var/lib/news
267%dir /var/lib/news/tmp
268%dir /var/run/news
269%defattr(-,root,root)
270%{_mandir}/man1/c*.1.gz
271%{_mandir}/man1/f*.1.gz
272%{_mandir}/man1/g*.1.gz
273%{_mandir}/man1/inn*.1.gz
274%{_mandir}/man1/n*.1.gz
275%{_mandir}/man1/p*.1.gz
276%{_mandir}/man1/r*.1.gz
277%{_mandir}/man1/s*.1.gz
278%{_mandir}/man[58]/*
279%doc NEWS README* ChangeLog CONTRIBUTORS LICENSE INSTALL
280%doc %dir samples
281
282%files devel -f files.devel
283%defattr(-,root,root)
284%{_mandir}/man3/*
285
286%files -n inews
287%defattr(-,root,root)
288%config(noreplace) /etc/news/inn.conf
289/usr/bin/inews
290%attr(0755,root,root) /usr/lib/news/bin/inews
291%{_mandir}/man1/inews*
292
293%changelog
294* Mon Oct 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.4.3-7vl1
295- s/Copyright/License/
296- updated to 2.4.3 based on FC package
297- rebuilt with new toolchain
298- updated BuildRequires and Requires
299- changed inews Group to Applications/Internet
300
301* Sat Aug 18 2001 <sagami@vinelinux.org>
302- 2.3.2-5vl1: sync with 2.3.2-5 from 2.3.1-2vl1 :-)
303- changed back Requires: bash
304
305* Mon Jul 02 2001 Shoji Matsumoto <shom@vinelinux.org>
306- rebuild for Vine ( from RH7.1 )
307- change Requires: bash
308
309* Wed Feb 14 2001 Florian La Roche <Florian.LaRoche@redhat.de>
310- add startup script patch by kevin@labsysgrp.com #27421
311- inews subpackage does not depend on inn anymore #24439
312- fix reload and make some cleanups to the startup script #18076
313
314* Wed Feb 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
315- add a "exit 0" to the postun script
316
317* Wed Jan 24 2001 Florian La Roche <Florian.LaRoche@redhat.de>
318- update to 2.3.1
319- do not use --enable-tagged-hash
320- move tmp dir to /var/lib/news/tmp
321- add more docu
322- do not call "strip" directly
323- remove some of the default files as the ones in INN are ok
324- do not req /etc/init.d
325- do not attempt an automatic update from previous versions as
326  we have to deal with different storage methods
327- prepare startup script for translations
328- add minimal check into startup for a history file
329
330* Mon Jan 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
331- innreport had wrong perms
332- files for the cron-jobs must be owned by root:root
333
334* Tue Aug 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
335- remove cleanfeed sources
336
337* Mon Jul 24 2000 Florian La Roche <Florian.LaRoche@redhat.de>
338- fix some perms
339
340* Mon Jul 24 2000 Florian La Roche <Florian.LaRoche@redhat.de>
341- update to 2.2.3
342- fixed many perms
343- cleaned up complete build process
344
345* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
346- move initscript back
347
348* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
349- automatic rebuild
350
351* Sun Jul 10 2000 Bill Nottingham <notting@redhat.com>
352- add fix for the verifycancels problem fron Russ Allbery
353- turn them off anyways
354- fix perms on inews
355
356* Sat Jul  8 2000 Florian La Roche <Florian.LaRoche@redhat.com>
357- prereq init.d
358
359* Tue Jun 27 2000 Than Ngo <than@redhat.de>
360- /etc/rc.d/init.d -> /etc/init.d
361- fix initscript
362
363* Sun Jun 25 2000 Matt Wilson <msw@redhat.com>
364- defattr root
365
366* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
367- fix up some issues with our new gcc compiler (patch 6)
368- don't do chown in the install script so we can build as nonroot
369
370* Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
371- FHS mandir
372
373* Tue May 23 2000 Florian La Roche <Florian.LaRoche@redhat.com>
374- add inn-2.2.2-rnews.patch which is also accepted in current cvs
375
376* Mon May 22 2000 Florian La Roche <Florian.LaRoche@redhat.com>
377- fix stupid bug in rnews cronjob
378- enable controlchan in default newsfeeds config
379- run "rnews -U" hourly instead of daily
380
381* Fri May 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
382- add bug-fix to batcher from cvs version
383- "su news" before starting rnews from cron
384
385* Mon Apr  3 2000 Bill Notttingham <notting@redhat.com>
386- arrgh, there is no /usr/lib/news anymore. (#10536)
387- pppatch ppport for ppproper ppperl
388
389* Thu Mar 02 2000 Cristian Gafton <gafton@redhat.com>
390- remove useless filter_innd.pl so that we will get the cleanfeed one
391  instead
392
393* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
394- handle compressed manpages
395- other minor fixes
396
397* Tue Dec 14 1999 Bill Nottingham <notting@redhat.com>
398- update to 2.2.2
399
400* Sun Aug 29 1999 Cristian Gafton <gafton@redhat.com>
401- version 2.2.1 to fix security problems in previous inn versions
402- add the faq back to the source rpm
403
404* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
405- initscript munging
406
407* Tue Jun 22 1999 Jeff Johnson <jbj@redhat.com>
408- fix syntax error in reload (#3636).
409
410* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
411- don't run by default
412
413* Sun Jun 13 1999 Jeff Johnson <jbj@redhat.com>
414- mark /var/lib/news/* as %config(noreplace) (#3425)
415
416* Thu Jun 10 1999 Dale Lovelace <dale@redhat.com>
417- change su news to su - news (#3331)
418
419* Wed Jun  2 1999 Jeff Johsnon <jbj@redhat.com>
420- complete trn->inews->inn dependency (#2646)
421- use f_bsize rather than f_frsize when computing blocks avail (#3154).
422- increase client timeout to 30 mins (=1800) (#2833).
423- add missing includes to inn-devel (#2904).
424
425* Mon May 31 1999 Jeff Johnson <jbj@redhat.com>
426- fix owner and permissions on /var/lib/news/.news.daily (#2354).
427
428* Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
429- fixed paths in cron jobs, check to see that innd is enabled
430
431* Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
432- path to makehistory corrected.
433
434* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
435- fixed permissions on rnews for uucp
436
437* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
438- make sure init scripts get packaged up, fix other minor bugs
439- major fixups to innd.conf for denial of service attacks, sanity, etc.
440- make sure history gets rebuilt in an upgrade (added to post section)
441- many thanks go out to mmchen@minn.net for these suggestions.
442
443* Fri Feb 19 1999 Cristian Gafton <gafton@redhat.com>
444- prereq all the stuff we need in the postinstall scripts
445
446* Sat Feb  6 1999 Bill Nottingham <notting@redhat.com>
447- strip -x bits from docs/samples (bogus dependencies)
448
449* Thu Sep 03 1998 Cristian Gafton <gafton@redhat.com>
450- updated to version 2.1
451
452* Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
453- innd.init chkconfig entry was incorrect (problem #855)
454
455* Tue Jun 30 1998 Jeff Johnson <jbj@redhat.com>
456- susbsys name must be identical to script name (problem #700)
457
458* Mon Jun 29 1998 Bryan C. Andregg <bandregg@redhat.com>
459- fixed startinnfeed paths
460
461* Tue May 05 1998 Prospector System <bugs@redhat.com>
462- translations modified for de, fr, tr
463
464* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
465- enhanced initscript
466
467* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
468- fixed innfeed patched to be perl-version independent
469
470* Wed Apr 15 1998 Bryan C. Andregg <bandregg@redhat.com>
471- fixed sfnet.* entries in control.ctl
472
473* Mon Apr 13 1998 Bryan C. Andregg <bandregg@redhat.com>
474- moved cleanfeed to its own package
475
476* Thu Apr 09 1998 Bryan C. Andregg <bandregg@redhat.com>
477- added insync patches
478- added cleanfeed
479- added innfeed
480
481* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
482- abuse buildroot to simplify the file list
483- built against Manhattan
484
485* Tue Mar 24 1998 Bryan C. Andregg <bandregg@redhat.com>
486- updated to inn 1.7.2
487- Added REMEMBER_TRASH and Poison patch
488
489* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
490- updated to inn 1.7
491- added chkconfig support to the initscripts
492- orginally released as release 2, leving release 1 if a 4.2.x upgrade
493  is ever necessary
494- don't start it in any runlevel (by default)
495- added inndcomm.h
496
497* Thu Oct 09 1997 Erik Troan <ewt@redhat.com>
498- built against glibc
499
500* Tue Aug 05 1997 Elliot Lee <sopwith@redhat.com>
501- Applied the 1.5.1sec and 1.5.1sec2 patches
502- Applied 3 more unoff patches.
503- Removed insanity in /etc/cron.hourly/inn-cron-nntpsend, it now
504  just runs nntpsend as news.
505
506* Wed Apr 02 1997 Erik Troan <ewt@redhat.com>
507- Patch from CERT for sh exploit.
508- Changed /usr/ucb/compress reference to /usr/bin/compress
509
510* Mon Mar 17 1997 Erik Troan <ewt@redhat.com>
511- Removed inews.1 from main inn package (it's still in the inews packaeg)
512- Fixed references to /usr/spoo in sendbatch
513- added "-s -" to crosspost line in newsfeeds
514- /var/lib/news/active.time is now created as news.news
515- /etc/news/nnrp.access and /etc/news/nntpsend.ctl are mode 0440
516- included a better rc script which does a better job of shutting down news
517- updated /etc/rc.d/rc.news output look like the rest of our initscripts
518- hacked sendbatch df stuff to work on machines w/o a separate /var/spool/news
519
520* Tue Mar 11 1997 Erik Troan <ewt@redhat.com>
521- added chmod to make sure rnews is 755
522- /etc/news/nnrp.access and /etc/news/nntpsend.ctl are news.news not root.news
523  or root.root
524- install an empty /var/lib/news/.news.daily as a config file
525- added dbz/dbz.h as /usr/include/dbz.h
526- added /usr/bin/inews link to /usr/lib/news/inews
527- changed INEWS_PATH to DONT -- I'm not sure this is right though
528- turned off MMAP_SYNC
529- added a ton of man pages which were missing from the filelist
530- increased CLIENT_TIMEOUT to (30 * 60)
531- added a postinstall to create /var/lib/news/active.times if it doesn't
532  already exist
533- patched rc.news to start inn w/ -L flag
534- pulled news.init into a separate source file rather then creating it through
535  a patch
536- added /etc/rc.d/rc5.d/S95news to the file list
537- remove pid files from /var/lock/news/* on shutdown
538- use /var/lock/subsys/news rather then /var/lock/subsys/inn or things
539  don't shutdown properly
540
541* Mon Mar 10 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
542- changed devel package description to include tin.
543- the devel package missed libinn.h
544- moved libinn.3 man-page to the devel package
545- moved changelog up
546- in %post some echo statements were messed up. if we put the redirection
547  staements in a different line than the echo command we really should use
548  a backslash to thell the shell :-)
549- in %install a chmod line referenced the same directory twice.
550- changed inn-1.5.1-redhat.patch: The patch for news.daily had a side effect.
551  as EXPIREOVERFLAGS was set to '-a', expireover would break if there were
552  articles to be removed, as '-a' can't be used if '-z' is specified...
553  Now there is a separate 'eval expireover -a' after the first eval. Dirty
554  but works.
555
556* Wed Feb 26 1997 Erik Troan <ewt@redhat.com>
557- Added a /usr/bin/rnews symlink to /usr/lib/news/rnews as other programs like
558  to use it.
559
560* Tue Feb 25 1997 Elliot Lee <sopwith@cuc.edu>
561- Fixed rnews path in /etc/cron.daily/inn-cron-rnews
562- Added overview! and crosspost lines to /etc/news/newsfeeds
563- Fixed nntpsend.ctl path in /usr/lib/news/bin/nntpsend, and set a saner
564  nntpsend.ctl config file.
565- Added automated inn.conf 'server: ' line creation in %post
566- Added misc. patches from ftp.isc.org/isc/inn/unoff-patches/1.5
567- Removed -lelf from config.data LIBS
568- Made RPM_OPT_FLAGS work.
569- Bug in rpm meant that putting %post after %files made it not run. Moved
570  %post up.
571- Added /etc/cron.hourly/inn-cron-nntpsend to send news every hour.
572- Fixed most of the misc permissions/ownership stuff that inncheck
573  complained about.
574
575* Wed Feb 19 1997 Erik Troan <ewt@redhat.com>
576- Incorporated changes from <drdisk@tilx01.ti.fht-esslingen.de> which fixed
577  some paths and restored the cron jobs which disappeared in the 1.5.1
578  switch. He also made the whole thing use a buildroot and added some files
579  which were missing from the file list.
Note: See TracBrowser for help on using the repository browser.