source: projects/specs/trunk/i/inkscape/inkscape-vl.spec @ 11698

Revision 11698, 8.7 KB checked in by ara_t, 6 years ago (diff)

inkscape: update to 0.92.3

Line 
1Name:           inkscape
2Summary:        A Vector Drawing Application
3Summary(ja):    ベクター描画アプリケーション
4Version:        0.92.3
5Release:        1%{?_dist_release}
6
7Group:          Applications/Graphics
8License:        GPLv2+
9URL:            https://launchpad.net/inkscape
10
11Source0:        https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}.tar.bz2
12
13# # to fix compile error with poppler>=0.58
14# Patch1000:  poppler-0.58.x.patch
15# Patch1001:  poppler-0.58.x-autotools.patch
16
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gtk2-devel >= 2.8.0
20BuildRequires: gnome-vfs2-devel >= 2.0
21BuildRequires: libxml2-devel >= 2.6.11
22BuildRequires: libxslt-devel >= 1.0.15
23BuildRequires: gc-devel >= 6.4
24BuildRequires: dbus-glib-devel
25BuildRequires: libsigc++-devel >= 2.0.12
26BuildRequires: gtkmm2-devel >= 2.8.0
27BuildRequires: libpng-devel >= 1.2.0
28BuildRequires: libwpg-devel
29BuildRequires: libexif-devel
30BuildRequires: libjpeg-turbo-devel
31BuildRequires: perl-XML-Parser
32BuildRequires: lcms2-devel
33BuildRequires: poppler-devel >= 0.14.2
34BuildRequires: pango-devel, cairo-devel
35BuildRequires: gsl-devel
36BuildRequires: libboost-devel
37BuildRequires: popt-devel
38BuildRequires: ImageMagick-c++-devel
39BuildRequires: dos2unix
40BuildRequires: automake autoconf
41Requires:      python-lxml
42Requires:      perl-XML-RegExp
43Requires:      perl-XML-DOM
44Requires:      perl-XML-XQL
45# the package requires libperl.so, so it also has to require this:
46Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
47
48# Filter out perl requires and provides
49# XXX: For now _all_
50%global __perl_provides %{nil}
51%global __perl_requires %{nil}
52
53Vendor: Project Vine
54Distribution: Vine Linux
55
56%description
57Inkscape is a SVG based generic vector-drawing program for
58Linux/Unix/Windows/Mac.
59
60%description -l ja
61Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
62Linux/Unix/Windows/Mac で動作します。
63
64%prep
65%setup -q -n %{name}-%{version}
66
67# %patch1000 -p1
68# %patch1001 -p1
69
70# https://bugs.launchpad.net/inkscape/+bug/314381
71# A couple of files have executable bits set,
72# despite not being executable
73find . -name '*.cpp' | xargs chmod -x
74find . -name '*.h' | xargs chmod -x
75find share/extensions -name '*.py' | xargs chmod -x
76
77# Fix end of line encodings
78dos2unix -k -q share/extensions/*.py
79
80%build
81./autogen.sh
82
83export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
84%configure \
85    --with-python \
86    --with-gnome-vfs \
87    --with-inkjar \
88    --enable-lcms2 \
89    --enable-poppler-cairo \
90        --disable-strict-build
91
92make %{?_smp_mflags}
93
94%install
95rm -rf %{buildroot}
96
97make install DESTDIR=$RPM_BUILD_ROOT
98
99rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
100
101%find_lang %{name}
102
103%clean
104rm -rf %{buildroot}
105
106%post
107/sbin/ldconfig
108touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
109
110%postun
111if [ $1 -eq 0 ] ; then
112    update-desktop-database -q &> /dev/null
113    touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
114    gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
115fi
116
117%posttrans
118update-desktop-database -q &> /dev/null
119gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
120
121
122%files -f %{name}.lang
123%defattr(-, root, root)
124%doc AUTHORS COPYING ChangeLog NEWS README
125%{_bindir}/inkscape
126%{_bindir}/inkview
127%{_datadir}/appdata/inkscape.appdata.xml
128%{_datadir}/applications/*.desktop
129%{_datadir}/icons/hicolor/*
130%{_datadir}/inkscape
131%{_mandir}/man1/*
132%{_mandir}/*/man1/*
133
134%changelog
135* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
136- updated to 0.92.3
137- drop Patch1000,1001
138
139* Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
140- updated to 0.92.2
141
142* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
143- rebuild with gcc-5.4.0
144
145* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
146- rebuild with poppler-0.43.0
147
148* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
149- update to 0.91
150- remove old patches
151- add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
152
153* Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
154- rebuild with ImageMagick-6.9.1.1
155
156* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
157- rebuilt with libwpd 0.3.0
158- added Patch14 to build with libwpd 0.3.0
159
160* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
161- rebuild with poppler-0.26.2
162
163* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
164- new upstream release
165- add BuildRequires: libwpg-devel
166- remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
167
168* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
169- rebuild with poppler-0.24.5
170- add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
171
172* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
173- rebuild with ImageMagick-6.8.7.5
174
175* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
176- rebuild with poppler-0.24.2
177
178* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
179- rebuild with ImageMagick-6.8.6.8
180
181* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
182- new upstream release
183- remove Patch0 (inkscape-0.48.2-poppler_020.patch)
184
185* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
186- rebuild with poppler-0.20.4
187- add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
188- change BuildRequires: lcms2-devel instead of lcms-devel
189
190* Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
191- new upstream release
192
193* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
194- rebuild with ImageMagick-6.7.5.10
195
196* Sat Feb  4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
197- new upstream release
198
199* Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
200- add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
201
202* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
203- new upstream release
204- built with poppler-0.16.3
205
206* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
207- rebuild with poppler-0.14.2
208- add BuildRequires: popt-devel, ImageMagick-c++-devel
209
210* Sun Oct  3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
211- new upstream release
212- rebuilt with ImageMagick-6.6.4.8
213
214* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
215- added Patch0 for building with poppler-0.12.2+
216- rebuilt with new toolchain and ImageMagick-6.6.1.5
217- removed BR: libgnomeprint-devel, libgnomeprintui-devel
218
219* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
220- rebuild with poppler-0.12.1
221
222* Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
223- new upstream release
224- add BR: libboost-devel
225
226* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
227- update to 0.47pre2
228- drop obsolete patches
229- add BR: gsl-devel
230
231* Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
232- rebuild with poppler-0.10.2
233
234* Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
235- add Patch[1-6]
236
237* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
238- added inkscape-0.46-poppler-0.8.3.patch
239- spec in utf-8
240- added option %%{?_smp_mflags} at make
241
242* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
243- new upstream release
244
245* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
246- rebuild with new environment/toolchain
247
248* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
249- new upstream release
250
251* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
252- add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
253- update required version of gtk2-devel
254
255* Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
256- new upstream release
257
258* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
259- new upstream release
260
261* Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
262- new upstream release
263
264* Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
265- new upstream release
266
267* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
268- new upstream release
269
270* Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
271- new upstream release
272
273* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
274- new upstream release
275- add Japanese summary and description
276- fixed dependancy of libsigc++12 to libsigc++ >= 2.0
277
278* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
279- fixed dependancy of libsigc++ to libsigc++12
280- fixed %files section
281
282* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
283- rebuild for Vine Linux
284- s/Copyright/License/
285- added Requires and BuildRequires
286
287* Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
288- Removing _libdir and TODO, updating description
289
290* Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
291- Fix up the spec file for current release
292
293* Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
294- Update to 0.2.6
295
296* Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
297- Update to 0.2.5
298- Changed SPEC to benefit from macros
Note: See TracBrowser for help on using the repository browser.