source: projects/specs/trunk/i/inkscape/inkscape-vl.spec @ 9791

Revision 9791, 8.1 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1Name:           inkscape
2Summary:        A Vector Drawing Application
3Summary(ja):    ベクター描画アプリケーション
4Version:        0.91
5Release:        1%{?_dist_release}
6
7Group:          Applications/Graphics
8License:        GPLv2+
9URL:            https://launchpad.net/inkscape
10
11Source0:        https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gtk2-devel >= 2.8.0
15BuildRequires: gnome-vfs2-devel >= 2.0
16BuildRequires: libxml2-devel >= 2.6.11
17BuildRequires: libxslt-devel >= 1.0.15
18BuildRequires: gc-devel >= 6.4
19BuildRequires: dbus-glib-devel
20BuildRequires: libsigc++-devel >= 2.0.12
21BuildRequires: gtkmm2-devel >= 2.8.0
22BuildRequires: libpng-devel >= 1.2.0
23BuildRequires: libwpg-devel
24BuildRequires: libexif-devel
25BuildRequires: libjpeg-turbo-devel
26BuildRequires: perl-XML-Parser
27BuildRequires: lcms2-devel
28BuildRequires: poppler-devel >= 0.14.2
29BuildRequires: pango-devel, cairo-devel
30BuildRequires: gsl-devel
31BuildRequires: libboost-devel
32BuildRequires: popt-devel
33BuildRequires: ImageMagick-c++-devel
34BuildRequires: dos2unix
35BuildRequires: automake autoconf
36Requires:      python-lxml
37Requires:      perl-XML-RegExp
38Requires:      perl-XML-DOM
39Requires:      perl-XML-XQL
40# the package requires libperl.so, so it also has to require this:
41Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
42
43# Filter out perl requires and provides
44# XXX: For now _all_
45%global __perl_provides %{nil}
46%global __perl_requires %{nil}
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52Inkscape is a SVG based generic vector-drawing program for
53Linux/Unix/Windows/Mac.
54
55%description -l ja
56Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
57Linux/Unix/Windows/Mac で動作します。
58
59%prep
60%setup -q -n %{name}-%{version}
61
62# https://bugs.launchpad.net/inkscape/+bug/314381
63# A couple of files have executable bits set,
64# despite not being executable
65find . -name '*.cpp' | xargs chmod -x
66find . -name '*.h' | xargs chmod -x
67find share/extensions -name '*.py' | xargs chmod -x
68
69# Fix end of line encodings
70dos2unix -k -q share/extensions/*.py
71
72%build
73export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
74%configure \
75    --with-python \
76    --with-gnome-vfs \
77    --with-inkjar \
78    --enable-lcms2 \
79    --enable-poppler-cairo \
80        --disable-strict-build
81
82make %{?_smp_mflags}
83
84%install
85rm -rf %{buildroot}
86
87make install DESTDIR=$RPM_BUILD_ROOT
88
89rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
90
91%find_lang %{name}
92
93%clean
94rm -rf %{buildroot}
95
96%post
97/sbin/ldconfig
98touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
99
100%postun
101if [ $1 -eq 0 ] ; then
102    update-desktop-database -q &> /dev/null
103    touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
104    gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
105fi
106
107%posttrans
108update-desktop-database -q &> /dev/null
109gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
110
111
112%files -f %{name}.lang
113%defattr(-, root, root)
114%doc AUTHORS COPYING ChangeLog NEWS README
115%{_bindir}/inkscape
116%{_bindir}/inkview
117%{_datadir}/applications/*.desktop
118%{_datadir}/icons/hicolor/*
119%{_datadir}/inkscape
120%{_mandir}/man1/*
121%{_mandir}/*/man1/*
122
123%changelog
124* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
125- update to 0.91
126- remove old patches
127- add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
128
129* Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
130- rebuild with ImageMagick-6.9.1.1
131
132* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
133- rebuilt with libwpd 0.3.0
134- added Patch14 to build with libwpd 0.3.0
135
136* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
137- rebuild with poppler-0.26.2
138
139* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
140- new upstream release
141- add BuildRequires: libwpg-devel
142- remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
143
144* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
145- rebuild with poppler-0.24.5
146- add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
147
148* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
149- rebuild with ImageMagick-6.8.7.5
150
151* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
152- rebuild with poppler-0.24.2
153
154* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
155- rebuild with ImageMagick-6.8.6.8
156
157* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
158- new upstream release
159- remove Patch0 (inkscape-0.48.2-poppler_020.patch)
160
161* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
162- rebuild with poppler-0.20.4
163- add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
164- change BuildRequires: lcms2-devel instead of lcms-devel
165
166* Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
167- new upstream release
168
169* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
170- rebuild with ImageMagick-6.7.5.10
171
172* Sat Feb  4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
173- new upstream release
174
175* Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
176- add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
177
178* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
179- new upstream release
180- built with poppler-0.16.3
181
182* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
183- rebuild with poppler-0.14.2
184- add BuildRequires: popt-devel, ImageMagick-c++-devel
185
186* Sun Oct  3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
187- new upstream release
188- rebuilt with ImageMagick-6.6.4.8
189
190* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
191- added Patch0 for building with poppler-0.12.2+
192- rebuilt with new toolchain and ImageMagick-6.6.1.5
193- removed BR: libgnomeprint-devel, libgnomeprintui-devel
194
195* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
196- rebuild with poppler-0.12.1
197
198* Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
199- new upstream release
200- add BR: libboost-devel
201
202* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
203- update to 0.47pre2
204- drop obsolete patches
205- add BR: gsl-devel
206
207* Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
208- rebuild with poppler-0.10.2
209
210* Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
211- add Patch[1-6]
212
213* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
214- added inkscape-0.46-poppler-0.8.3.patch
215- spec in utf-8
216- added option %%{?_smp_mflags} at make
217
218* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
219- new upstream release
220
221* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
222- rebuild with new environment/toolchain
223
224* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
225- new upstream release
226
227* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
228- add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
229- update required version of gtk2-devel
230
231* Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
232- new upstream release
233
234* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
235- new upstream release
236
237* Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
238- new upstream release
239
240* Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
241- new upstream release
242
243* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
244- new upstream release
245
246* Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
247- new upstream release
248
249* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
250- new upstream release
251- add Japanese summary and description
252- fixed dependancy of libsigc++12 to libsigc++ >= 2.0
253
254* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
255- fixed dependancy of libsigc++ to libsigc++12
256- fixed %files section
257
258* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
259- rebuild for Vine Linux
260- s/Copyright/License/
261- added Requires and BuildRequires
262
263* Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
264- Removing _libdir and TODO, updating description
265
266* Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
267- Fix up the spec file for current release
268
269* Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
270- Update to 0.2.6
271
272* Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
273- Update to 0.2.5
274- Changed SPEC to benefit from macros
Note: See TracBrowser for help on using the repository browser.