source: projects/specs/trunk/i/inkscape/inkscape-vl.spec @ 12129

Revision 12129, 8.8 KB checked in by ara_t, 5 years ago (diff)

inkscape: update to 0.92.4

RevLine 
[12129]1%define filever  A6N0YOn
[1987]2
[12129]3Name:     inkscape
4Summary:  A Vector Drawing Application
5Summary(ja):  ベクター描画アプリケーション
6Version:  0.92.4
7Release:  1%{?_dist_release}
[521]8
[12129]9Group:    Applications/Graphics
10License:  GPLv2+
11URL:      https://launchpad.net/inkscape
[941]12
[12129]13Source0:  https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}_%{filever}.tar.bz2
14
[11698]15# # to fix compile error with poppler>=0.58
16# Patch1000:  poppler-0.58.x.patch
17# Patch1001:  poppler-0.58.x-autotools.patch
[11313]18
19
[12129]20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
[521]22BuildRequires: gtk2-devel >= 2.8.0
[9791]23BuildRequires: gnome-vfs2-devel >= 2.0
[521]24BuildRequires: libxml2-devel >= 2.6.11
25BuildRequires: libxslt-devel >= 1.0.15
26BuildRequires: gc-devel >= 6.4
[9791]27BuildRequires: dbus-glib-devel
[521]28BuildRequires: libsigc++-devel >= 2.0.12
[9259]29BuildRequires: gtkmm2-devel >= 2.8.0
[521]30BuildRequires: libpng-devel >= 1.2.0
[8721]31BuildRequires: libwpg-devel
[9791]32BuildRequires: libexif-devel
33BuildRequires: libjpeg-turbo-devel
[12129]34BuildRequires: perl-XML-Parser
[6890]35BuildRequires: lcms2-devel
[2041]36BuildRequires: poppler-devel >= 0.14.2
[521]37BuildRequires: pango-devel, cairo-devel
38BuildRequires: gsl-devel
39BuildRequires: libboost-devel
[2041]40BuildRequires: popt-devel
41BuildRequires: ImageMagick-c++-devel
[9259]42BuildRequires: dos2unix
[12129]43BuildRequires: automake autoconf
44
[3965]45Requires:      python-lxml
46Requires:      perl-XML-RegExp
47Requires:      perl-XML-DOM
48Requires:      perl-XML-XQL
[9259]49# the package requires libperl.so, so it also has to require this:
50Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
[521]51
[9259]52# Filter out perl requires and provides
53# XXX: For now _all_
54%global __perl_provides %{nil}
55%global __perl_requires %{nil}
56
[7756]57Vendor: Project Vine
58Distribution: Vine Linux
59
[521]60%description
61Inkscape is a SVG based generic vector-drawing program for
62Linux/Unix/Windows/Mac.
63
64%description -l ja
65Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
66Linux/Unix/Windows/Mac で動作します。
67
68%prep
69%setup -q -n %{name}-%{version}
70
[11698]71# %patch1000 -p1
72# %patch1001 -p1
[11313]73
[9259]74# https://bugs.launchpad.net/inkscape/+bug/314381
75# A couple of files have executable bits set,
76# despite not being executable
77find . -name '*.cpp' | xargs chmod -x
78find . -name '*.h' | xargs chmod -x
79find share/extensions -name '*.py' | xargs chmod -x
80
81# Fix end of line encodings
82dos2unix -k -q share/extensions/*.py
83
[521]84%build
[11313]85./autogen.sh
86
[9791]87export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
[521]88%configure \
[941]89    --with-gnome-vfs \
90    --with-inkjar \
[9791]91    --enable-poppler-cairo \
[12129]92    --disable-strict-build
[521]93
94make %{?_smp_mflags}
95
96%install
97rm -rf %{buildroot}
[1987]98
[6890]99make install DESTDIR=$RPM_BUILD_ROOT
[521]100
[1987]101rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
102
[521]103%find_lang %{name}
104
105%clean
106rm -rf %{buildroot}
107
[1987]108%post
109/sbin/ldconfig
110touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
111
112%postun
113if [ $1 -eq 0 ] ; then
114    update-desktop-database -q &> /dev/null
115    touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
116    gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
117fi
118
119%posttrans
120update-desktop-database -q &> /dev/null
121gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
122
123
[521]124%files -f %{name}.lang
125%defattr(-, root, root)
126%doc AUTHORS COPYING ChangeLog NEWS README
127%{_bindir}/inkscape
128%{_bindir}/inkview
[11313]129%{_datadir}/appdata/inkscape.appdata.xml
[521]130%{_datadir}/applications/*.desktop
[1987]131%{_datadir}/icons/hicolor/*
[521]132%{_datadir}/inkscape
133%{_mandir}/man1/*
[6011]134%{_mandir}/*/man1/*
[521]135
[12129]136
[521]137%changelog
[12129]138* Mon May 20 2019 Toshiaki Ara <ara_t@384.jp> 0.92.3-2
139- update to 0.92.4
140- drop unrecognized options: --with-python, --enable-lcms2
141
[11698]142* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
143- updated to 0.92.3
144- drop Patch1000,1001
145
[11313]146* Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
[11698]147- updated to 0.92.2
[11313]148
[10413]149* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
150- rebuild with gcc-5.4.0
151
[10266]152* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
153- rebuild with poppler-0.43.0
154
[9791]155* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
156- update to 0.91
157- remove old patches
158- add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
159
[9508]160* Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
161- rebuild with ImageMagick-6.9.1.1
162
[9259]163* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
164- rebuilt with libwpd 0.3.0
165- added Patch14 to build with libwpd 0.3.0
166
[8771]167* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
168- rebuild with poppler-0.26.2
169
[8721]170* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
171- new upstream release
172- add BuildRequires: libwpg-devel
173- remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
174
[8406]175* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
176- rebuild with poppler-0.24.5
177- add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
178
[8011]179* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
180- rebuild with ImageMagick-6.8.7.5
181
[7938]182* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
183- rebuild with poppler-0.24.2
184
[7766]185* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
186- rebuild with ImageMagick-6.8.6.8
187
[7756]188* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
189- new upstream release
190- remove Patch0 (inkscape-0.48.2-poppler_020.patch)
191
[6890]192* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
193- rebuild with poppler-0.20.4
194- add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
195- change BuildRequires: lcms2-devel instead of lcms-devel
196
[6011]197* Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
198- new upstream release
199
[5879]200* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
201- rebuild with ImageMagick-6.7.5.10
202
[5568]203* Sat Feb  4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
204- new upstream release
205
[3965]206* Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
207- add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
208
[2998]209* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
210- new upstream release
211- built with poppler-0.16.3
212
[2041]213* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
214- rebuild with poppler-0.14.2
215- add BuildRequires: popt-devel, ImageMagick-c++-devel
216
[1987]217* Sun Oct  3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
218- new upstream release
219- rebuilt with ImageMagick-6.6.4.8
220
[941]221* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
222- added Patch0 for building with poppler-0.12.2+
223- rebuilt with new toolchain and ImageMagick-6.6.1.5
224- removed BR: libgnomeprint-devel, libgnomeprintui-devel
225
[521]226* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
227- rebuild with poppler-0.12.1
228
229* Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
230- new upstream release
231- add BR: libboost-devel
232
233* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
234- update to 0.47pre2
235- drop obsolete patches
236- add BR: gsl-devel
237
238* Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
239- rebuild with poppler-0.10.2
240
241* Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
242- add Patch[1-6]
243
244* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
245- added inkscape-0.46-poppler-0.8.3.patch
246- spec in utf-8
247- added option %%{?_smp_mflags} at make
248
249* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
250- new upstream release
251
252* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
253- rebuild with new environment/toolchain
254
255* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
256- new upstream release
257
258* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
259- add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
260- update required version of gtk2-devel
261
262* Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
263- new upstream release
264
265* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
266- new upstream release
267
268* Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
269- new upstream release
270
271* Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
272- new upstream release
273
274* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
275- new upstream release
276
277* Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
278- new upstream release
279
280* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
281- new upstream release
282- add Japanese summary and description
283- fixed dependancy of libsigc++12 to libsigc++ >= 2.0
284
285* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
286- fixed dependancy of libsigc++ to libsigc++12
287- fixed %files section
288
289* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
290- rebuild for Vine Linux
291- s/Copyright/License/
292- added Requires and BuildRequires
293
294* Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
295- Removing _libdir and TODO, updating description
296
297* Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
298- Fix up the spec file for current release
299
300* Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
301- Update to 0.2.6
302
303* Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
304- Update to 0.2.5
305- Changed SPEC to benefit from macros
Note: See TracBrowser for help on using the repository browser.