source: projects/specs/trunk/i/indent/indent-vl.spec @ 8084

Revision 8084, 4.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary:     A GNU program for formatting C code.
2Summary(ja): C のコードを整形する GNU プログラム
3Name:        indent
4Version:     2.2.9
5Release:     6%{?_dist_release}
6License:     GPL
7Group:       Applications/Text
8URL:         http://www.gnu.org/software/indent/
9Source:      ftp://ftp.gnu.org/pub/gnu/indent-%{version}.tar.gz
10Patch0:      indent-2.2.9-indent_h.patch
11Requires(pre):      /sbin/install-info
12BuildRoot:   %{_tmppath}/%{name}-%{version}-root
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17%description
18Indent is a GNU program for beautifying C code, so that it is easier to
19read.  Indent can also convert from one C writing style to a different
20one.  Indent understands correct C syntax and tries to handle incorrect
21C syntax.
22
23Install the indent package if you are developing applications in C and
24you want a program to format your code.
25
26%description -l ja
27Indent は C のコードを読みやすく整形する GNU プログラムです.Indent を
28使うと,C コードのあるスタイルから別のスタイルへと返還することも出来ます.
29Indent は C 文法を理解しますので,間違った C の文法を可能な限り解釈しよう
30とします.
31
32C によるアプリケーション開発を行っていて,プログラムコードを整形したい
33場合には indent パッケージをインストールして下さい.
34
35
36%prep
37%setup -q
38%patch0 -p0 -b .indent_h
39
40%build
41%configure
42export PATH=$PATH:.
43make
44
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49%makeinstall
50rm -f $RPM_BUILD_ROOT/%{_infodir}/dir $RPM_BUILD_ROOT/usr/bin/texinfo2man \
51        $RPM_BUILD_ROOT/usr/doc/indent/indent.html
52
53%find_lang %name
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58
59%post
60/sbin/install-info %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent).                              Program to format source code."
61
62
63%preun
64if [ "$1" = 0 ]; then
65        /sbin/install-info --delete %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent).                      Program to format source code."
66
67fi
68
69%files -f %{name}.lang
70%defattr(-,root,root)
71%{_bindir}/indent
72%{_mandir}/*/*
73%{_infodir}/*
74
75
76%changelog
77* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.9-6
78- rebuild with VineSeed environment
79
80* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.2.9-5
81- rebuilt with rpm-4.8.1-3
82
83* Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-4vl5
84- applied new versioning policy, spec in utf-8
85- added indent-2.2.9-indent_h.patch
86
87* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.9-3vl2
88- rebuilt for x86_64 architecture
89
90* Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3vl1
91- rebuild with new toolchains
92- based on Redhat Rawhide 2.2.9-3
93
94* Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
95- 2.2.6-1vl2
96- Oops the spec was in Shift_JIS. Fixed.
97
98* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
99- 2.2.6-1vl1
100- rebuilt for Vine Linux
101
102* Sun Nov 19 2000 Florian La Roche <Florian.LaRoche@redhat.de>
103- update to 2.2.6
104
105* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
106- rebuild
107
108* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
109- automatic rebuild
110
111* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
112- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir}
113  and %%{_tmppath}
114- don't use %%{_prefix}
115
116* Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
117- added URL
118- remove manual stripping
119
120
121* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
122- man pages are compressed
123
124* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
125- 2.2.5
126
127* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
128- 2.2.0
129
130* Fri Jul 16 1999 Bill Nottingham <notting@redhat.com>
131- update to 2.1.1
132
133* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
134- update to 1.10.0.
135
136* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
137- auto rebuild in the new build environment (release 11)
138
139* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
140- build for 6.0 tree
141
142* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
143- build root
144
145* Thu May 07 1998 Prospector System <bugs@redhat.com>
146- translations modified for de, fr, tr
147
148* Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
149- use install-info
150
151* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
152- built against glibc
Note: See TracBrowser for help on using the repository browser.