source: projects/specs/trunk/i/indent/indent-vl.spec @ 8979

Revision 8979, 4.3 KB checked in by inagaki, 10 years ago (diff)

2014-09-27 Ryoichi INAGAKI <ryo1@…>

  • daq, indent, pxz: changed Group


Line 
1Summary:     A GNU program for formatting C code.
2Summary(ja): C のコードを整形する GNU プログラム
3Name:        indent
4Version:     2.2.10
5Release:     1%{?_dist_release}
6
7License:     GPLv3
8Group:       Development/Tools
9URL:         http://www.gnu.org/software/indent/
10
11Source:      ftp://ftp.gnu.org/pub/gnu/indent-%{version}.tar.gz
12Patch0:      indent-2.2.9-indent_h.patch
13
14BuildRoot:   %{_tmppath}/%{name}-%{version}-root
15Requires(post): /sbin/install-info
16Requires(preun): /sbin/install-info
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22Indent is a GNU program for beautifying C code, so that it is easier to
23read.  Indent can also convert from one C writing style to a different
24one.  Indent understands correct C syntax and tries to handle incorrect
25C syntax.
26
27Install the indent package if you are developing applications in C and
28you want a program to format your code.
29
30%description -l ja
31Indent は C のコードを読みやすく整形する GNU プログラムです.Indent を
32使うと,C コードのあるスタイルから別のスタイルへと返還することも出来ます.
33Indent は C 文法を理解しますので,間違った C の文法を可能な限り解釈しよう
34とします.
35
36C によるアプリケーション開発を行っていて,プログラムコードを整形したい
37場合には indent パッケージをインストールして下さい.
38
39
40%prep
41%setup -q
42#patch0 -p0 -b .indent_h
43
44%build
45%configure
46export PATH=$PATH:.
47make
48
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53%makeinstall
54rm -f $RPM_BUILD_ROOT/%{_infodir}/dir $RPM_BUILD_ROOT/usr/bin/texinfo2man \
55        $RPM_BUILD_ROOT/usr/doc/indent/indent.html
56
57%find_lang %name
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62
63%post
64/sbin/install-info %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent).                              Program to format source code."
65
66
67%preun
68if [ "$1" = 0 ]; then
69        /sbin/install-info --delete %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent).                      Program to format source code."
70
71fi
72
73%files -f %{name}.lang
74%defattr(-,root,root)
75%{_bindir}/indent
76%{_mandir}/*/*
77%{_infodir}/*
78
79
80%changelog
81* Sat Sep 27 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.10-1
82- updated to 2.2.10
83- dropt Patch0
84- changed Group to Development/Tools
85
86* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.9-6
87- rebuild with VineSeed environment
88
89* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.2.9-5
90- rebuilt with rpm-4.8.1-3
91
92* Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-4vl5
93- applied new versioning policy, spec in utf-8
94- added indent-2.2.9-indent_h.patch
95
96* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.9-3vl2
97- rebuilt for x86_64 architecture
98
99* Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3vl1
100- rebuild with new toolchains
101- based on Redhat Rawhide 2.2.9-3
102
103* Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
104- 2.2.6-1vl2
105- Oops the spec was in Shift_JIS. Fixed.
106
107* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
108- 2.2.6-1vl1
109- rebuilt for Vine Linux
110
111* Sun Nov 19 2000 Florian La Roche <Florian.LaRoche@redhat.de>
112- update to 2.2.6
113
114* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
115- rebuild
116
117* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
118- automatic rebuild
119
120* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
121- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir}
122  and %%{_tmppath}
123- don't use %%{_prefix}
124
125* Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
126- added URL
127- remove manual stripping
128
129
130* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
131- man pages are compressed
132
133* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
134- 2.2.5
135
136* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
137- 2.2.0
138
139* Fri Jul 16 1999 Bill Nottingham <notting@redhat.com>
140- update to 2.1.1
141
142* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
143- update to 1.10.0.
144
145* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
146- auto rebuild in the new build environment (release 11)
147
148* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
149- build for 6.0 tree
150
151* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
152- build root
153
154* Thu May 07 1998 Prospector System <bugs@redhat.com>
155- translations modified for de, fr, tr
156
157* Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
158- use install-info
159
160* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
161- built against glibc
Note: See TracBrowser for help on using the repository browser.