source: projects/specs/trunk/i/incron/incron-vl.spec @ 12316

Revision 12316, 4.7 KB checked in by tomop, 4 years ago (diff)

updated 22 packages

actdiag-0.5.4-1

blockdiag-1.5.4-1

clamav-0.102.1-1

ghostscript-9.27-3

git-2.24.1-1

incron-0.5.12-4

iputils-20190709-2

libsass-3.6.3-1

libxslt-1.1.34-1

nginx-1.16.1-4

nsd-4.2.4-1

nwdiag-1.0.4-1

oniguruma-6.9.4-1

php73-7.3.12-1

python-funcparserlib-0.3.6-1

python-webcolors-1.10-1

samba-4.10.10-1

seqdiag-0.9.6-1

strongswan-5.8.1-1

trousers-0.3.14-1

unbound-1.9.6-1

unrar-free-0.0.1.20140707-1

Line 
1Summary:     Inotify cron system
2Name:        incron
3Version:     0.5.12
4Release:     4%{?_dist_release}
5
6Group:       System Environment/Base         
7License:     GPLv2
8URL:         https://github.com/ar-/incron
9Source0:     https://github.com/ar-/incron/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
10Source1:     incrond.init
11Patch0:      incron-0.5.10-gcc.patch
12Patch1:      incron-0.5.12-prevent-zombies.patch
13# https://github.com/ar-/incron/pull/45/commits/134900ea1dd19834ba6e6c7e7e07611a0e0d78a0
14Patch2:      incron-fix-segv-on-mkdir.patch
15BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17Requires(post):   /sbin/chkconfig
18Requires(preun):  /sbin/chkconfig, /sbin/service
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: tomop
23
24%description
25This program is an "inotify cron" system.
26It consists of a daemon and a table manipulator.
27You can use it a similar way as the regular cron.
28The difference is that the inotify cron handles
29filesystem events rather than time periods.
30
31%prep
32%setup -q
33%patch0 -p1 -b .gcc
34%patch1 -p1 -b .zombie
35%patch2 -p1 -b .mkdir
36
37%build
38make %{?_smp_mflags} CXXFLAGS="%{optflags}"
39
40
41%install
42rm -rf %{buildroot}
43
44#install files manually since source Makefile tries to do it as root
45install -D -p incrond %{buildroot}%{_sbindir}/incrond
46install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
47install -d %{buildroot}%{_localstatedir}/spool/%{name}
48install -d %{buildroot}%{_sysconfdir}/%{name}.d
49install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
50install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
51
52# install manpages
53make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
54
55%post
56if [ $1 -eq 1 ]; then
57    /sbin/chkconfig --add incrond
58fi
59
60
61%preun
62if [ $1 -eq 0 ]; then
63        /sbin/service %{name} stop >/dev/null 2>&1 || :
64        /sbin/chkconfig --del incrond
65fi
66
67
68%postun
69if [ $1 -ge 1 ]; then
70        /sbin/service incrond condrestart >/dev/null 2>&1 || :
71fi
72
73
74%clean
75rm -rf %{buildroot}
76
77%files
78%defattr(-,root,root,-)
79%license COPYING LICENSE*
80%doc CHANGELOG README TODO
81%attr(4755,root,root) %{_bindir}/incrontab
82%{_sbindir}/incrond
83%{_initdir}/incrond
84%config(noreplace) %{_sysconfdir}/%{name}.conf
85%{_mandir}/man1/incrontab.1.gz
86%{_mandir}/man5/incrontab.5.gz
87%{_mandir}/man5/incron.conf.5.gz
88%{_mandir}/man8/incrond.8.gz
89%dir %{_localstatedir}/spool/%{name}
90%dir %{_sysconfdir}/%{name}.d
91
92
93
94%changelog
95* Mon Dec 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-4
96- imported Patch2.
97
98* Mon Nov 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-3
99- replaced Patch1.
100
101* Sat Jul  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-2
102- added Patch1.
103
104* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-1
105- new upstream release.
106
107* Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-2
108- rebuilt with current environment.
109
110* Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
111- new upstream release.
112- built for Vine Linux.
113
114* Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
115- Migrate to systemd, BZ 789688.
116- gcc47 patch.
117
118* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
120
121* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
123
124* Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
125- Upstream released new version
126
127* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
129
130* Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
131- Upstream released new version
132- GCC 4.4 fixes
133- Drop GCC 4.3 patch, fixed upstream
134
135* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
137
138* Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
139- Sync with upstream
140
141* Tue Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
142- Sync with upstream
143* Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
144- Update to new upstream version
145- Upstream fixed permissions on pidfile
146- New manpage for incron.conf
147- Upstream fixed example conf file
148* Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
149- Updated to new upstream version
150- Upstream fixed the incorrect encoding of the LICENSE-GPL file
151* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
152- Updated to new upstream version
153- Changed the service name in the scriptlets
154- Added a configuration file
155- Included GPL License
156* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
157- First try at packaging it up
Note: See TracBrowser for help on using the repository browser.