source: projects/specs/trunk/i/incron/incron-vl.spec @ 10566

Revision 10566, 4.4 KB checked in by tomop, 8 years ago (diff)

incron-0.5.12-2

Line 
1Summary:     Inotify cron system
2Name:        incron
3Version:     0.5.12
4Release:     2%{?_dist_release}
5
6Group:       System Environment/Base         
7License:     GPLv2
8URL:         https://github.com/ar-/incron
9Source0:     https://github.com/ar-/incron/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
10Source1:     incrond.init
11Patch0:      incron-0.5.10-gcc.patch
12Patch1:      incron-sigchld.patch
13BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15Requires(post):   /sbin/chkconfig
16Requires(preun):  /sbin/chkconfig, /sbin/service
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: tomop
21
22%description
23This program is an "inotify cron" system.
24It consists of a daemon and a table manipulator.
25You can use it a similar way as the regular cron.
26The difference is that the inotify cron handles
27filesystem events rather than time periods.
28
29%prep
30%setup -q
31%patch0 -p1 -b .gcc
32%patch1 -p1 -b .sigchld
33
34%build
35make %{?_smp_mflags} CXXFLAGS="%{optflags}"
36
37
38%install
39rm -rf %{buildroot}
40
41#install files manually since source Makefile tries to do it as root
42install -D -p incrond %{buildroot}%{_sbindir}/incrond
43install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
44install -d %{buildroot}%{_localstatedir}/spool/%{name}
45install -d %{buildroot}%{_sysconfdir}/%{name}.d
46install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
47install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
48
49# install manpages
50make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
51
52%post
53if [ $1 -eq 1 ]; then
54    /sbin/chkconfig --add incrond
55fi
56
57
58%preun
59if [ $1 -eq 0 ]; then
60        /sbin/service %{name} stop >/dev/null 2>&1 || :
61        /sbin/chkconfig --del incrond
62fi
63
64
65%postun
66if [ $1 -ge 1 ]; then
67        /sbin/service incrond condrestart >/dev/null 2>&1 || :
68fi
69
70
71%clean
72rm -rf %{buildroot}
73
74%files
75%defattr(-,root,root,-)
76%license COPYING LICENSE*
77%doc CHANGELOG README TODO
78%attr(4755,root,root) %{_bindir}/incrontab
79%{_sbindir}/incrond
80%{_initdir}/incrond
81%config(noreplace) %{_sysconfdir}/%{name}.conf
82%{_mandir}/man1/incrontab.1.gz
83%{_mandir}/man5/incrontab.5.gz
84%{_mandir}/man5/incron.conf.5.gz
85%{_mandir}/man8/incrond.8.gz
86%dir %{_localstatedir}/spool/%{name}
87%dir %{_sysconfdir}/%{name}.d
88
89
90
91%changelog
92* Sat Jul  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-2
93- added Patch1.
94
95* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-1
96- new upstream release.
97
98* Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-2
99- rebuilt with current environment.
100
101* Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
102- new upstream release.
103- built for Vine Linux.
104
105* Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
106- Migrate to systemd, BZ 789688.
107- gcc47 patch.
108
109* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
111
112* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
114
115* Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
116- Upstream released new version
117
118* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
122- Upstream released new version
123- GCC 4.4 fixes
124- Drop GCC 4.3 patch, fixed upstream
125
126* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
128
129* Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
130- Sync with upstream
131
132* Tue Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
133- Sync with upstream
134* Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
135- Update to new upstream version
136- Upstream fixed permissions on pidfile
137- New manpage for incron.conf
138- Upstream fixed example conf file
139* Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
140- Updated to new upstream version
141- Upstream fixed the incorrect encoding of the LICENSE-GPL file
142* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
143- Updated to new upstream version
144- Changed the service name in the scriptlets
145- Added a configuration file
146- Included GPL License
147* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
148- First try at packaging it up
Note: See TracBrowser for help on using the repository browser.