source: projects/specs/trunk/i/incron/incron-vl.spec @ 10556

Revision 10556, 4.2 KB checked in by tomop, 8 years ago (diff)

incron-0.5.12-1

Line 
1Summary:     Inotify cron system
2Name:        incron
3Version:     0.5.12
4Release:     1%{?_dist_release}
5
6Group:       System Environment/Base         
7License:     GPLv2
8URL:         http://inotify.aiken.cz
9Source0:     http://inotify.aiken.cz/download/incron/%{name}-%{version}.tar.gz
10Source1:     incrond.init
11Patch0:      incron-0.5.10-gcc.patch
12BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14Requires(post):   /sbin/chkconfig
15Requires(preun):  /sbin/chkconfig, /sbin/service
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: tomop
20
21%description
22This program is an "inotify cron" system.
23It consists of a daemon and a table manipulator.
24You can use it a similar way as the regular cron.
25The difference is that the inotify cron handles
26filesystem events rather than time periods.
27
28%prep
29%setup -q
30%patch0 -p1 -b .gcc
31
32%build
33make %{?_smp_mflags} CXXFLAGS="%{optflags}"
34
35
36%install
37rm -rf %{buildroot}
38
39#install files manually since source Makefile tries to do it as root
40install -D -p incrond %{buildroot}%{_sbindir}/incrond
41install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
42install -d %{buildroot}%{_localstatedir}/spool/%{name}
43install -d %{buildroot}%{_sysconfdir}/%{name}.d
44install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
45install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
46
47# install manpages
48make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
49
50%post
51if [ $1 -eq 1 ]; then
52    /sbin/chkconfig --add incrond
53fi
54
55
56%preun
57if [ $1 -eq 0 ]; then
58        /sbin/service %{name} stop >/dev/null 2>&1 || :
59        /sbin/chkconfig --del incrond
60fi
61
62
63%postun
64if [ $1 -ge 1 ]; then
65        /sbin/service incrond condrestart >/dev/null 2>&1 || :
66fi
67
68
69%clean
70rm -rf %{buildroot}
71
72%files
73%defattr(-,root,root,-)
74%license COPYING LICENSE*
75%doc CHANGELOG README TODO
76%attr(4755,root,root) %{_bindir}/incrontab
77%{_sbindir}/incrond
78%{_initdir}/incrond
79%config(noreplace) %{_sysconfdir}/%{name}.conf
80%{_mandir}/man1/incrontab.1.gz
81%{_mandir}/man5/incrontab.5.gz
82%{_mandir}/man5/incron.conf.5.gz
83%{_mandir}/man8/incrond.8.gz
84%dir %{_localstatedir}/spool/%{name}
85%dir %{_sysconfdir}/%{name}.d
86
87
88
89%changelog
90* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-1
91- new upstream release.
92
93* Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-2
94- rebuilt with current environment.
95
96* Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
97- new upstream release.
98- built for Vine Linux.
99
100* Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
101- Migrate to systemd, BZ 789688.
102- gcc47 patch.
103
104* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
106
107* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
111- Upstream released new version
112
113* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
115
116* Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
117- Upstream released new version
118- GCC 4.4 fixes
119- Drop GCC 4.3 patch, fixed upstream
120
121* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
123
124* Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
125- Sync with upstream
126
127* Tue Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
128- Sync with upstream
129* Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
130- Update to new upstream version
131- Upstream fixed permissions on pidfile
132- New manpage for incron.conf
133- Upstream fixed example conf file
134* Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
135- Updated to new upstream version
136- Upstream fixed the incorrect encoding of the LICENSE-GPL file
137* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
138- Updated to new upstream version
139- Changed the service name in the scriptlets
140- Added a configuration file
141- Included GPL License
142* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
143- First try at packaging it up
Note: See TracBrowser for help on using the repository browser.