source: projects/specs/trunk/i/inchi/inchi-vl.spec @ 521

Revision 521, 3.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define inchi_so_ver 1.02.00
2
3Summary: The IUPAC International Chemical Identifier library
4Summary(ja): IUPAC International Chemical Identifier (InChI)ライブラリ
5Name: inchi
6Version: 1.0.2
7Release: 1%{?_dist_release}
8Group: System Environment/Libraries
9License: LGPLv2+
10URL: http://www.iupac.org/inchi/
11Source0: http://www.iupac.org/inchi/download/inchi102b.zip
12Patch0: %{name}-rpm.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16%description
17The IUPAC International Chemical Identifier (InChITM) is a non-proprietary
18identifier for chemical substances that can be used in printed and
19electronic data sources thus enabling easier linking of diverse data
20compilations. It was developed under IUPAC Project 2000-025-1-800 during
21the period 2000-2004. Details of the project and the history of its
22progress are available from the project web site.
23
24%package devel
25Summary: Development headers for the InChI library
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28
29%description devel
30The inchi-devel package includes the header files and libraries
31necessary for developing programs using the InChI library.
32
33If you are going to develop programs which will use this library
34you should install inchi-devel.  You'll also need to have the
35inchi package installed.
36
37%prep
38%setup -q -n InChI-1-software-1-02-beta
39%patch0 -p1 -b .r
40
41%build
42pushd INCHI_API/gcc_so_makefile
43make OPTFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
44popd
45
46%install
47rm -rf $RPM_BUILD_ROOT
48mkdir -p $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/inchi}
49install -p INCHI_API/gcc_so_makefile/result/libinchi.so.%{inchi_so_ver} $RPM_BUILD_ROOT%{_libdir}
50ln -s libinchi.so.%{inchi_so_ver} $RPM_BUILD_ROOT%{_libdir}/libinchi.so.1
51ln -s libinchi.so.1               $RPM_BUILD_ROOT%{_libdir}/libinchi.so
52sed -i 's/\r//' INCHI_API/INCHI_DLL/inchi_api.h
53install -pm644 INCHI_API/INCHI_DLL/inchi_api.h $RPM_BUILD_ROOT%{_includedir}/inchi
54sed -i 's/\r//' LICENSE readme.txt
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%post -p /sbin/ldconfig
60
61%postun -p /sbin/ldconfig
62
63%files
64%defattr(-,root,root,-)
65%doc LICENSE readme.txt Software-1-02-beta.pdf
66%{_libdir}/libinchi.so.*
67
68%files devel
69%defattr(-,root,root,-)
70%{_includedir}/inchi
71%{_libdir}/libinchi.so
72
73%changelog
74* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.2-1
75- Initial build for Vine Linux
76
77* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-0.5
78- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
79
80* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-0.4
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
82
83* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-0.3
84- Autorebuild for GCC 4.3
85
86* Mon Oct 01 2007 Dominik Mierzejewski <rpm@greysector.net> 1.0.2-0.2
87- updated license tag
88- fixed non-Unix EOLs in docs
89- fixed dangling symlinks
90
91* Thu Sep 06 2007 Dominik Mierzejewski <rpm@greysector.net> 1.0.2-0.1
92- updated to 1.02b
93- dropped WDI patch (upstream'd)
94- updated license tag
95
96* Sun Jul 01 2007 Dominik Mierzejewski <rpm@greysector.net> 1.0.1-8
97- initial build
Note: See TracBrowser for help on using the repository browser.