source: projects/specs/trunk/i/imlib/imlib-vl.spec @ 521

Revision 521, 6.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: Image loading and rendering library for X11R6
5Summary(ja): 画像の読み込み/レンダリング用のライブラリ
6Name: imlib
7Version: 1.9.15
8Release: 2%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11Source0: ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
12Patch0: imlib-1.9.14-suse-alt-bound.patch
13Patch1: imlib-1.9.13-sec2.patch
14Patch2: imlib-1.9.14-configure-x86_64.patch
15Obsoletes: Imlib
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: libpng-devel >= 2:1.2.5 gtk+-devel >= 1.2.1
19BuildRequires: libtiff-devel libjpeg-devel libungif-devel
20Requires: libpng
21Requires: libtiff
22Requires: libjpeg
23Requires: zlib
24Requires: netpbm-progs
25Requires: libungif
26
27%description
28Imlib is an advanced replacement library for libraries like libXpm that
29provides many more features with much greater flexability and
30speed.
31
32%package -n compat32-%{name}
33Summary: Image loading and rendering library for X11R6
34Summary(ja): 画像の読み込み/レンダリング用のライブラリ
35Group: System Environment/Libraries
36Requires: %{name} = %{version}-%{release}
37
38%description -n compat32-%{name}
39Imlib is an advanced replacement library for libraries like libXpm that
40provides many more features with much greater flexability and
41speed.
42
43%package devel
44Summary: Imlib headers, static libraries and documentation
45Summary(ja): Imlib のヘッダファイルおよび静的ライブラリ、ドキュメント
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: libungif-devel libjpeg-devel
49Requires: libtiff-devel libpng-devel zlib-devel
50Obsoletes: Imlib
51
52%description devel
53Headers, static libraries and documentation for Imlib.
54
55%package cfgeditor
56Summary: Imlib configuration editor
57Summary(ja): Imlib 設定エディタ
58Group: User Interface/Desktops
59Requires: %{name} = %{version}
60#Requires: gtk+ >= 1.2.1
61
62%description cfgeditor
63The imlib_config program allows you to control the way imlib uses
64color and handles gamma correction/etc.
65
66%prep
67%setup -q
68#patch0 -p1 -b .bmp-buffer-overflow
69%patch1 -p1 -b .can-2004-1025_1026
70%patch2 -p1 -b .x86_64
71
72%build
73%define __libtoolize /bin/true
74%configure
75if [ "$SMP" != "" ]; then
76  (make "MAKE=make -k -j $SMP"; exit 0)
77  make
78else
79  make
80fi
81
82%install
83[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
84
85%makeinstall
86
87rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
88
89##%find_lang %{name}
90
91%post -p /sbin/ldconfig
92
93%postun -p /sbin/ldconfig
94
95%post -n compat32-%{name} -p /sbin/ldconfig
96
97%postun -n compat32-%{name} -p /sbin/ldconfig
98
99%clean
100[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
101
102##%files -f %{name}.lang
103%files
104%defattr(-,root,root)
105%doc README AUTHORS ChangeLog NEWS
106%attr(755,root,root) %{_libdir}/lib*.so.*
107%config %{_sysconfdir}/*
108%{_libdir}/libimlib-*.so
109
110%files cfgeditor
111%defattr(-,root,root)
112%{_bindir}/imlib_config
113%{_mandir}/man1/imlib_config*
114
115%files devel
116%defattr(-,root,root)
117%doc doc/*.gif doc/*.html
118%{_bindir}/imlib-config
119%{_libdir}/libImlib.so
120%{_libdir}/libgdk_imlib.so
121%{_libdir}/*.a
122%{_libdir}/pkgconfig/*
123%{_includedir}/*
124%{_datadir}/aclocal/*
125%{_mandir}/man1/imlib-config*
126
127%if %{build_compat32}
128%files -n compat32-%{name}
129%defattr(-,root,root)
130%attr(755,root,root) %{_libdir}/lib*.so.*
131%{_libdir}/libimlib-*.so
132%endif
133
134%changelog
135* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.15-2
136- spec in utf-8
137
138* Tue Jul 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.15-1
139- updated to 1.9.15 (dropped Patch0)
140- applied to new versioning policy
141
142* Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.9.14-0vl10
143- added compat32-imlib package for x86_64 architecture support
144
145* Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 1.9.14-0vl9
146- added imlib-1.9.14-configure-x86_64.patch
147- disable %%find_lang macro
148- rebuilt for x86_64 architecture
149
150* Sat May 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.14-0vl8
151- added Requires: lib*-devel to devel package
152- added %{_libdir}/pkgconfig/*.pc files to devel package
153- removed gtk+ dependancy on main package
154
155* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.14-0vl7
156- rebuild for VineSeed
157
158* Mon Jan 31 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.9.14-0vl6.1
159- Added a security patch for CAN-2004-1025 and CAN-2004-1026.
160- Patch1: imlib-1.9.13-sec2.patch
161  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138516
162
163* Fri Sep 17 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.9.14-0vl6
164- Updated Patch0: http://bugzilla.gnome.org/show_bug.cgi?id=151034#c8
165
166* Wed Sep  1 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp>  1.9.14-0vl5
167- Added a security patch for buffer overflow in bmp handling (Patch0).
168
169* Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.9.14-0vl4
170- rebuild
171
172* Sat Apr 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.9.14-0vl2
173- rebuild with libpng12-devel
174- add BuildPrereq
175
176* Sat Mar 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.14-0vl1
177- updated to new upstream release
178- Patch0 removed (merged into upstream source)
179
180* Sat Jul 14 2001 <sagami@vinelinux.org>
181- 1.9.10-0vl2: fix to build against new libtool
182
183* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.10-0vl1
184- New upstream release.
185
186* Wed Mar  7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.9-0vl1
187- New upstream release.
188- use rpmmacros.
189
190* Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
191- 1.9.8.1-2vl2
192- requires netpbm-progs instead of libgr-progs
193
194* Sun Jul 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
195- change to use libtoolize
196
197* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
198- change group
199- added Japanese summary
200
201* Wed Jan 5 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
202- added setlocale patch
203
204* Mon Jan 11 1999 Carsten Haitzler <raster@redhat.com>
205- up to 1.9.0
206
207* Wed Sep 23 1998 Carsten Haitzler <raster@redhat.com>
208- up to 1.8.1
209
210* Tue Sep 22 1998 Cristian Gafton <gafton@redhat.com>
211- yet another build for today (%defattr and %attr in the files lists)
212- devel docs are back on the spec file
213
214* Tue Sep 22 1998 Carsten Haitzler <raster@redhat.com>
215- Added minor patch for ps saving code.
216
217* Mon Sep 21 1998 Cristian Gafton <gafton@redhat.com>
218- updated to version 1.8
219
220* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
221- take out imlib_config from devel package
222
223* Wed Sep 9 1998 Michael Fulbright <msf@redhat.com>
224- upgraded to 1.7
225- changed name so it will persist if user later install devel imlib
226- added subpackage for imlib_config
227
228* Fri Apr 3 1998 Michael K. Johnson <johnsonm@redhat.com>
229- fixed typo
230
231* Fri Mar 13 1998 Marc Ewing <marc@redhat.com>
232- Added -k, Obsoletes
233- Integrate into CVS source tree
234
Note: See TracBrowser for help on using the repository browser.