source: projects/specs/trunk/i/imlib/imlib-vl.spec @ 8982

Revision 8982, 7.7 KB checked in by inagaki, 10 years ago (diff)

2014-09-28 Ryoichi INAGAKI <ryo1@…>

  • imlib: fixed typo


Line 
1# Note that this is NOT a relocatable package
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Name: imlib
5Summary: Image loading and rendering library for X11R6
6Summary(ja): 画像の読み込み/レンダリング用のライブラリ
7Version: 1.9.15
8Release: 6%{?_dist_release}
9
10License: LGPL
11Group: System Environment/Libraries
12
13Source0: ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
14
15Patch1: imlib-1.9.13-sec2.patch
16Patch2: imlib-1.9.14-configure-x86_64.patch
17Patch3: imlib-1.9.15-libpng15.patch
18Patch4: imlib-1.9.15-bpp16-CVE-2007-3568.patch
19Patch5: imlib-1.9.13-underquoted.patch
20Patch6: imlib-1.9.15-giflib4.patch
21Obsoletes: Imlib
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: giflib-devel
25BuildRequires: gtk+-devel >= 1.2.1
26BuildRequires: libjpeg-devel
27BuildRequires: libpng-devel >= 2:1.2.5
28BuildRequires: libtiff-devel
29BuildRequires: libSM-devel
30BuildRequires: libXt-devel
31BuildRequires: zlib-devel
32Requires: netpbm-progs
33
34%description
35Imlib is an advanced replacement library for libraries like libXpm that
36provides many more features with much greater flexability and
37speed.
38
39%package -n compat32-%{name}
40Summary: Image loading and rendering library for X11R6
41Summary(ja): 画像の読み込み/レンダリング用のライブラリ
42Group: System Environment/Libraries
43Requires: %{name} = %{version}-%{release}
44
45%description -n compat32-%{name}
46Imlib is an advanced replacement library for libraries like libXpm that
47provides many more features with much greater flexability and
48speed.
49
50%package devel
51Summary: Imlib headers, static libraries and documentation
52Summary(ja): Imlib のヘッダファイルおよび静的ライブラリ、ドキュメント
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55Requires: libungif-devel libjpeg-devel
56Requires: libtiff-devel libpng-devel zlib-devel
57Obsoletes: Imlib
58
59%description devel
60Headers, static libraries and documentation for Imlib.
61
62%package cfgeditor
63Summary: Imlib configuration editor
64Summary(ja): Imlib 設定エディタ
65Group: Applications/System
66Requires: %{name} = %{version}
67#Requires: gtk+ >= 1.2.1
68
69%description cfgeditor
70The imlib_config program allows you to control the way imlib uses
71color and handles gamma correction/etc.
72
73%prep
74%setup -q
75#patch0 -p1 -b .bmp-buffer-overflow
76%patch1 -p1 -b .can-2004-1025_1026
77%patch2 -p1 -b .x86_64
78%patch3 -p0 -b .libpng
79## CVE-2007-3568 (DoS via a BMP image with a Bits Per Page of 0) (#426091)
80%patch4 -p0 -b .bpp16
81## Fix underquoted m4 definitions
82%patch5 -p1 -b .underquoted
83%patch6 -p1 -b .giflib4
84
85%build
86%define __libtoolize /bin/true
87%configure --disable-static
88
89## Remove -L%%{_libdir} from imlib-config if present;
90## it's redundant and breaks multilib compatibility
91sed -i -e 's,-L%{_libdir} ,,g' imlib-config
92
93## Kill bogus RPATHs
94sed -i 's|^sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spec="/%{_lib} %{_libdir}|' libtool
95
96if [ "$SMP" != "" ]; then
97  (make "MAKE=make -k -j $SMP"; exit 0)
98  make
99else
100  make
101fi
102
103%install
104[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
105
106make install DESTDIR=$RPM_BUILD_ROOT
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
109
110##%find_lang %{name}
111
112%post -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%post -n compat32-%{name} -p /sbin/ldconfig
117
118%postun -n compat32-%{name} -p /sbin/ldconfig
119
120%clean
121[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
122
123##%files -f %{name}.lang
124%files
125%defattr(-,root,root)
126%doc README AUTHORS ChangeLog NEWS
127%config %{_sysconfdir}/*
128%{_libdir}/lib*.so.*
129%{_libdir}/libimlib-*.so
130
131%files cfgeditor
132%defattr(-,root,root)
133%{_bindir}/imlib_config
134%{_mandir}/man1/imlib_config*
135
136%files devel
137%defattr(-,root,root)
138%doc doc/*.gif doc/*.html
139%{_bindir}/imlib-config
140%{_libdir}/libImlib.so
141%{_libdir}/libgdk_imlib.so
142%{_libdir}/pkgconfig/*
143%{_includedir}/*
144%{_datadir}/aclocal/*
145%{_mandir}/man1/imlib-config*
146
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-,root,root)
150%{_libdir}/lib*.so.*
151%{_libdir}/libimlib-*.so
152%endif
153
154%changelog
155* Sun Sep 28 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.15-6
156- fixed Group typo on cfgeditor subpackage
157
158* Fri Sep 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.15-5
159- added Patch4, Patch5 from Fedora
160- added Patch6 to build with giflib-4.2.3
161
162* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.15-4
163- add BuildRequires: libSM-devel, libXt-devel
164- add Patch3 (imlib-1.9.15-libpng15.patch) from fedora
165
166* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.9.15-3
167- rebuilt with rpm-4.8.1 for pkg-config
168
169* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.15-2
170- spec in utf-8
171
172* Tue Jul 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.15-1
173- updated to 1.9.15 (dropped Patch0)
174- applied to new versioning policy
175
176* Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.9.14-0vl10
177- added compat32-imlib package for x86_64 architecture support
178
179* Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 1.9.14-0vl9
180- added imlib-1.9.14-configure-x86_64.patch
181- disable %%find_lang macro
182- rebuilt for x86_64 architecture
183
184* Sat May 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.14-0vl8
185- added Requires: lib*-devel to devel package
186- added %{_libdir}/pkgconfig/*.pc files to devel package
187- removed gtk+ dependancy on main package
188
189* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.14-0vl7
190- rebuild for VineSeed
191
192* Mon Jan 31 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.9.14-0vl6.1
193- Added a security patch for CAN-2004-1025 and CAN-2004-1026.
194- Patch1: imlib-1.9.13-sec2.patch
195  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138516
196
197* Fri Sep 17 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.9.14-0vl6
198- Updated Patch0: http://bugzilla.gnome.org/show_bug.cgi?id=151034#c8
199
200* Wed Sep  1 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp>  1.9.14-0vl5
201- Added a security patch for buffer overflow in bmp handling (Patch0).
202
203* Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.9.14-0vl4
204- rebuild
205
206* Sat Apr 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.9.14-0vl2
207- rebuild with libpng12-devel
208- add BuildPrereq
209
210* Sat Mar 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.14-0vl1
211- updated to new upstream release
212- Patch0 removed (merged into upstream source)
213
214* Sat Jul 14 2001 <sagami@vinelinux.org>
215- 1.9.10-0vl2: fix to build against new libtool
216
217* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.10-0vl1
218- New upstream release.
219
220* Wed Mar  7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.9-0vl1
221- New upstream release.
222- use rpmmacros.
223
224* Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
225- 1.9.8.1-2vl2
226- requires netpbm-progs instead of libgr-progs
227
228* Sun Jul 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
229- change to use libtoolize
230
231* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
232- change group
233- added Japanese summary
234
235* Wed Jan 5 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
236- added setlocale patch
237
238* Mon Jan 11 1999 Carsten Haitzler <raster@redhat.com>
239- up to 1.9.0
240
241* Wed Sep 23 1998 Carsten Haitzler <raster@redhat.com>
242- up to 1.8.1
243
244* Tue Sep 22 1998 Cristian Gafton <gafton@redhat.com>
245- yet another build for today (%defattr and %attr in the files lists)
246- devel docs are back on the spec file
247
248* Tue Sep 22 1998 Carsten Haitzler <raster@redhat.com>
249- Added minor patch for ps saving code.
250
251* Mon Sep 21 1998 Cristian Gafton <gafton@redhat.com>
252- updated to version 1.8
253
254* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
255- take out imlib_config from devel package
256
257* Wed Sep 9 1998 Michael Fulbright <msf@redhat.com>
258- upgraded to 1.7
259- changed name so it will persist if user later install devel imlib
260- added subpackage for imlib_config
261
262* Fri Apr 3 1998 Michael K. Johnson <johnsonm@redhat.com>
263- fixed typo
264
265* Fri Mar 13 1998 Marc Ewing <marc@redhat.com>
266- Added -k, Obsoletes
267- Integrate into CVS source tree
268
Note: See TracBrowser for help on using the repository browser.