source: projects/specs/trunk/i/imake/imake-vl.spec @ 8545

Revision 8545, 6.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1Summary: imake source code configuration and build system
2Name: imake
3Version: 1.0.7
4Release: 1%{?_dist_release}
5License: MIT/X11
6Group: User Interface/X
7URL: http://www.x.org
8
9Source0: ftp://ftp.x.org/pub/individual/util/%{name}-%{version}.tar.bz2
10Source1: ftp://ftp.x.org/pub/individual/util/makedepend-1.0.5.tar.bz2
11Source2: ftp://ftp.x.org/pub/individual/util/gccmakedep-1.0.3.tar.bz2
12Source3: ftp://ftp.x.org/pub/individual/util/xorg-cf-files-1.0.5.tar.bz2
13Source4: ftp://ftp.x.org/pub/individual/util/lndir-1.0.3.tar.bz2
14Patch2: xorg-cf-files-1.0.5-redhat.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: pkgconfig
18BuildRequires: xorg-x11-util-macros
19BuildRequires: xorg-x11-proto-devel
20
21Provides: ccmakedep cleanlinks gccmakedep imake lndir makedepend makeg
22Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
23
24%description
25Imake is a deprecated source code configuration and build system which
26has traditionally been supplied by and used to build the X Window System
27in X11R6 and previous releases.  As of the X Window System X11R7 release,
28the X Window system has switched to using GNU autotools as the primary
29build system, and the Imake system is now deprecated, and should not be
30used by new software projects.  Software developers are encouraged to
31migrate software to the GNU autotools system.
32
33%prep
34%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
35%patch2 -p0 -b .redhat
36
37%build
38# Build everything
39{
40   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
41      pushd $pkg-*
42      case $pkg in
43         imake|xorg-cf-files)
44            %configure --with-config-dir=%{_datadir}/X11/config
45            ;;
46         *)
47            %configure
48            ;;
49      esac
50      make
51      popd
52   done
53}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58# Install everything
59{
60   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
61      pushd $pkg-*
62      case $pkg in
63#         xorg-cf-files)
64#            make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_datadir}
65#            ;;
66         *)
67            make install DESTDIR=$RPM_BUILD_ROOT
68            ;;
69      esac
70      popd
71   done
72}
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(-,root,root,-)
79%doc
80%{_bindir}/ccmakedep
81%{_bindir}/cleanlinks
82%{_bindir}/gccmakedep
83%{_bindir}/imake
84%{_bindir}/lndir
85%{_bindir}/makedepend
86%{_bindir}/makeg
87%{_bindir}/mergelib
88%{_bindir}/mkdirhier
89%{_bindir}/mkhtmlindex
90%{_bindir}/revpath
91%{_bindir}/xmkmf
92%dir %{_datadir}/X11
93%dir %{_datadir}/X11/config
94%{_datadir}/X11/config/*.cf
95%{_datadir}/X11/config/*.def
96%{_datadir}/X11/config/*.rules
97%{_datadir}/X11/config/*.tmpl
98#%dir %{_mandir}/man1x
99%{_mandir}/man1/ccmakedep.1.*
100%{_mandir}/man1/cleanlinks.1.*
101%{_mandir}/man1/gccmakedep.1.*
102%{_mandir}/man1/imake.1.*
103%{_mandir}/man1/lndir.1.*
104%{_mandir}/man1/makedepend.1.*
105%{_mandir}/man1/makeg.1.*
106%{_mandir}/man1/mergelib.1.*
107%{_mandir}/man1/mkdirhier.1.*
108%{_mandir}/man1/mkhtmlindex.1.*
109%{_mandir}/man1/revpath.1.*
110%{_mandir}/man1/xmkmf.1.*
111
112%changelog
113* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
114- imake-1.0.7
115- gccmakedep-1.0.3
116- makedepend-1.0.5
117- xorg-cf-files-1.0.5
118- update Patch2 (xorg-cf-files-1.0.5-redhat.patch)
119
120* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
121- imake-1.0.5
122- lndir-1.0.3
123- makedepend-1.0.4
124
125* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
126- xorg-cf-files-1.0.4
127- update Patch2 (xorg-cf-files-1.0.4-redhat.patch)
128- delete Patch0,1,3
129
130* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
131- imake-1.0.4
132- lndir-1.0.2
133- makedepend-1.0.3
134- xorg-cf-files-1.0.3
135- update Patch2 (xorg-cf-files-1.0.3-redhat.patch)
136- update Patch3 (xorg-cf-files-1.0.3-xprint.patch)
137- fix %%files
138
139* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
140- rebuilt with new toolchain
141
142* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
143- new versioning policy
144
145* Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
146- initial build for Vine Linux
147
148* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-5
149- Rebuild for build id
150
151* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
152- makedepend 1.0.1
153
154* Tue Jul 18 2006 Than Ngo <than@redhat.com> 1.0.2-3
155- cleanup patch files
156- update source files
157
158* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-2
159- rebuild
160
161* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
162- Update to imake-1.0.2, gccmakedep-1.0.2, xorg-cf-files-1.0.2
163
164* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
165- Fix ExtraXawReqs to reflect reality (libXp is unneeded)
166
167* Mon Mar 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
168- Updated xorg-cf-files-1.0.1-redhat.patch with fix for (#178177)
169
170* Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-2
171- Buildrequires: xorg-x11-proto-devel
172
173* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
174- bump again for double-long bug on ppc(64)
175
176* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
177- rebuilt for new gcc4.1 snapshot and glibc changes
178
179* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
180- Updated all packages to version 1.0.1 from X11R7.0
181
182* Wed Dec 21 2005 Than Ngo <than@redhat.com> 1.0.0-4
183- final fix for #173593
184
185* Tue Dec 20 2005 Than Ngo <than@redhat.com> 1.0.0-3
186- add correct XAppLoadDir #173593
187- add more macros for fedora
188
189* Mon Dec 19 2005 Than Ngo <than@redhat.com> 1.0.0-2
190- add some macros to fix problem in building of manpages
191
192* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
193- Updated all packages to version 1.0.0 from X11R7 RC4
194- Added new lndir, gccmakedep tarballs.  (#173478)
195- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
196- Removed all previous 'misc' patch, as we now pass --with-config-dir to
197  configure to specify the location of the Imake config files.
198- Renamed imake patch to xorg-cf-files-1.0.0-ProjectRoot.patch as it did not
199  patch imake at all.  This should probably be changed to be a custom Red Hat
200  host.def file that is added as a source line instead of randomly patching
201  various files.
202
203* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 0.99.2-5.1
204- rebuilt
205
206* Mon Nov 28 2005 Than Ngo <than@redhat.com> 0.99.2-5
207- add correct ProjectRoot for modular X
208
209* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-4
210- add missing host.conf
211
212* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-3
213- fix typo
214
215* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-2
216- fix xmkmf to look config files in /usr/share/X11/config
217  instead /usr/%%{_lib}/X11/config/
218- add host.conf
219
220* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
221- Updated to imake-0.99.2, xorg-cf-files-0.99.2, makedepend-0.99.2 from
222  X11R7 RC2.
223
224* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
225- Initial build.
Note: See TracBrowser for help on using the repository browser.