source: projects/specs/trunk/i/imake/imake-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: imake source code configuration and build system
2Name: imake
3Version: 1.0.2
4Release: 2%{?_dist_release}
5License: MIT/X11
6Group: User Interface/X
7URL: http://www.x.org
8
9Source0: ftp://ftp.x.org/pub/individual/util/imake-1.0.2.tar.bz2
10Source1: ftp://ftp.x.org/pub/individual/util/makedepend-1.0.1.tar.bz2
11Source2: ftp://ftp.x.org/pub/individual/util/gccmakedep-1.0.2.tar.bz2
12Source3: ftp://ftp.x.org/pub/individual/util/xorg-cf-files-1.0.2.tar.bz2
13Source4: ftp://ftp.x.org/pub/individual/util/lndir-1.0.1.tar.bz2
14Patch0: xorg-cf-files-1.0.0-misc.patch
15Patch1: xorg-cf-files-1.0.0-ProjectRoot.patch
16Patch2: xorg-cf-files-1.0.2-redhat.patch
17Patch3: xorg-cf-files-1.0.2-xprint.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: pkgconfig
21BuildRequires: xorg-x11-util-macros
22BuildRequires: xorg-x11-proto-devel
23
24Provides: ccmakedep cleanlinks gccmakedep imake lndir makedepend makeg
25Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
26
27%description
28Imake is a deprecated source code configuration and build system which
29has traditionally been supplied by and used to build the X Window System
30in X11R6 and previous releases.  As of the X Window System X11R7 release,
31the X Window system has switched to using GNU autotools as the primary
32build system, and the Imake system is now deprecated, and should not be
33used by new software projects.  Software developers are encouraged to
34migrate software to the GNU autotools system.
35
36%prep
37%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
38#%patch0 -p0 -b .imake
39#%patch1 -p0 -b .ProjectRoot
40%patch2 -p0 -b .redhat
41%patch3 -p0 -b .xprint
42
43%build
44# Build everything
45{
46   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
47      pushd $pkg-*
48      case $pkg in
49         imake|xorg-cf-files)
50            %configure --with-config-dir=%{_datadir}/X11/config
51            ;;
52         *)
53            %configure
54            ;;
55      esac
56      make
57      popd
58   done
59}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64# Install everything
65{
66   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
67      pushd $pkg-*
68      case $pkg in
69#         xorg-cf-files)
70#            make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_datadir}
71#            ;;
72         *)
73            make install DESTDIR=$RPM_BUILD_ROOT
74            ;;
75      esac
76      popd
77   done
78}
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(-,root,root,-)
85%doc
86%{_bindir}/ccmakedep
87%{_bindir}/cleanlinks
88%{_bindir}/gccmakedep
89%{_bindir}/imake
90%{_bindir}/lndir
91%{_bindir}/makedepend
92%{_bindir}/makeg
93%{_bindir}/mergelib
94%{_bindir}/mkdirhier
95%{_bindir}/mkhtmlindex
96%{_bindir}/revpath
97%{_bindir}/xmkmf
98%dir %{_datadir}/X11
99%dir %{_datadir}/X11/config
100%{_datadir}/X11/config/*.cf
101%{_datadir}/X11/config/*.def
102%{_datadir}/X11/config/*.rules
103%{_datadir}/X11/config/*.tmpl
104#%dir %{_mandir}/man1x
105%{_mandir}/man1/ccmakedep.1x*
106%{_mandir}/man1/cleanlinks.1x*
107%{_mandir}/man1/gccmakedep.1x*
108%{_mandir}/man1/imake.1x*
109%{_mandir}/man1/lndir.1x*
110%{_mandir}/man1/makedepend.1*
111%{_mandir}/man1/makeg.1x*
112%{_mandir}/man1/mergelib.1x*
113%{_mandir}/man1/mkdirhier.1x*
114%{_mandir}/man1/mkhtmlindex.1x*
115%{_mandir}/man1/revpath.1x*
116%{_mandir}/man1/xmkmf.1x*
117
118%changelog
119* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
120- rebuilt with new toolchain
121
122* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
123- new versioning policy
124
125* Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
126- initial build for Vine Linux
127
128* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-5
129- Rebuild for build id
130
131* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
132- makedepend 1.0.1
133
134* Tue Jul 18 2006 Than Ngo <than@redhat.com> 1.0.2-3
135- cleanup patch files
136- update source files
137
138* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-2
139- rebuild
140
141* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
142- Update to imake-1.0.2, gccmakedep-1.0.2, xorg-cf-files-1.0.2
143
144* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
145- Fix ExtraXawReqs to reflect reality (libXp is unneeded)
146
147* Mon Mar 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
148- Updated xorg-cf-files-1.0.1-redhat.patch with fix for (#178177)
149
150* Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-2
151- Buildrequires: xorg-x11-proto-devel
152
153* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
154- bump again for double-long bug on ppc(64)
155
156* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
157- rebuilt for new gcc4.1 snapshot and glibc changes
158
159* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
160- Updated all packages to version 1.0.1 from X11R7.0
161
162* Wed Dec 21 2005 Than Ngo <than@redhat.com> 1.0.0-4
163- final fix for #173593
164
165* Tue Dec 20 2005 Than Ngo <than@redhat.com> 1.0.0-3
166- add correct XAppLoadDir #173593
167- add more macros for fedora
168
169* Mon Dec 19 2005 Than Ngo <than@redhat.com> 1.0.0-2
170- add some macros to fix problem in building of manpages
171
172* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
173- Updated all packages to version 1.0.0 from X11R7 RC4
174- Added new lndir, gccmakedep tarballs.  (#173478)
175- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
176- Removed all previous 'misc' patch, as we now pass --with-config-dir to
177  configure to specify the location of the Imake config files.
178- Renamed imake patch to xorg-cf-files-1.0.0-ProjectRoot.patch as it did not
179  patch imake at all.  This should probably be changed to be a custom Red Hat
180  host.def file that is added as a source line instead of randomly patching
181  various files.
182
183* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 0.99.2-5.1
184- rebuilt
185
186* Mon Nov 28 2005 Than Ngo <than@redhat.com> 0.99.2-5
187- add correct ProjectRoot for modular X
188
189* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-4
190- add missing host.conf
191
192* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-3
193- fix typo
194
195* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-2
196- fix xmkmf to look config files in /usr/share/X11/config
197  instead /usr/%%{_lib}/X11/config/
198- add host.conf
199
200* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
201- Updated to imake-0.99.2, xorg-cf-files-0.99.2, makedepend-0.99.2 from
202  X11R7 RC2.
203
204* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
205- Initial build.
Note: See TracBrowser for help on using the repository browser.