source: projects/specs/trunk/i/imake/imake-vl.spec @ 9052

Revision 9052, 6.7 KB checked in by inagaki, 9 years ago (diff)

2014-11-02 Ryoichi INAGAKI <ryo1@…>

  • freeciv, imake, lasem, lua, mate-icon-theme: changed Group


Line 
1Summary: imake source code configuration and build system
2Name: imake
3Version: 1.0.7
4Release: 2%{?_dist_release}
5License: MIT/X11
6Group: Development/Tools
7URL: http://www.x.org
8
9Source0: ftp://ftp.x.org/pub/individual/util/%{name}-%{version}.tar.bz2
10Source1: ftp://ftp.x.org/pub/individual/util/makedepend-1.0.5.tar.bz2
11Source2: ftp://ftp.x.org/pub/individual/util/gccmakedep-1.0.3.tar.bz2
12Source3: ftp://ftp.x.org/pub/individual/util/xorg-cf-files-1.0.5.tar.bz2
13Source4: ftp://ftp.x.org/pub/individual/util/lndir-1.0.3.tar.bz2
14Patch2: xorg-cf-files-1.0.5-redhat.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: pkgconfig
18BuildRequires: xorg-x11-util-macros
19BuildRequires: xorg-x11-proto-devel
20
21Provides: ccmakedep cleanlinks gccmakedep imake lndir makedepend makeg
22Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
23
24%description
25Imake is a deprecated source code configuration and build system which
26has traditionally been supplied by and used to build the X Window System
27in X11R6 and previous releases.  As of the X Window System X11R7 release,
28the X Window system has switched to using GNU autotools as the primary
29build system, and the Imake system is now deprecated, and should not be
30used by new software projects.  Software developers are encouraged to
31migrate software to the GNU autotools system.
32
33%prep
34%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
35%patch2 -p0 -b .redhat
36
37%build
38# Build everything
39{
40   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
41      pushd $pkg-*
42      case $pkg in
43         imake|xorg-cf-files)
44            %configure --with-config-dir=%{_datadir}/X11/config
45            ;;
46         *)
47            %configure
48            ;;
49      esac
50      make
51      popd
52   done
53}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58# Install everything
59{
60   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
61      pushd $pkg-*
62      case $pkg in
63#         xorg-cf-files)
64#            make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_datadir}
65#            ;;
66         *)
67            make install DESTDIR=$RPM_BUILD_ROOT
68            ;;
69      esac
70      popd
71   done
72}
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(-,root,root,-)
79%doc
80%{_bindir}/ccmakedep
81%{_bindir}/cleanlinks
82%{_bindir}/gccmakedep
83%{_bindir}/imake
84%{_bindir}/lndir
85%{_bindir}/makedepend
86%{_bindir}/makeg
87%{_bindir}/mergelib
88%{_bindir}/mkdirhier
89%{_bindir}/mkhtmlindex
90%{_bindir}/revpath
91%{_bindir}/xmkmf
92%dir %{_datadir}/X11
93%dir %{_datadir}/X11/config
94%{_datadir}/X11/config/*.cf
95%{_datadir}/X11/config/*.def
96%{_datadir}/X11/config/*.rules
97%{_datadir}/X11/config/*.tmpl
98#%dir %{_mandir}/man1x
99%{_mandir}/man1/ccmakedep.1.*
100%{_mandir}/man1/cleanlinks.1.*
101%{_mandir}/man1/gccmakedep.1.*
102%{_mandir}/man1/imake.1.*
103%{_mandir}/man1/lndir.1.*
104%{_mandir}/man1/makedepend.1.*
105%{_mandir}/man1/makeg.1.*
106%{_mandir}/man1/mergelib.1.*
107%{_mandir}/man1/mkdirhier.1.*
108%{_mandir}/man1/mkhtmlindex.1.*
109%{_mandir}/man1/revpath.1.*
110%{_mandir}/man1/xmkmf.1.*
111
112%changelog
113* Sun Nov  2 2014 Ryoichi INAAGKI <ryo1@toki.waseda.jp> 1.0.7-2
114- moved to Development/Tools Group
115
116* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
117- imake-1.0.7
118- gccmakedep-1.0.3
119- makedepend-1.0.5
120- xorg-cf-files-1.0.5
121- update Patch2 (xorg-cf-files-1.0.5-redhat.patch)
122
123* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
124- imake-1.0.5
125- lndir-1.0.3
126- makedepend-1.0.4
127
128* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
129- xorg-cf-files-1.0.4
130- update Patch2 (xorg-cf-files-1.0.4-redhat.patch)
131- delete Patch0,1,3
132
133* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
134- imake-1.0.4
135- lndir-1.0.2
136- makedepend-1.0.3
137- xorg-cf-files-1.0.3
138- update Patch2 (xorg-cf-files-1.0.3-redhat.patch)
139- update Patch3 (xorg-cf-files-1.0.3-xprint.patch)
140- fix %%files
141
142* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
143- rebuilt with new toolchain
144
145* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
146- new versioning policy
147
148* Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
149- initial build for Vine Linux
150
151* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-5
152- Rebuild for build id
153
154* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
155- makedepend 1.0.1
156
157* Tue Jul 18 2006 Than Ngo <than@redhat.com> 1.0.2-3
158- cleanup patch files
159- update source files
160
161* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-2
162- rebuild
163
164* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
165- Update to imake-1.0.2, gccmakedep-1.0.2, xorg-cf-files-1.0.2
166
167* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
168- Fix ExtraXawReqs to reflect reality (libXp is unneeded)
169
170* Mon Mar 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
171- Updated xorg-cf-files-1.0.1-redhat.patch with fix for (#178177)
172
173* Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-2
174- Buildrequires: xorg-x11-proto-devel
175
176* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
177- bump again for double-long bug on ppc(64)
178
179* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
180- rebuilt for new gcc4.1 snapshot and glibc changes
181
182* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
183- Updated all packages to version 1.0.1 from X11R7.0
184
185* Wed Dec 21 2005 Than Ngo <than@redhat.com> 1.0.0-4
186- final fix for #173593
187
188* Tue Dec 20 2005 Than Ngo <than@redhat.com> 1.0.0-3
189- add correct XAppLoadDir #173593
190- add more macros for fedora
191
192* Mon Dec 19 2005 Than Ngo <than@redhat.com> 1.0.0-2
193- add some macros to fix problem in building of manpages
194
195* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
196- Updated all packages to version 1.0.0 from X11R7 RC4
197- Added new lndir, gccmakedep tarballs.  (#173478)
198- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
199- Removed all previous 'misc' patch, as we now pass --with-config-dir to
200  configure to specify the location of the Imake config files.
201- Renamed imake patch to xorg-cf-files-1.0.0-ProjectRoot.patch as it did not
202  patch imake at all.  This should probably be changed to be a custom Red Hat
203  host.def file that is added as a source line instead of randomly patching
204  various files.
205
206* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 0.99.2-5.1
207- rebuilt
208
209* Mon Nov 28 2005 Than Ngo <than@redhat.com> 0.99.2-5
210- add correct ProjectRoot for modular X
211
212* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-4
213- add missing host.conf
214
215* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-3
216- fix typo
217
218* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-2
219- fix xmkmf to look config files in /usr/share/X11/config
220  instead /usr/%%{_lib}/X11/config/
221- add host.conf
222
223* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
224- Updated to imake-0.99.2, xorg-cf-files-0.99.2, makedepend-0.99.2 from
225  X11R7 RC2.
226
227* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
228- Initial build.
Note: See TracBrowser for help on using the repository browser.