source: projects/specs/trunk/i/imake/imake-vl.spec @ 12559

Revision 12559, 7.2 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

git-2.30.1-1

imake-1.0.8-1

irqbalance-1.7.0-1

meson-0.57.1-1

vine-rpm-macros-4-1

Line 
1%global makedepend_version              1.0.6
2%global gccmakedep_version              1.0.3
3%global xorg_cf_files_version   1.0.6
4%global lndir_version                   1.0.3
5
6Summary: imake source code configuration and build system
7Name: imake
8Version: 1.0.8
9Release: 1%{?_dist_release}
10Group: programming
11Vendor: Project Vine
12Distribution: Vine Linux
13
14License: MIT/X11
15URL: https://www.x.org/
16
17Source0: https://www.x.org/pub/individual/util/%{name}-%{version}.tar.bz2
18Source1: https://www.x.org/pub/individual/util/makedepend-%{makedepend_version}.tar.bz2
19Source2: https://www.x.org/pub/individual/util/gccmakedep-%{gccmakedep_version}.tar.bz2
20Source3: https://www.x.org/pub/individual/util/xorg-cf-files-%{xorg_cf_files_version}.tar.bz2
21Source4: https://www.x.org/pub/individual/util/lndir-%{lndir_version}.tar.bz2
22Patch2: xorg-cf-files-1.0.5-redhat.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25BuildRequires: pkgconfig
26BuildRequires: xorg-x11-util-macros
27BuildRequires: xorg-x11-proto-devel
28
29Provides: ccmakedep cleanlinks gccmakedep imake lndir makedepend makeg
30Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
31
32%description
33Imake is a deprecated source code configuration and build system which
34has traditionally been supplied by and used to build the X Window System
35in X11R6 and previous releases.  As of the X Window System X11R7 release,
36the X Window system has switched to using GNU autotools as the primary
37build system, and the Imake system is now deprecated, and should not be
38used by new software projects.  Software developers are encouraged to
39migrate software to the GNU autotools system.
40
41
42%debug_package
43
44
45%prep
46%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
47pushd xorg-cf-files-%{xorg_cf_files_version}
48%patch2 -p1 -b .redhat
49popd
50
51
52%build
53# Build everything
54{
55   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
56      pushd $pkg-*
57      case $pkg in
58         imake|xorg-cf-files)
59            %configure --with-config-dir=%{_datadir}/X11/config
60            ;;
61         *)
62            %configure
63            ;;
64      esac
65      make
66      popd
67   done
68}
69
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74# Install everything
75{
76   for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
77      pushd $pkg-*
78      case $pkg in
79#         xorg-cf-files)
80#            make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_datadir}
81#            ;;
82         *)
83            make install DESTDIR=$RPM_BUILD_ROOT
84            ;;
85      esac
86      popd
87   done
88}
89
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94
95%files
96%defattr(-,root,root,-)
97%doc
98%{_bindir}/ccmakedep
99%{_bindir}/cleanlinks
100%{_bindir}/gccmakedep
101%{_bindir}/imake
102%{_bindir}/lndir
103%{_bindir}/makedepend
104%{_bindir}/makeg
105%{_bindir}/mergelib
106%{_bindir}/mkdirhier
107%{_bindir}/mkhtmlindex
108%{_bindir}/revpath
109%{_bindir}/xmkmf
110%dir %{_datadir}/X11
111%dir %{_datadir}/X11/config
112%{_datadir}/X11/config/*.cf
113%{_datadir}/X11/config/*.def
114%{_datadir}/X11/config/*.rules
115%{_datadir}/X11/config/*.tmpl
116#%dir %{_mandir}/man1x
117%{_mandir}/man1/ccmakedep.1.*
118%{_mandir}/man1/cleanlinks.1.*
119%{_mandir}/man1/gccmakedep.1.*
120%{_mandir}/man1/imake.1.*
121%{_mandir}/man1/lndir.1.*
122%{_mandir}/man1/makedepend.1.*
123%{_mandir}/man1/makeg.1.*
124%{_mandir}/man1/mergelib.1.*
125%{_mandir}/man1/mkdirhier.1.*
126%{_mandir}/man1/mkhtmlindex.1.*
127%{_mandir}/man1/revpath.1.*
128%{_mandir}/man1/xmkmf.1.*
129
130
131%changelog
132* Mon Mar 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.8-1
133- imake-1.0.8.
134- makedepend-1.0.6.
135- xorg-cf-files-1.0.6.
136
137* Sun Nov  2 2014 Ryoichi INAAGKI <ryo1@toki.waseda.jp> 1.0.7-2
138- moved to Development/Tools Group
139
140* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
141- imake-1.0.7
142- gccmakedep-1.0.3
143- makedepend-1.0.5
144- xorg-cf-files-1.0.5
145- update Patch2 (xorg-cf-files-1.0.5-redhat.patch)
146
147* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
148- imake-1.0.5
149- lndir-1.0.3
150- makedepend-1.0.4
151
152* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
153- xorg-cf-files-1.0.4
154- update Patch2 (xorg-cf-files-1.0.4-redhat.patch)
155- delete Patch0,1,3
156
157* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
158- imake-1.0.4
159- lndir-1.0.2
160- makedepend-1.0.3
161- xorg-cf-files-1.0.3
162- update Patch2 (xorg-cf-files-1.0.3-redhat.patch)
163- update Patch3 (xorg-cf-files-1.0.3-xprint.patch)
164- fix %%files
165
166* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
167- rebuilt with new toolchain
168
169* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
170- new versioning policy
171
172* Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
173- initial build for Vine Linux
174
175* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-5
176- Rebuild for build id
177
178* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
179- makedepend 1.0.1
180
181* Tue Jul 18 2006 Than Ngo <than@redhat.com> 1.0.2-3
182- cleanup patch files
183- update source files
184
185* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-2
186- rebuild
187
188* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
189- Update to imake-1.0.2, gccmakedep-1.0.2, xorg-cf-files-1.0.2
190
191* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
192- Fix ExtraXawReqs to reflect reality (libXp is unneeded)
193
194* Mon Mar 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
195- Updated xorg-cf-files-1.0.1-redhat.patch with fix for (#178177)
196
197* Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-2
198- Buildrequires: xorg-x11-proto-devel
199
200* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
201- bump again for double-long bug on ppc(64)
202
203* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
204- rebuilt for new gcc4.1 snapshot and glibc changes
205
206* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
207- Updated all packages to version 1.0.1 from X11R7.0
208
209* Wed Dec 21 2005 Than Ngo <than@redhat.com> 1.0.0-4
210- final fix for #173593
211
212* Tue Dec 20 2005 Than Ngo <than@redhat.com> 1.0.0-3
213- add correct XAppLoadDir #173593
214- add more macros for fedora
215
216* Mon Dec 19 2005 Than Ngo <than@redhat.com> 1.0.0-2
217- add some macros to fix problem in building of manpages
218
219* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
220- Updated all packages to version 1.0.0 from X11R7 RC4
221- Added new lndir, gccmakedep tarballs.  (#173478)
222- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
223- Removed all previous 'misc' patch, as we now pass --with-config-dir to
224  configure to specify the location of the Imake config files.
225- Renamed imake patch to xorg-cf-files-1.0.0-ProjectRoot.patch as it did not
226  patch imake at all.  This should probably be changed to be a custom Red Hat
227  host.def file that is added as a source line instead of randomly patching
228  various files.
229
230* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 0.99.2-5.1
231- rebuilt
232
233* Mon Nov 28 2005 Than Ngo <than@redhat.com> 0.99.2-5
234- add correct ProjectRoot for modular X
235
236* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-4
237- add missing host.conf
238
239* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-3
240- fix typo
241
242* Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-2
243- fix xmkmf to look config files in /usr/share/X11/config
244  instead /usr/%%{_lib}/X11/config/
245- add host.conf
246
247* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
248- Updated to imake-0.99.2, xorg-cf-files-0.99.2, makedepend-0.99.2 from
249  X11R7 RC2.
250
251* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
252- Initial build.
Note: See TracBrowser for help on using the repository browser.