source: projects/specs/trunk/i/ilmbase/ilmbase-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Abraction/convenience libraries
2
3Name:    ilmbase
4Version: 1.0.1
5Release: 1%{?_dist_release}
6
7Group:   System Environment/Libraries
8License: BSD
9URL:     http://www.openexr.com/
10Source0: http://download.savannah.nongnu.org/releases/openexr/ilmbase-%{version}.tar.gz
11Source1: http://download.savannah.nongnu.org/releases/openexr/ilmbase-%{version}.tar.gz.sig
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires: automake libtool
15
16# undefined pthread symbols
17Patch1: ilmbase-1.0.0-no_undefined.patch
18# move pthread linkage to Libs.private, tho probably not needed
19# if already using patch1 above.
20Patch2: ilmbase-1.0.0-pkgconfig.patch
21
22%description
23Half is a class that encapsulates the ilm 16-bit floating-point format.
24
25IlmThread is a thread abstraction library for use with OpenEXR
26and other software packages.
27
28Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
29and other useful 2D and 3D math functions.
30
31Iex is an exception-handling library.
32
33%package devel
34Summary: Headers and libraries for building apps that use %{name}
35Group:   Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: libGL-devel libGLU-devel
38Requires: pkgconfig
39%description devel
40%{summary}.
41
42
43%prep
44%setup -q
45
46%patch1 -p1 -b .no_undefined
47%patch2 -p1 -b .pkgconfig
48
49# for patch1
50./bootstrap
51
52
53%build
54%configure --disable-static
55
56make %{?_smp_mflags}
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
63
64rm -f  $RPM_BUILD_ROOT%{_libdir}/lib*.la
65
66
67%check
68make check
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74
75%post -p /sbin/ldconfig
76
77%postun -p /sbin/ldconfig
78
79
80%files
81%defattr(-,root,root,-)
82%doc AUTHORS ChangeLog COPYING NEWS README
83%{_libdir}/lib*.so.*
84
85%files devel
86%defattr(-,root,root,-)
87%{_includedir}/OpenEXR/
88%{_libdir}/lib*.so
89%{_libdir}/pkgconfig/*
90
91
92%changelog
93* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
94- initial build for Vine Linux
95
96* Fri Feb 08 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.1-2
97- respin (gcc43)
98
99* Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.1-1
100- ilmbase-1.0.1
101
102* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-3
103- include *.tar.sig in sources
104
105* Mon Oct 08 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-2
106- update %%summary
107- -devel: +Requires: libGL-devel libGLU-devel
108- make install ... INSTALL="install -p" to preserve timestamps
109
110
111* Thu Aug 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-1
112- ilmbase-1.0.0 (first try)
113
Note: See TracBrowser for help on using the repository browser.