source: projects/specs/trunk/i/iksemel/iksemel-vl.spec @ 9127

Revision 9127, 5.2 KB checked in by inagaki, 9 years ago (diff)

2014-12-01 Ryoichi INAGAKI <ryo1@…>

  • iksemel, netatalk: rebuilt
  • samba: updated Group


Line 
1Summary:        An XML parser library designed for Jabber applications
2Summary(ja):    Jabber アプリケーションのために設計された XML パーサ
3
4Name:           iksemel
5Version:        1.4
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://code.google.com/p/iksemel/
11Source0:        http://iksemel.googlecode.com/files/iksemel-%{version}.tar.gz
12
13Patch0:         0001-Fix-issues-compiling-with-newer-gnutls.patch
14Patch1:         0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch
15Patch2:         0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires:  gnutls-devel > 2
19BuildRequires:  libgcrypt-devel
20BuildRequires:  autoconf
21BuildRequires:  automake
22BuildRequires:  libtool > 2
23BuildRequires:  texinfo
24
25%description
26An XML parser library designed for Jabber applications. It is coded in
27ANSI C for POSIX compatible environments, thus highly portable.
28
29%package devel
30Summary:        Development files for iksemel
31Summary(ja):    iksemel の開発ファイル
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       gnutls-devel
35Requires:       pkgconfig
36Requires(post): /sbin/install-info
37Requires(preun): /sbin/install-info
38
39%description devel
40Development files for iksemel.
41
42%package utils
43Summary:        Utilities for iksemel
44Summary(ja):    iksemel 用のユーティリティ
45Group:          Applications/Internet
46Requires:       %{name} = %{version}-%{release}
47
48%description utils
49Utlity programs for iksemel.
50
51%prep
52%setup0 -q
53%patch0 -p1
54%patch1 -p1
55%patch2 -p1
56
57# force rebuilding of the info file
58rm doc/iksemel
59
60%build
61# We need to re-run the autotools because the patch we apply modifies
62# the configure.ac and src/Makefile.am
63libtoolize --copy --force --automake
64aclocal
65autoheader
66automake --add-missing --force-missing --gnu --include-deps
67autoconf
68%configure --disable-static --disable-rpath
69make %{?_smp_mflags}
70
71%install
72rm -rf %{buildroot}
73make install DESTDIR=%{buildroot}
74
75rm -f %{buildroot}%{_libdir}/*.la
76rm -f %{buildroot}%{_infodir}/dir
77
78mv %{buildroot}%{_infodir}/iksemel %{buildroot}%{_infodir}/iksemel.info
79
80%check
81%ifnarch ppc
82make check
83%endif
84
85%clean
86rm -rf %{buildroot}
87
88%postun -p /sbin/ldconfig
89
90%post -p /sbin/ldconfig
91
92%post devel
93/sbin/install-info --quiet %{_infodir}/%{name}.info %{_infodir}/dir || :
94
95%preun devel
96if [ "$1" = 0 ]; then
97    /sbin/install-info --quiet --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
98fi
99
100
101%files
102%defattr(-,root,root,-)
103%doc AUTHORS ChangeLog COPYING HACKING NEWS README TODO
104%{_libdir}/libiksemel.so.*
105
106%files devel
107%defattr(-,root,root,-)
108%doc COPYING
109%{_libdir}/libiksemel.so
110%{_includedir}/iksemel.h
111%{_libdir}/pkgconfig/iksemel.pc
112%{_infodir}/iksemel.info*
113
114%files utils
115%defattr(-,root,root,-)
116%doc COPYING
117%{_bindir}/ikslint
118%{_bindir}/iksperf
119%{_bindir}/iksroster
120
121%changelog
122* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4-2
123- rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
124
125* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
126- update to 1.4
127- remove old patches
128- add patches from fedora
129   - Patch0 (0001-Fix-issues-compiling-with-newer-gnutls.patch)
130   - Patch1 (0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch)
131   - Patch2 (0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch)
132
133* Tue May 05 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3-2vl5
134- rebuild with gnutls 2.6.6, libtool 2.2.6
135
136* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.3-1vl5
137- applied new versioning policy, spec in utf-8
138
139* Wed Dec 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
140- initial build for Vine Linux
141
142* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-2
143- Disable "make check" on PPC again.
144
145* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-1
146- Update to 1.3
147- Don't need to BR pkgconfig because gnutls-devel now requires it properly.
148- Update license.
149- Run "make check" on PPC
150- Update patches so that they apply to 1.3
151- Update URLs
152
153* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-13
154- ppp != ppc
155
156* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-12
157- Don't run make check on PPC - tests failing.
158
159* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-11
160- Add patch from Hans de Goede that fixes 64 bit issues
161- Re-enable "make check".
162- Remove tabs from specfile.
163
164* Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-10
165- Bump release and rebuild.
166
167* Wed Aug  2 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-6
168- Temporarily disable make check until problems with it can be figured out.
169
170* Thu Jul 27 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-5
171- Patch to use SHA1 hashing routines from libgcrypt rather than
172  broken internal code.  This means that we need to BR autoools
173  to regenerate comfigure script and makefiles.
174
175* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-4
176- Don't re-run autotools, fix rpath in a different way.
177
178* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-3
179- Add a %check section.
180- Add BR for libtool.
181
182* Tue May 30 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-2
183- Add texinfo BR
184
185* Mon May 29 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-1
186- First version for Fedora Extras.
187
Note: See TracBrowser for help on using the repository browser.