source: projects/specs/trunk/i/iksemel/iksemel-vl.spec @ 10096

Revision 10096, 5.4 KB checked in by tomop, 8 years ago (diff)

iksemel-1.4-3

Line 
1Summary:        An XML parser library designed for Jabber applications
2Summary(ja):    Jabber アプリケーションのために設計された XML パーサ
3
4Name:           iksemel
5Version:        1.4
6Release:        3%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://code.google.com/p/iksemel/
11Source0:        http://iksemel.googlecode.com/files/iksemel-%{version}.tar.gz
12
13Patch0:         0001-Fix-issues-compiling-with-newer-gnutls.patch
14Patch1:         0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch
15Patch2:         0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch
16Patch3:         secure_gnutls_options.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires:  gnutls-devel > 2
20BuildRequires:  libgcrypt-devel
21BuildRequires:  autoconf
22BuildRequires:  automake
23BuildRequires:  libtool > 2
24BuildRequires:  texinfo
25
26%description
27An XML parser library designed for Jabber applications. It is coded in
28ANSI C for POSIX compatible environments, thus highly portable.
29
30%package devel
31Summary:        Development files for iksemel
32Summary(ja):    iksemel の開発ファイル
33Group:          Development/Libraries
34Requires:       %{name} = %{version}-%{release}
35Requires:       gnutls-devel
36Requires:       pkgconfig
37Requires(post): /sbin/install-info
38Requires(preun): /sbin/install-info
39
40%description devel
41Development files for iksemel.
42
43%package utils
44Summary:        Utilities for iksemel
45Summary(ja):    iksemel 用のユーティリティ
46Group:          Applications/Internet
47Requires:       %{name} = %{version}-%{release}
48
49%description utils
50Utlity programs for iksemel.
51
52%prep
53%setup0 -q
54%patch0 -p1
55%patch1 -p1
56%patch2 -p1
57%patch3 -p1
58
59# force rebuilding of the info file
60rm doc/iksemel
61
62%build
63# We need to re-run the autotools because the patch we apply modifies
64# the configure.ac and src/Makefile.am
65libtoolize --copy --force --automake
66aclocal
67autoheader
68automake --add-missing --force-missing --gnu --include-deps
69autoconf
70%configure --disable-static --disable-rpath
71make %{?_smp_mflags}
72
73%install
74rm -rf %{buildroot}
75make install DESTDIR=%{buildroot}
76
77rm -f %{buildroot}%{_libdir}/*.la
78rm -f %{buildroot}%{_infodir}/dir
79
80mv %{buildroot}%{_infodir}/iksemel %{buildroot}%{_infodir}/iksemel.info
81
82%check
83%ifnarch ppc
84make check
85%endif
86
87%clean
88rm -rf %{buildroot}
89
90%postun -p /sbin/ldconfig
91
92%post -p /sbin/ldconfig
93
94%post devel
95/sbin/install-info --quiet %{_infodir}/%{name}.info %{_infodir}/dir || :
96
97%preun devel
98if [ "$1" = 0 ]; then
99    /sbin/install-info --quiet --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
100fi
101
102
103%files
104%defattr(-,root,root,-)
105%doc AUTHORS ChangeLog COPYING HACKING NEWS README TODO
106%{_libdir}/libiksemel.so.*
107
108%files devel
109%defattr(-,root,root,-)
110%doc COPYING
111%{_libdir}/libiksemel.so
112%{_includedir}/iksemel.h
113%{_libdir}/pkgconfig/iksemel.pc
114%{_infodir}/iksemel.info*
115
116%files utils
117%defattr(-,root,root,-)
118%doc COPYING
119%{_bindir}/ikslint
120%{_bindir}/iksperf
121%{_bindir}/iksroster
122
123%changelog
124* Mon Mar 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4-3
125- added Patch3 to build with gnutls-3.4.
126
127* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4-2
128- rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
129
130* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
131- update to 1.4
132- remove old patches
133- add patches from fedora
134   - Patch0 (0001-Fix-issues-compiling-with-newer-gnutls.patch)
135   - Patch1 (0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch)
136   - Patch2 (0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch)
137
138* Tue May 05 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3-2vl5
139- rebuild with gnutls 2.6.6, libtool 2.2.6
140
141* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.3-1vl5
142- applied new versioning policy, spec in utf-8
143
144* Wed Dec 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
145- initial build for Vine Linux
146
147* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-2
148- Disable "make check" on PPC again.
149
150* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-1
151- Update to 1.3
152- Don't need to BR pkgconfig because gnutls-devel now requires it properly.
153- Update license.
154- Run "make check" on PPC
155- Update patches so that they apply to 1.3
156- Update URLs
157
158* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-13
159- ppp != ppc
160
161* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-12
162- Don't run make check on PPC - tests failing.
163
164* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-11
165- Add patch from Hans de Goede that fixes 64 bit issues
166- Re-enable "make check".
167- Remove tabs from specfile.
168
169* Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-10
170- Bump release and rebuild.
171
172* Wed Aug  2 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-6
173- Temporarily disable make check until problems with it can be figured out.
174
175* Thu Jul 27 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-5
176- Patch to use SHA1 hashing routines from libgcrypt rather than
177  broken internal code.  This means that we need to BR autoools
178  to regenerate comfigure script and makefiles.
179
180* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-4
181- Don't re-run autotools, fix rpath in a different way.
182
183* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-3
184- Add a %check section.
185- Add BR for libtool.
186
187* Tue May 30 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-2
188- Add texinfo BR
189
190* Mon May 29 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-1
191- First version for Fedora Extras.
192
Note: See TracBrowser for help on using the repository browser.