source: projects/specs/trunk/i/ifplugd/ifplugd-vl.spec @ 521

Revision 521, 4.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Detect and perform actions when an ethernet cable is (un)plugged.
2Name: ifplugd
3Version: 0.28
4Release: 2%{_dist_release}
5Source0: %{name}-%{version}.tar.gz
6Source1: ifplugd.init
7Patch10: ifplugd-0.28-interface.c.patch
8License: GPL
9Group: System Environment/Daemons
10URL: http://www.stud.uni-hamburg.de/users/lennart/projects/ifplugd/
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12Prefix: %{_prefix}
13Requires: libdaemon >= 0.5
14Requires: initscripts >= 7.2.6
15Buildprereq: libdaemon-devel >= 0.5, pkgconfig
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21ifplugd is a Linux daemon which will automatically configure your
22ethernet device when a cable is plugged in and automatically
23unconfigure it if the cable is pulled. This is useful on laptops with
24onboard network adapters, since it will only configure the interface
25when a cable is really connected.
26
27%description -l ja
28ifplugd はケーブルの抜き差しで ethernet device を自動的に有効・無効に
29する Linux の daemon です。
30この機能は ethernet device を内蔵している laptop のマシンで有用です。
31
32%prep
33%setup -q
34%patch10 -p1
35
36# patching Makefile / man page
37cd man
38perl -p -i -e 's@/usr/local@@' *.[58]
39cd ..
40
41%build
42%configure --disable-lynx --disable-xmltoman --disable-subversion
43make
44
45%install
46[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
47make DESTDIR=$RPM_BUILD_ROOT install
48
49# replace init scirpt
50rm -f $RPM_BUILD_ROOT/etc/init.d/ifplugd
51install -d $RPM_BUILD_ROOT%{_initdir}
52install %{SOURCE1} $RPM_BUILD_ROOT%{_initdir}/ifplugd
53
54# Brush docs
55cp -r doc doc2
56rm doc/Makefile*
57rm doc/*.in
58rm doc/*.SuSE
59
60%clean
61[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
62
63%post
64/sbin/chkconfig --add %{name}
65
66%preun
67if [ $1 = 0 ] ; then
68  /sbin/chkconfig --del %{name}
69fi
70
71%files
72%defattr(-,root,root)
73%doc LICENSE README doc/
74%{_sbindir}/ifplugd
75%{_sbindir}/ifplugstatus
76%{_mandir}/man8/*
77%{_mandir}/man5/*
78%{_initdir}/ifplugd
79%config(noreplace) /etc/ifplugd/ifplugd.conf
80%config(noreplace) /etc/ifplugd/ifplugd.action
81
82%changelog
83* Thu Mar 05 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
84- 0.28-2
85- spec in UTF-8
86
87* Wed Mar 04 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
88- 0.28-1
89- new versioning policy
90- add patch10 to fix header file compatibility issue
91- rebuild with libdaemon 0.13
92
93* Sun Oct 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
94- 0.28-0vl5
95- drop Source10, Source11, Patch1 (These ware for Vine 3.2)
96- Require initscripts >= 7.2.6
97
98* Sat May 20 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
99- 0.28-0vl4
100- changed Group to Systen Environment/Daemons
101
102* Sun Feb 12 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
103- 0.28-0vl3
104- rebuild for VineSeed
105
106* Fri Nov 18 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
107- 0.28-0vl2
108- release for VinePlus 3.x
109
110* Fri Nov 18 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
111- 0.28-0vl1
112- release for VinePlus 2.x
113- add requires initscripts >= 6.51-1vl26
114
115* Wed Sep 21 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
116- 0.28-0vl0.3
117- test release for Vine 3.2
118- add patch1, ifup.ifplugd, ifdown.ifplugd for Vine 3.2
119- add requires initscripts >= 6.51-1vl33.3
120
121* Wed Aug 31 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
122- 0.28-0vl0.2
123- upstream release for VinePlus 3.0/3.1
124- add configure option (--disable-subversion)
125- brush up doc files
126
127* Wed Aug 31 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
128- 0.28-0vl0.1
129- upstream release for VinePlus 2.5/2.6
130- add configure option (--disable-subversion)
131- brush up doc files
132
133* Thu Dec 02 2004 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
134- 0.25-0vl2
135- upstream release for VinePlus 3.0/3.1
136
137* Thu Dec 02 2004 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
138- 0.25-0vl1
139- upstream release for VinePlus 2.5/2.6
140
141* Fri Feb 27 2004 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
142- 0.22-0vl1
143- upstream release
144- update Requires/Buildprereq tag
145- update files list (ifstatus -> ifplugstatus)
146- add japanese discription
147
148* Sun Aug 03 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
149- 0.15-0vl2
150- add Vendor / Distribution tag for VineLinux
151
152* Sat Aug 02 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
153- 0.15-0vl1
154- updated 0.15
155- change make/install method (./configure)
156- add Require libdaemon / Buildprereq libdaemon-devel
157- update ifplugd.init
158- for Vine 2.5/6
159
160* Sat Jun 06 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
161- 0.13-0vl3
162- Fix install location init script
163- Fix changelog typo
164
165* Fri Jun 05 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
166- 0.13-0vl2
167- Fix ifplugd init script
168- Fix install location man pages
169
170* Fri Jun 05 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
171- 0.13-0vl1
172- 1st build for VinePlus 2.5/2.6
173- discription from ifplugd-0.13-3mdk.src.rpm. Thanx!
Note: See TracBrowser for help on using the repository browser.