source: projects/specs/trunk/i/icu/icu-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define sover 40
2Summary: International Components for Unicode
3Summary(ja): ユニコード用国際化コンポーネント
4Name: icu
5Version: 4.0.1
6Release: 1%{?_dist_release}
7Group:   Development/Tools
8License: MIT
9URL:     http://www.ibm.com/software/globalization/icu/
10
11Source0: http://download.icu-project.org/files/icu4c/4.0.1/icu4c-4_0_1-src.tgz
12Source1: http://download.icu-project.org/files/icu4c/4.0.1/icu4c-4_0_1-docs.zip
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15#Requires: libicu%{sover} = %{version}
16Requires: libicu = %{version}-%{release}
17BuildRequires: gcc-c++
18BuildRequires: unzip perl
19
20%description
21ICU is a C++ and C library that provides robust and full-featured Unicode
22support. This package contains the Unicode character database and derived
23properties, along with converters and time zones data.
24
25#package -n libicu%{sover}
26%package -n libicu
27Summary: International Components for Unicode (library)
28Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
29Group: System Environment/Libraries
30Provides: libicu%{sover} = %{version}-%{release}
31
32#description -n libicu%{sover}
33%description -n libicu
34ICU is a C++ and C library that provides robust and full-featured Unicode
35support. This package contains the runtime libraries for ICU. It does not
36contain any of the data files needed at runtime.
37
38%package -n libicu-devel
39Summary: Header files, libraries and development documentation for libicu
40Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
41Group: Development/Libraries
42Requires: libicu = %{version}-%{release}
43
44%description -n libicu-devel
45This package contains the header files, static libraries for %{name}.
46If you like to develop programs using %{name}, you will need to install
47%{name}-devel.
48
49%package -n libicu-doc
50Summary: Documentation for International Components for Unicode
51Summary(ja): ユニコード用国際化コンポーネントのドキュメント
52Group: Applications/Documentation
53
54%description -n libicu-doc
55This package contains the development documentation for %{name}.
56
57%prep
58%setup -q -n %{name}
59find . -name CVS -o -name .cvsignore | xargs -r rm -rf
60perl -pi -e 's/^(HAVE_DOT\b.*=).*$/$1 YES/' source/Doxyfile.in
61
62mkdir docs
63pushd docs
64unzip %{SOURCE1}
65popd
66
67%build
68cd source
69export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
70export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
71%configure --enable-static --with-data-packaging=library --disable-samples
72make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make -C source install DESTDIR=$RPM_BUILD_ROOT
77chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
78
79%check || :
80make -C source check
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -n libicu -p /sbin/ldconfig
86
87%postun -n libicu -p /sbin/ldconfig
88
89%files
90%defattr(-, root, root, 0755)
91%doc license.html readme.html
92#%{_sysconfdir}/icu/
93%{_bindir}/derb
94%{_bindir}/genbrk
95%{_bindir}/gencnval
96%{_bindir}/genctd
97%{_bindir}/genrb
98%{_bindir}/makeconv
99%{_bindir}/pkgdata
100%{_bindir}/uconv
101%{_sbindir}/*
102%{_mandir}/man?/*
103%exclude %{_mandir}/man1/icu-config.1*
104
105%files -n libicu
106%defattr(-, root, root, 0755)
107%{_libdir}/*.so.*
108
109%files -n libicu-devel
110%defattr(-, root, root, 0755)
111%{_bindir}/icu-config
112%{_includedir}/layout
113%{_includedir}/unicode
114%{_libdir}/*.so
115%{_libdir}/*.a
116%{_libdir}/%{name}
117%{_mandir}/man1/icu-config.1*
118%dir %{_datadir}/icu/
119%dir %{_datadir}/icu/4.0.1
120%{_datadir}/icu/4.0.1/config
121%{_datadir}/icu/4.0.1/install-sh
122%{_datadir}/icu/4.0.1/mkinstalldirs
123%doc %{_datadir}/icu/4.0.1/license.html
124
125%files -n libicu-doc
126%defattr(-,root,root,-)
127%doc docs/*
128
129%changelog
130* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.1-1vl5
131- new upstream release
132- updated URL
133
134* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 3.6-1vl5
135- applied new versioning policy, spec in utf-8
136
137* Tue Sep  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.6-0vl1
138- updated to 3.6
139- removed ".so ver" from libicu package name
140- changed Group to Development/Tools
141- changed libicu-doc Group to Applications/Documentation
142
143* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.4.1-0vl1
144- updated to 3.4.1
145
146* Sun Jul 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.2-3vl1
147- updated to 3.2 based on Fedora extra
148- new subpackage libicu-doc for API document
149
150* Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0-0vl1
151- Build for Vine Linux
152- add developers document to devel package
153- add Japanese summary
154
155* Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-1
156- Fixed a typo in the dependencies "libuci" should be "libicu". (Daniel Demus)
157
158* Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-0
159- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.