source: projects/specs/trunk/i/icu/icu-vl.spec @ 12339

Revision 12339, 6.5 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

icu-66.1-1

openssh-8.2p1-1

php74-7.4.4-1

postfix-3.5.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define sover 66
4%define minorver 1
5
6Summary: International Components for Unicode
7Summary(ja): ユニコード用国際化コンポーネント
8Name: icu
9Version: %{sover}.%{minorver}
10Release: 1%{?_dist_release}
11Group:   Development/Tools
12License: MIT
13URL:     http://icu-project.org/
14
15Source0: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-src.tgz
16Source1: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-docs.zip
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gcc-c++
20BuildRequires: unzip perl
21Requires: libicu%{sover} = %{version}-%{release}
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27ICU is a C++ and C library that provides robust and full-featured Unicode
28support. This package contains the Unicode character database and derived
29properties, along with converters and time zones data.
30
31%package -n libicu%{sover}
32Summary: International Components for Unicode (library)
33Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
34Group: System Environment/Libraries
35Provides: libicu = %{version}-%{release}
36
37%description -n libicu%{sover}
38ICU is a C++ and C library that provides robust and full-featured Unicode
39support. This package contains the runtime libraries for ICU. It does not
40contain any of the data files needed at runtime.
41
42%package -n libicu-devel
43Summary: Header files, libraries and development documentation for libicu
44Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
45Group: Development/Libraries
46Requires: libicu%{sover} = %{version}-%{release}
47
48%description -n libicu-devel
49This package contains the header files, static libraries for %{name}.
50If you like to develop programs using %{name}, you will need to install
51%{name}-devel.
52
53%package -n libicu-doc
54Summary: Documentation for International Components for Unicode
55Summary(ja): ユニコード用国際化コンポーネントのドキュメント
56Group: Applications/Documentation
57Requires: libicu%{sover} = %{version}-%{release}
58
59%description -n libicu-doc
60This package contains the development documentation for %{name}.
61
62# compat32
63%if %{build_compat32}
64%package -n compat32-libicu%{sover}
65Summary: International Components for Unicode (library)
66Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
67Group: System Environment/Libraries
68Provides: compat32-libicu = %{version}-%{release}
69
70%description -n compat32-libicu%{sover}
71ICU is a C++ and C library that provides robust and full-featured Unicode
72support. This package contains the runtime libraries for ICU. It does not
73contain any of the data files needed at runtime.
74%endif
75
76
77%prep
78%setup -q -n icu
79
80find . -name CVS -o -name .cvsignore | xargs -r rm -rf
81perl -pi -e 's/^(HAVE_DOT\b.*=).*$/$1 YES/' source/Doxyfile.in
82
83mkdir docs
84pushd docs
85unzip %{SOURCE1}
86popd
87
88%build
89cd source
90export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
91export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
92%configure --disable-static --with-data-packaging=library --disable-samples
93make %{?_smp_mflags}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97make -C source install DESTDIR=$RPM_BUILD_ROOT
98cp -pR ./source/tools/ctestfw/libicutest.so* $RPM_BUILD_ROOT/%{_libdir}
99chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
100
101%ifarch x86_64
102%check || :
103make %{?_smp_mflags} -C source check
104%endif
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -n libicu%{sover} -p /sbin/ldconfig
110
111%postun -n libicu%{sover} -p /sbin/ldconfig
112
113%files
114%defattr(-, root, root, 0755)
115%license LICENSE
116%doc license.html readme.html
117%{_bindir}/derb
118%{_bindir}/genbrk
119%{_bindir}/gencfu
120%{_bindir}/gencnval
121%{_bindir}/gendict
122%{_bindir}/genrb
123%{_bindir}/icuinfo
124%{_bindir}/makeconv
125%{_bindir}/pkgdata
126%{_bindir}/uconv
127%{_sbindir}/*
128%{_mandir}/man?/*
129%exclude %{_mandir}/man1/icu-config.1*
130
131%files -n libicu%{sover}
132%license LICENSE
133%defattr(-, root, root, 0755)
134%{_libdir}/*.so.*
135
136%files -n libicu-devel
137%license LICENSE
138%defattr(-, root, root, 0755)
139%{_bindir}/icu-config
140%{_includedir}/unicode
141%{_libdir}/*.so
142%{_libdir}/%{name}
143%{_libdir}/pkgconfig/*.pc
144%{_mandir}/man1/icu-config.1*
145%{_datadir}/%{name}
146
147%files -n libicu-doc
148%license LICENSE
149%defattr(-,root,root,-)
150%doc docs/*
151
152%if %{build_compat32}
153%files -n compat32-libicu%{sover}
154%license LICENSE
155%defattr(-, root, root, 0755)
156%{_libdir}/*.so.*
157%endif
158
159%changelog
160* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 66.1-1
161- updated to 66.1.
162
163* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-2
164- made to build compat32-* package.
165
166* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-1
167- updated to 65.1.
168
169* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.3-1
170- updated to 60.3.
171- disabled tests on i686.
172
173* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.2-1
174- updated to 60.2.
175
176* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-2
177- rebuild with gcc-5.4.0
178
179* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-1
180- update to 56.1
181
182* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 54.1-1
183- update to 54.1
184
185* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 52.1-1
186- new upstream release
187
188* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 51.2-1
189- update to 51.2
190
191* Tue Apr 13 2010 Shu KONNO <owa@bg.wakwak.com> 4.4-2
192- install libicutest.so*
193
194* Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4-1
195- new upstream release
196- built with new toolchain
197
198* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.1-1vl5
199- new upstream release
200- updated URL
201
202* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 3.6-1vl5
203- applied new versioning policy, spec in utf-8
204
205* Tue Sep  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.6-0vl1
206- updated to 3.6
207- removed ".so ver" from libicu package name
208- changed Group to Development/Tools
209- changed libicu-doc Group to Applications/Documentation
210
211* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.4.1-0vl1
212- updated to 3.4.1
213
214* Sun Jul 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.2-3vl1
215- updated to 3.2 based on Fedora extra
216- new subpackage libicu-doc for API document
217
218* Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0-0vl1
219- Build for Vine Linux
220- add developers document to devel package
221- add Japanese summary
222
223* Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-1
224- Fixed a typo in the dependencies "libuci" should be "libicu". (Daniel Demus)
225
226* Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-0
227- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.