source: projects/specs/trunk/i/icedtea-web/icedtea-web-vl.spec @ 7586

Revision 7586, 7.0 KB checked in by daisuke, 11 years ago (diff)

icedtea-web: update to 1.3.1

Line 
1# We require at the least the first release java-1.6.0-openjdk
2# with IcedTea6 1.10
3%define min_openjdk_version 1.6.0.0-60
4%define multilib_arches ppc64 sparc64 x86_64
5
6# Version of java
7%define javaver 1.7.0
8
9# Alternatives priority
10%define priority 17000
11
12%ifarch %{ix86}
13%define archinstall i386
14%endif
15%ifarch x86_64
16%define archinstall amd64
17%endif
18# 32 bit sparc, optimized for v9
19%ifarch sparcv9
20%define archinstall sparc
21%endif
22# 64 bit sparc
23%ifarch sparc64
24%define archinstall sparcv9
25%endif
26
27%ifarch %{multilib_arches}
28%define javadir     %{_jvmdir}/java-%{javaver}-openjdk.%{_arch}
29%define jredir      %{_jvmdir}/jre-%{javaver}-openjdk.%{_arch}
30%define jre6dir     %{_jvmdir}/jre-1.6.0-openjdk.%{_arch}
31%define javaplugin  libjavaplugin.so.%{_arch}
32%else
33%define javadir     %{_jvmdir}/java-%{javaver}-openjdk
34%define jredir      %{_jvmdir}/jre-%{javaver}-openjdk
35%define jre6dir     %{_jvmdir}/jre-1.6.0-openjdk
36%define javaplugin  libjavaplugin.so
37%endif
38
39%define binsuffix      .itweb
40
41Name:           icedtea-web
42Version:        1.3.1
43Release:        1%{?_dist_release}
44Summary:        Java browser plug-in and Web Start implementation
45Summary(ja):    Java ブラウザプラグイン
46
47Group:      Applications/Internet
48License:    LGPLv2+ and GPLv2 with exceptions
49URL:        http://icedtea.classpath.org/wiki/IcedTea-Web
50Source0:    http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
51
52BuildRequires:  java-%{javaver}-openjdk-devel
53BuildRequires:  desktop-file-utils
54BuildRequires:  gecko-devel
55BuildRequires:  glib2-devel
56BuildRequires:  gtk2-devel
57BuildRequires:  xulrunner-devel
58
59# For functionality and the OpenJDK dirs
60Requires:      java-%{javaver}-openjdk
61
62# Post requires alternatives to install plugin alternative.
63Requires(post):   alternatives
64
65# Postun requires alternatives to uninstall plugin alternative.
66Requires(postun): alternatives
67
68# Standard JPackage plugin provides.
69Provides: java-plugin = %{javaver}
70Provides: javaws      = %{javaver}
71
72Provides:   java-1.7.0-openjdk-plugin
73Obsoletes:  java-1.6.0-openjdk-plugin <= %{min_openjdk_version}
74
75# IcedTea is only built on these archs for now
76ExclusiveArch: x86_64 i686 %{arm}
77
78%description
79The IcedTea-Web project provides a Java web browser plugin, an implementation
80of Java Web Start (originally based on the Netx project) and a settings tool to
81manage deployment settings for the aforementioned plugin and Web Start
82implementations.
83
84%package javadoc
85Summary:    API documentation for IcedTea-Web
86Summary(ja):    API documentation for IcedTea-Web
87Group:      Documentation
88Requires:   jpackage-utils
89BuildArch:  noarch
90
91%description javadoc
92This package contains Javadocs for the IcedTea-Web project.
93
94%prep
95%setup -q
96
97%build
98autoconf
99./configure \
100    --with-pkgversion=vine-%{release}-%{_arch} \
101    --docdir=%{_datadir}/javadoc/%{name} \
102    --with-jdk-home=%{javadir} \
103    --with-jre-home=%{jredir} \
104    --libdir=%{_libdir} \
105    --program-suffix=%{binsuffix} \
106    --prefix=%{_prefix}
107
108make CXXFLAGS="$RPM_OPT_FLAGS"
109
110%install
111rm -rf $RPM_BUILD_ROOT
112make install DESTDIR=$RPM_BUILD_ROOT
113
114# Move javaws man page to a more specific name
115mv $RPM_BUILD_ROOT/%{_mandir}/man1/javaws.1 $RPM_BUILD_ROOT/%{_mandir}/man1/javaws-itweb.1
116
117# Install desktop files.
118install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/{applications,pixmaps}
119cp javaws.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
120desktop-file-install --vendor ''\
121  --dir $RPM_BUILD_ROOT%{_datadir}/applications javaws.desktop
122desktop-file-install --vendor ''\
123  --dir $RPM_BUILD_ROOT%{_datadir}/applications itweb-settings.desktop
124
125mkdir -p $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/
126
127%post
128if [ $1 -gt 1 ]
129then
130alternatives --remove %{javaplugin} \
131  %{jre6dir}/lib/%{archinstall}/IcedTeaPlugin.so 2>/dev/null || :       
132fi
133
134%posttrans
135update-desktop-database &> /dev/null || :
136alternatives \
137  --install %{_libdir}/mozilla/plugins/libjavaplugin.so %{javaplugin} \
138  %{_libdir}/IcedTeaPlugin.so %{priority} \
139  --slave %{_bindir}/javaws javaws %{_prefix}/bin/javaws%{binsuffix} \
140  --slave %{_mandir}/man1/javaws.1.gz javaws.1.gz \
141  %{_mandir}/man1/javaws-itweb.1.gz
142
143exit 0
144
145%postun
146update-desktop-database &> /dev/null || :
147if [ $1 -eq 0 ]
148then
149  alternatives --remove %{javaplugin} \
150    %{_libdir}/IcedTeaPlugin.so
151fi
152
153exit 0
154
155%files
156%defattr(-,root,root,-)
157%doc NEWS README COPYING
158%{_prefix}/bin/*
159%{_libdir}/IcedTeaPlugin.so
160%{_datadir}/applications/*
161%{_datadir}/icedtea-web
162%{_datadir}/man/man1/*
163%{_datadir}/pixmaps/*
164%dir %{_libdir}/mozilla/plugins/
165
166%files javadoc
167%defattr(-,root,root,-)
168%{_datadir}/javadoc/%{name}
169%doc COPYING
170
171%changelog
172* Mon Mar 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-1
173- update to 1.3.1
174
175* Mon Sep 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp>  1.2.1-1
176- initial build for Vine Linux
177
178* Tue Jul 31 2012 Deepak Bhole <dbhole@redhat.com> 1.2.1-1
179- Updated to 1.2.1
180- Resolves: RH840592/CVE-2012-3422
181- Resolves: RH841345/CVE-2012-3423
182
183* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
185
186* Thu May 03 2012 Deepak Bhole <dbhole@redhat.com> 1.2-4
187- Resolves rhbz#814585
188- Fixed java-plugin provides and added one for javaws
189
190* Tue Apr 17 2012 Deepak Bhole <dbhole@redhat.com> 1.2-3
191- Updated summary
192- Fixed virtual provide
193
194* Tue Mar 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.2-2
195- Enable building on ARM platforms
196
197* Mon Mar 05 2012 Deepak Bhole <dbhole@redhat.com> 1.2-1
198- Updated to 1.2
199
200* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-4
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
202
203* Fri Nov 25 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-3
204- Resolves rhbz#757191
205- Bumped min_openjdk_version to -60 (latest)
206
207* Thu Nov 24 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-2
208- Resolves: rhbz#742887. Do not own directories not created by the package.
209
210* Tue Nov 08 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-1
211- Updated to 1.1.4
212- Added npapi-fix patch so that the plug-in compiles with xulrunner 8
213
214* Thu Sep 01 2011 Deepak Bhole <dbhole@redhat.com> 1.1.2-1
215- Updated to 1.1.2
216- Removed all patches (now upstream)
217- Resolves: rhbz# 734890
218
219* Tue Aug 23 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-3
220- Added patch to allow install to jre dir
221- Fixed requirement for java-1.7.0-openjdk
222
223* Tue Aug 09 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-2
224- Fixed file ownership so that debuginfo is not in main package
225
226* Wed Aug 03 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-1
227- Bump to 1.1.1
228- Added patch for PR768 and PR769
229
230* Wed Jul 20 2011 Deepak Bhole <dbhole@redhat.com> 1.0.4-1
231- Bump to 1.0.4
232- Fixed rhbz#718164: Home directory path disclosure to untrusted applications
233- Fixed rhbz#718170: Java Web Start security warning dialog manipulation
234
235* Mon Jun 13 2011 Deepak Bhole <dbhole@redhat.com> 1.0.3-1
236- Update to 1.0.3
237- Resolves: rhbz#691259
238
239* Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-2
240- Fixed incorrect macro value for min_openjdk_version
241- Use posttrans instead of post, so that upgrade from old plugin works
242
243* Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-1
244- Initial build
Note: See TracBrowser for help on using the repository browser.