source: projects/specs/trunk/i/icedtea-web/icedtea-web-vl.spec @ 8122

Revision 8122, 7.1 KB checked in by daisuke, 10 years ago (diff)

icedtea-web: update to 1.4.1

Line 
1# We require at the least the first release java-1.6.0-openjdk
2# with IcedTea6 1.10
3%define min_openjdk_version 1.6.0.0-60
4%define multilib_arches ppc64 sparc64 x86_64
5
6# Version of java
7%define javaver 1.7.0
8
9# Alternatives priority
10%define priority 17000
11
12%ifarch %{ix86}
13%define archinstall i386
14%endif
15%ifarch x86_64
16%define archinstall amd64
17%endif
18# 32 bit sparc, optimized for v9
19%ifarch sparcv9
20%define archinstall sparc
21%endif
22# 64 bit sparc
23%ifarch sparc64
24%define archinstall sparcv9
25%endif
26
27%ifarch %{multilib_arches}
28%define javadir     %{_jvmdir}/java-%{javaver}-openjdk.%{_arch}
29%define jredir      %{_jvmdir}/jre-%{javaver}-openjdk.%{_arch}
30%define jre6dir     %{_jvmdir}/jre-1.6.0-openjdk.%{_arch}
31%define javaplugin  libjavaplugin.so.%{_arch}
32%else
33%define javadir     %{_jvmdir}/java-%{javaver}-openjdk
34%define jredir      %{_jvmdir}/jre-%{javaver}-openjdk
35%define jre6dir     %{_jvmdir}/jre-1.6.0-openjdk
36%define javaplugin  libjavaplugin.so
37%endif
38
39%define binsuffix      .itweb
40
41Name:           icedtea-web
42Version:        1.4.1
43Release:        1%{?_dist_release}
44Summary:        Java browser plug-in and Web Start implementation
45Summary(ja):    Java ブラウザプラグイン
46
47Group:      Applications/Internet
48License:    LGPLv2+ and GPLv2 with exceptions
49URL:        http://icedtea.classpath.org/wiki/IcedTea-Web
50Source0:    http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
51
52BuildRequires:  java-%{javaver}-openjdk-devel
53BuildRequires:  desktop-file-utils
54BuildRequires:  gecko-devel
55BuildRequires:  glib2-devel
56BuildRequires:  xulrunner-devel
57
58# For functionality and the OpenJDK dirs
59Requires:      java-%{javaver}-openjdk
60
61# Post requires alternatives to install plugin alternative.
62Requires(post):   alternatives
63
64# Postun requires alternatives to uninstall plugin alternative.
65Requires(postun): alternatives
66
67# Standard JPackage plugin provides.
68Provides: java-plugin = %{javaver}
69Provides: javaws      = %{javaver}
70
71Provides:   java-1.7.0-openjdk-plugin
72Obsoletes:  java-1.6.0-openjdk-plugin <= %{min_openjdk_version}
73
74# IcedTea is only built on these archs for now
75ExclusiveArch: x86_64 i686 %{arm}
76
77%description
78The IcedTea-Web project provides a Java web browser plugin, an implementation
79of Java Web Start (originally based on the Netx project) and a settings tool to
80manage deployment settings for the aforementioned plugin and Web Start
81implementations.
82
83%package javadoc
84Summary:    API documentation for IcedTea-Web
85Summary(ja):    API documentation for IcedTea-Web
86Group:      Documentation
87Requires:   jpackage-utils
88BuildArch:  noarch
89
90%description javadoc
91This package contains Javadocs for the IcedTea-Web project.
92
93%prep
94%setup -q
95
96%build
97autoconf
98./configure \
99    --with-pkgversion=vine-%{release}-%{_arch} \
100    --docdir=%{_datadir}/javadoc/%{name} \
101    --with-jdk-home=%{javadir} \
102    --with-jre-home=%{jredir} \
103    --libdir=%{_libdir} \
104    --program-suffix=%{binsuffix} \
105    --prefix=%{_prefix}
106
107make CXXFLAGS="$RPM_OPT_FLAGS"
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make install DESTDIR=$RPM_BUILD_ROOT
112
113# Move javaws man page to a more specific name
114mv $RPM_BUILD_ROOT/%{_mandir}/man1/javaws.1 $RPM_BUILD_ROOT/%{_mandir}/man1/javaws-itweb.1
115
116# Install desktop files.
117install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/{applications,pixmaps}
118cp javaws.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
119desktop-file-install --vendor ''\
120  --dir $RPM_BUILD_ROOT%{_datadir}/applications javaws.desktop
121desktop-file-install --vendor ''\
122  --dir $RPM_BUILD_ROOT%{_datadir}/applications itweb-settings.desktop
123
124mkdir -p $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/
125
126%post
127if [ $1 -gt 1 ]
128then
129alternatives --remove %{javaplugin} \
130  %{jre6dir}/lib/%{archinstall}/IcedTeaPlugin.so 2>/dev/null || :       
131fi
132
133%posttrans
134update-desktop-database &> /dev/null || :
135alternatives \
136  --install %{_libdir}/mozilla/plugins/libjavaplugin.so %{javaplugin} \
137  %{_libdir}/IcedTeaPlugin.so %{priority} \
138  --slave %{_bindir}/javaws javaws %{_prefix}/bin/javaws%{binsuffix} \
139  --slave %{_mandir}/man1/javaws.1.gz javaws.1.gz \
140  %{_mandir}/man1/javaws-itweb.1.gz
141
142exit 0
143
144%postun
145update-desktop-database &> /dev/null || :
146if [ $1 -eq 0 ]
147then
148  alternatives --remove %{javaplugin} \
149    %{_libdir}/IcedTeaPlugin.so
150fi
151
152exit 0
153
154%files
155%defattr(-,root,root,-)
156%doc NEWS README COPYING
157%{_prefix}/bin/*
158%{_libdir}/IcedTeaPlugin.so
159%{_datadir}/applications/*
160%{_datadir}/icedtea-web
161%{_datadir}/man/man1/*
162%{_datadir}/pixmaps/*
163%dir %{_libdir}/mozilla/plugins/
164
165%files javadoc
166%defattr(-,root,root,-)
167%{_datadir}/javadoc/%{name}
168%doc COPYING
169
170%changelog
171* Fri Dec 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
172- update to 1.4.1
173
174* Mon Mar 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-1
175- update to 1.3.1
176
177* Mon Sep 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp>  1.2.1-1
178- initial build for Vine Linux
179
180* Tue Jul 31 2012 Deepak Bhole <dbhole@redhat.com> 1.2.1-1
181- Updated to 1.2.1
182- Resolves: RH840592/CVE-2012-3422
183- Resolves: RH841345/CVE-2012-3423
184
185* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
187
188* Thu May 03 2012 Deepak Bhole <dbhole@redhat.com> 1.2-4
189- Resolves rhbz#814585
190- Fixed java-plugin provides and added one for javaws
191
192* Tue Apr 17 2012 Deepak Bhole <dbhole@redhat.com> 1.2-3
193- Updated summary
194- Fixed virtual provide
195
196* Tue Mar 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.2-2
197- Enable building on ARM platforms
198
199* Mon Mar 05 2012 Deepak Bhole <dbhole@redhat.com> 1.2-1
200- Updated to 1.2
201
202* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-4
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
204
205* Fri Nov 25 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-3
206- Resolves rhbz#757191
207- Bumped min_openjdk_version to -60 (latest)
208
209* Thu Nov 24 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-2
210- Resolves: rhbz#742887. Do not own directories not created by the package.
211
212* Tue Nov 08 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-1
213- Updated to 1.1.4
214- Added npapi-fix patch so that the plug-in compiles with xulrunner 8
215
216* Thu Sep 01 2011 Deepak Bhole <dbhole@redhat.com> 1.1.2-1
217- Updated to 1.1.2
218- Removed all patches (now upstream)
219- Resolves: rhbz# 734890
220
221* Tue Aug 23 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-3
222- Added patch to allow install to jre dir
223- Fixed requirement for java-1.7.0-openjdk
224
225* Tue Aug 09 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-2
226- Fixed file ownership so that debuginfo is not in main package
227
228* Wed Aug 03 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-1
229- Bump to 1.1.1
230- Added patch for PR768 and PR769
231
232* Wed Jul 20 2011 Deepak Bhole <dbhole@redhat.com> 1.0.4-1
233- Bump to 1.0.4
234- Fixed rhbz#718164: Home directory path disclosure to untrusted applications
235- Fixed rhbz#718170: Java Web Start security warning dialog manipulation
236
237* Mon Jun 13 2011 Deepak Bhole <dbhole@redhat.com> 1.0.3-1
238- Update to 1.0.3
239- Resolves: rhbz#691259
240
241* Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-2
242- Fixed incorrect macro value for min_openjdk_version
243- Use posttrans instead of post, so that upgrade from old plugin works
244
245* Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-1
246- Initial build
Note: See TracBrowser for help on using the repository browser.