source: projects/specs/trunk/i/ical/ical-vl.spec @ 521

Revision 521, 3.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name ical
2%define eversion 2.2
3%define version %{eversion}_jp
4%define release 10
5
6Summary: Calender application made with Tcl/Tk
7Name: %{name}
8Version: %{version}
9Release: %{release}
10Source: http://www.research.digial.com/SRC/personal/Sanjay_Ghemawat/ical/icalbins/ical-%{eversion}.tar.gz
11Source1: ical.wmconfig
12Patch0: ical-2.2-newtcl.patch
13Patch1: http://www.asahi-net.or.jp/~km5n-tkhs/ical-2.1j.diff
14Patch2: http://www.asahi-net.or.jp/~km5n-tkhs/ical-over.diff
15Patch3: ical-2.2-gcc2.95.patch
16Patch4: ical-2.2-glibc23.patch
17Url: http://www.research.digital.com/SRC/personal/Sanjay_Ghemawat/ical/home.html
18Copyright: distributable
19Group: Applications/Productivity
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: Jun Nishii <jun@vinelinux.org>
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24Summary(ja): Tcl/Tk ¤ÇÆ°¤¯ ¥«¥ì¥ó¥À¡¼ ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó
25
26
27%description
28ical is a popular X-based calendar/scheduler application which
29can help you keep track of single events and recurring events
30(daily, weekly, monthly, or yearly), and sets off alarms to warn
31you of appointments.
32
33%description -l ja
34ical ¤Ï X¥Ù¡¼¥¹¤Î¥«¥ì¥ó¥À¡¼/¥¹¥±¥¸¥å¡¼¥é¤Ç¤¹. ³Æ¼ï¥¤¥Ù¥ó¥È¤Î´ÉÍý¤ò
35¹Ô¤¨, ¤Þ¤¿Âç»ö¤ÊÃΤ餻¤Æ¤¯¤ì¤ë¥¢¥é¡¼¥àµ¡Ç½¤â¤Ä¤¤¤Æ¤¤¤Þ¤¹.
36
37
38%prep
39rm -rf %{buildroot}
40
41%setup -q -n ical-%{eversion}
42%patch0 -p1
43%patch1 -p1
44%patch2 -p1
45%patch3 -p0 -b .gcc2.95
46%patch4 -p1
47
48
49%build
50autoconf
51%configure
52make OPTF='-O -DKANJI -DKINPUT2' X_LIBS='-L/usr/X11R6/lib -lX11'
53
54
55%install
56rm -rf %{buildroot}
57install -d %{buildroot}/etc/X11/wmconfig
58install -d %{buildroot}%{_mandir}
59%makeinstall MANDIR=%{buildroot}%{_mandir}
60install -m 644 %{_sourcedir}/ical.wmconfig %{buildroot}/etc/X11/wmconfig/ical
61
62
63%clean
64rm -rf %{buildroot}
65
66
67%files
68%defattr(-,root,root)
69%doc ANNOUNCE CHANGES* COPYRIGHT* FTPDIR.README README* TODO INSTALL
70%doc doc/ical.html doc/ical.doc
71%doc doc/interface.html doc/interface.doc
72%{_bindir}/ical-%{eversion}
73%{_bindir}/ical
74%{_mandir}/man1/ical.1*
75%{_libdir}/ical
76%config /etc/X11/wmconfig/ical
77
78
79%changelog
80* Tue Nov 26 2002 Tomoya TAKA <taka@vinelinux.org> 2.2_jp-10
81- update Patch4 (add fix of calender/uid.C)
82
83* Fri Mar 15 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2_jp-9
84- rebuilt with new toolchain
85- added Patch4
86
87* Fri Mar 15 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2_jp-8
88- rebuilt with glibc > 2.2
89
90* Thu Jan 11 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 2.2_jp-7
91- use %%configure and %%makeinstall
92- fix to handle man page correctry with newer %%{_mandir} definition
93
94* Sat Nov 11 2000 MACHINO, Satoshi <machino@vinelinux.org> 2.2_jp-6
95- build on gcc-2.95.3
96- partially used rpmmacros
97
98* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
99- 2.2_jp-5
100- modified %files section to handle compressed man page(s)
101
102* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
103- use EUC in spec
104
105* Wed Oct 13 1999 Jun Nishii <jun@flatout.org>
106- build for Vine-1.9
107
108* Sun Mar 14 1999 Jun Nishii <jun@flatout.org>
109- added ical-2.1j.diff, ical-over.diff
110- added Japanese description and summary
111
112* Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
113- patch to build against the latest tcltk
114
115* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
116- build root
117
118* Thu May 07 1998 Prospector System <bugs@redhat.com>
119- translations modified for de, fr, tr
120
121* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
122- fixed wmconfig entry
123
124* Thu Oct 23 1997 Otto Hammersmith <otto@redhat.com>
125- replaced references to the version number with %{PACKAGE_VERSION}
126
127* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
128- updated to version 2.2, which is supposed to work with Tcl/Tk 8.0
129- added wmconfig entry
130
131* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
132- Update version
133
134* Tue Sep 30 1997 Erik Troan <ewt@redhat.com>
135- build against tcl/tk 8.0
136
137* Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
138- built against glibc
Note: See TracBrowser for help on using the repository browser.