source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 4641

Revision 4641, 12.3 KB checked in by daisuke, 13 years ago (diff)

ibus:

  • update to upstream snapshot (1.3.99.20110817)
  • add ibus-gjs for gnome3
  • update patches
Line 
1%define snapshot 20110817
2%define ver 1.3.99.%{snapshot}
3%define rel 1
4
5%if "%{?_dist_release}" >= "vl7"
6%define have_gjsfile 1
7%define have_libxkbfile 1
8%else
9%define have_gjsfile 0
10%define have_xkbfile 0
11%endif
12
13%define ibus_api_version 1.0
14
15Summary: Intelligent Input Bus for Linux / Unix OS
16Name: ibus
17Version: %{ver}
18Release: %{rel}%{?_dist_release}
19License: LGPL
20Group: System Environment/Libraries
21URL: http://code.google.com/p/ibus/
22
23Source0: %{name}-%{version}.tar.gz
24Source1: http://fujiwara.fedorapeople.org/ibus/gnome-shell/ibus-gjs-1.3.99.20110814.tar.gz
25
26Patch1:     ibus-530711-preload-sys.patch
27Patch4:     ibus-541492-xkb.patch
28
29# add Shift+space as trigger key instead of Ctrl+space
30Patch20: ibus-1.3.9-vine.patch
31
32Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
33Requires: notify-python
34Requires: librsvg2
35Requires(pre): GConf2
36Requires(post): GConf2
37Requires(preun): GConf2
38Requires(post): glib2
39Requires(post,postun): coreutils, gtk2
40BuildRequires(install,check): desktop-file-utils
41BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
42BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
43BuildRequires: glib2-devel >= 2.0.0
44%if %{?_dist_release} != "vl5"
45BuildRequires: gtk3-devel >= 3.0.0
46%endif
47%if %have_gjsfile
48BuildRequires: gjs
49BuildRequires: gnome-shell
50%endif
51%if %have_libxkbfile
52BuildRequires: libxkbfile-devel
53%endif
54BuildRequires: GConf2-devel >= 2.12
55BuildRequires: perl >= 5.8.1 perl-XML-Parser
56Buildrequires: python >= 2.5
57Buildroot: %{_tmppath}/%{name}-%{version}-root
58Provides: iBus
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: iwaim
63
64%description
65IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
66It provides full featured and user friendly input method user interface.
67It also may help developers to develop input method easily.
68
69%package devel
70Summary: Header files for iBus
71Group: Development/Libraries
72Requires: ibus == %{version}-%{release}
73Requires:   glib2-devel
74Requires:   dbus-devel
75Requires:   vala
76
77%description devel
78Header files for iBus.
79
80%package gtk3
81Summary: IBus im module for gtk3
82Summary(ja): gtk3 用 IBus IMモジュール
83Group: System Environment/Libraries
84Requires: %{name} = %{version}-%{release}
85Requires(post): glib2
86
87%description gtk3
88The ibus-gtk3 contains ibus im module for gtk3.
89
90%package gnome3
91Summary:    IBus gnome-shell-extension for GNOME3
92Summary(ja): GNOME3 用 IBus gnome-shell 拡張
93Group:      System Environment/Libraries
94Requires:   %{name} = %{version}-%{release}
95Requires:   gnome-shell
96
97%description gnome3
98This is a transitional package which allows users to try out new IBus
99GUI for GNOME3 in development.  Note that this package will be marked
100as obsolete once the integration has completed in the GNOME3 upstream.
101
102
103%prep
104%setup -q
105%if %have_gjsfile
106zcat %SOURCE1 | tar xf -
107%endif
108
109%patch1 -p1 -b .preload-sys
110%if %have_libxkbfile
111%patch4 -p1 -b .xkb
112%endif
113
114%patch20 -p1 -b .vine
115
116%if %have_libxkbfile
117aclocal -I m4
118autoheader
119autoconf -f
120automake -a -c -f
121%endif
122%configure \
123        --disable-static \
124%if %{?_dist_release} != "vl5"
125        --enable-gtk3 \
126%endif
127        --enable-gtk2 \
128        --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules \
129        --enable-xim \
130        --disable-gtk-doc \
131        --with-no-snooper-apps='gnome-do,Do.*,firefox.*,:*chrome.*,.*chromium.*' \
132        --enable-surrounding-text \
133        --enable-introspection
134
135%build
136make %{?_smp_mflags}
137
138%if %have_gjsfile
139d=`basename %SOURCE1 .tar.gz`
140cd $d
141export PKG_CONFIG_PATH=..:/usr/lib64/pkgconfig:/usr/lib/pkgconfig
142%configure
143make %{?_smp_mflags}
144cd ..
145%endif
146
147
148%install
149rm -rf %{buildroot}
150make DESTDIR=%{buildroot} install
151
152rm -rf %{buildroot}%{_libdir}/libibus-%{ibus_api_version}.la
153rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
154%if %{?_dist_release} != "vl5"
155rm -rf %{buildroot}%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.la
156%endif
157
158%{_bindir}/desktop-file-install \
159  --vendor="" --dir=%{buildroot}/%{_datadir}/applications \
160  --add-category=Applications \
161  --add-category=X-GNOME-PersonalSettings \
162  %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
163
164rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
165
166%if %have_gjsfile
167# https://bugzilla.redhat.com/show_bug.cgi?id=657165
168d=`basename %SOURCE1 .tar.gz`
169cd $d
170make DESTDIR=$RPM_BUILD_ROOT install
171rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/ibus-gjs.mo
172cd ..
173%endif
174
175
176%find_lang %{name}10
177
178%clean
179rm -rf %{buildroot}
180
181%check
182#make check
183%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
184%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
185
186
187%post
188/sbin/ldconfig
189if [ -x %{_bindir}/update-desktop-database ] ; then
190%{_bindir}/update-desktop-database %{_datadir}/applications -q
191fi
192%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
193export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
194gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
195# recreate icon cache
196touch --no-create %{_datadir}/icons/hicolor || :
197[ -x %{_bindir}/gtk-update-icon-cache ] && \
198  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
199
200
201%pre
202if [ "$1" -gt 1 ]; then
203    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
204    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
205fi
206
207
208%preun
209if [ "$1" -eq 0 ]; then
210    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
211    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
212fi
213
214
215%postun
216/sbin/ldconfig
217%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
218if [ -x %{_bindir}/update-desktop-database ] ; then
219%{_bindir}/update-desktop-database %{_datadir}/applications -q
220fi
221# recreate icon cache
222touch --no-create %{_datadir}/icons/hicolor || :
223[ -x %{_bindir}/gtk-update-icon-cache ] && \
224  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
225
226%if %{?_dist_release} != "vl5"
227%post gtk3
228%{_bindir}/gtk-query-immodules-3.0 --update-cache
229
230%postun gtk3
231%{_bindir}/gtk-query-immodules-3.0 --update-cache
232
233%endif
234
235%files -f %{name}10.lang
236%defattr(-,root,root,-)
237%doc AUTHORS COPYING ChangeLog NEWS README
238%{_bindir}/ibus*
239%{_libdir}/libibus-%{ibus_api_version}.so.*
240%{_libdir}/gtk-2.0/immodules/im-ibus.so
241%{_libexecdir}/ibus-gconf
242%{_libexecdir}/ibus-ui-gtk
243%{_libexecdir}/ibus-x11
244#%{python_sitearch}/ibus
245%{python_sitelib}/ibus
246%{_datadir}/applications/*
247%{_datadir}/ibus
248%{_datadir}/gtk-doc/html/ibus
249%{_datadir}/icons/hicolor/*/apps/*
250#%{_sysconfdir}/xdg/autostart/ibus.desktop
251%{_sysconfdir}/gconf/schemas/ibus.schemas
252%if %have_libxkbfile
253%{_libexecdir}/ibus-engine-xkb
254%{_libexecdir}/ibus-xkb
255%endif
256
257%files devel
258%defattr(-,root,root,-)
259%{_libdir}/pkgconfig/*
260%{_libdir}/lib*.so
261%{_includedir}/*
262%{_datadir}/vala/vapi/ibus-1.0.vapi
263%{_datadir}/vala/vapi/ibus-1.0.deps
264%if %{?_dist_release} != "vl5"
265%{_libdir}/girepository-1.0/IBus-1.0.typelib
266%{_datadir}/gir-1.0/IBus-1.0.gir
267%endif
268
269%if %{?_dist_release} != "vl5"
270%files gtk3
271%defattr(-,root,root,-)
272%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.so
273%endif
274
275%if %have_gjsfile
276%files gnome3
277%defattr(-,root,root,-)
278%{_datadir}/gnome-shell/js/ui/status/ibus
279%{_datadir}/gnome-shell/extensions/ibus-indicator@example.com
280%endif
281
282%changelog
283* Tue Aug 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.99.20110817-1
284- update to upstream snapshot (1.3.99.20110817)
285- add ibus-gjs for gnome3
286- update patches
287
288* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-5
289- add patch1 from ubuntu (accepted in upstream)
290  Use LC_MESSAGES instead of LC_ALL in bus_ibus_impl_set_default_preload_engines.
291- add "Catgegories=Applications;X-GNOME-PersonalSettings" to ibus-setup.desktop
292- add patch10 to add default preload engines to gconf schemas
293- add patch20 to modify IM trigger shortcut keys
294  - add Shift+space, remove Ctrl+space
295
296* Tue Apr 19 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.9-4vl6
297- drop {post,postun} script for gtk3 immodules in main package
298
299* Fri Apr  8 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.9-3vl6
300- drop GTK3 immodule file in main package
301
302* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.9-2
303- create -gtk3 sub package (VineSeed only)
304
305* Wed Dec 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.9-1
306- new upstream release
307- add files in devel sub package for VineSeed
308 - girepository-1.0/IBus-1.0.typelib
309 - gir-1.0/IBus-1.0.gir
310
311* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.7-2
312- rebuilt with rpm-4.8.1 for pkg-config
313
314* Mon Aug  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.7-1
315- new upstream release
316- add support Vala on Vine Linux 5
317
318* Fri Jul  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
319- new upstream release
320
321* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
322- new upstream release
323- update GTK immodule dir option for configure
324- add vapi file for VineSeed
325- add Requires: vala for devel package, VineSeed
326
327* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
328- update Requires: notify-python librsvg2
329- execute gconftool-2 on {post,pre,preun}
330- add Requires: Gconf2 on {post,pre,preun}
331- update Requires: glib2-devel dbus-devel for ibus-devel package
332- execute update-desktop-database on {post,postun}
333- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
334- add Requires: coreutils, gtk2 on {post,postun}
335- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
336
337* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
338- new upstream release
339- stop 'make check'
340
341* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
342- s/python_sitearch/python_sitelib/
343
344* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
345- new upstream release
346- execute 'make check'
347- clean up:
348  - drop unused git_source and vine_ja_po
349
350* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
351- new upstream release
352- stop 'make check'
353
354* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
355- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
356
357* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
358- new upstream release
359
360* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
361- new upstream release
362
363* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
364- new upstream release
365
366* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
367- new upstream release
368- add fix POFILES.in patch (Patch0)
369- update file list in %%files section
370- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
371
372* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
373- new upstream release
374
375* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
376- new upstream release
377- update %%files section
378- update BuildRequires
379- drop obsoleted configure option: --disable-qt4-immodule
380
381* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
382- new upstream release
383
384* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
385- new upstream release
386- add Packager tag
387
388* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
389- new upstream release
390
391* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
392- new upstream release
393- update BuildRequires
394  - add dbus-devel, intltool >= 0.40.0
395  - drop qt4-devel
396
397* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
398- new upstream release
399- drop defined python_sitearch rpm macro
400
401* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
402- new upstream release
403
404* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
405- new upstream release
406- drop Vine ja.po (SOURCE1)
407
408* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
409- new upstream release
410- update ja.po (SOURCE1)
411
412* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
413- new upstream release
414
415* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
416- add ja.po (SOURCE1): update
417- add ibus.desktop file in xdg autostart
418- add ibus.schemas file
419
420* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
421- set python_sitearch to arch independent path
422
423* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
424- new upstream release
425- add dbus-python version ( 0.83.0 and more ) in Requires
426- add BuildRequires: dbus-python-devel >= 0.83.0
427
428* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
429- new upstream release
430- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
431- generate devel sub package
432- stop creating qt4 immodule
433- drop .la files
434
435* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
436- initial release
Note: See TracBrowser for help on using the repository browser.