source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 2426

Revision 2426, 8.3 KB checked in by iwaim, 14 years ago (diff)

ibus 1.3.9-1

Line 
1%define ver 1.3.9
2%define rel 1
3
4Summary: Intelligent Input Bus for Linux / Unix OS
5Name: ibus
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10URL: http://code.google.com/p/ibus/
11Source0: %{name}-%{version}.tar.gz
12Patch0: ibus-1.2.0.20091024-fixPOFILES.in.patch
13Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
14Requires: notify-python
15Requires: librsvg2
16Requires(pre): GConf2
17Requires(post): GConf2
18Requires(preun): GConf2
19Requires(post): glib2
20Requires(post,postun): coreutils, gtk2
21BuildRequires(install,check): desktop-file-utils
22BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
23BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
24BuildRequires: glib2-devel >= 2.0.0
25BuildRequires: GConf2-devel >= 2.12
26BuildRequires: perl >= 5.8.1 perl-XML-Parser
27Buildrequires: python >= 2.5
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29Provides: iBus
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: iwaim
34
35%description
36IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
37It provides full featured and user friendly input method user interface.
38It also may help developers to develop input method easily.
39
40%package devel
41Summary: Header files for iBus
42Group: Development/Libraries
43Requires: ibus == %{version}-%{release}
44Requires:   glib2-devel
45Requires:   dbus-devel
46Requires:   vala
47
48%description devel
49Header files for iBus.
50
51%prep
52%setup -q
53%patch0 -p1
54%configure --disable-static --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules
55
56%build
57make %{?_smp_mflags}
58
59%install
60rm -rf %{buildroot}
61make DESTDIR=%{buildroot} install
62
63rm -rf %{buildroot}%{_libdir}/libibus.la
64rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
65
66rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
67
68%find_lang %{name}
69
70%clean
71rm -rf %{buildroot}
72
73%check
74#make check
75%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
76%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
77
78
79%post
80/sbin/ldconfig
81if [ -x %{_bindir}/update-desktop-database ] ; then
82%{_bindir}/update-desktop-database %{_datadir}/applications
83fi
84%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
85export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
87# recreate icon cache
88touch --no-create %{_datadir}/icons/hicolor || :
89[ -x %{_bindir}/gtk-update-icon-cache ] && \
90  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
91
92
93%pre
94if [ "$1" -gt 1 ]; then
95    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
97fi
98
99
100%preun
101if [ "$1" -eq 0 ]; then
102    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
103    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
104fi
105
106
107%postun
108/sbin/ldconfig
109%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
110if [ -x %{_bindir}/update-desktop-database ] ; then
111%{_bindir}/update-desktop-database %{_datadir}/applications
112fi
113# recreate icon cache
114touch --no-create %{_datadir}/icons/hicolor || :
115[ -x %{_bindir}/gtk-update-icon-cache ] && \
116  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
117
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%doc AUTHORS COPYING ChangeLog NEWS README
122%{_bindir}/ibus*
123%{_libdir}/libibus.so.*
124%{_libdir}/gtk-2.0/immodules/im-ibus.so
125%{_libexecdir}/ibus-gconf
126%{_libexecdir}/ibus-ui-gtk
127%{_libexecdir}/ibus-x11
128#%{python_sitearch}/ibus
129%{python_sitelib}/ibus
130%{_datadir}/applications/*
131%{_datadir}/ibus
132%{_datadir}/gtk-doc/html/ibus
133%{_datadir}/icons/hicolor/*/apps/*
134#%{_sysconfdir}/xdg/autostart/ibus.desktop
135%{_sysconfdir}/gconf/schemas/ibus.schemas
136
137%files devel
138%defattr(-,root,root,-)
139%{_libdir}/pkgconfig/ibus-1.0.pc
140%{_libdir}/libibus.so
141%{_includedir}/ibus-1.0
142%{_datadir}/vala/vapi/ibus-1.0.vapi
143%if %{?_dist_release} != "vl5"
144%{_libdir}/girepository-1.0/IBus-1.0.typelib
145%{_datadir}/gir-1.0/IBus-1.0.gir
146%endif
147
148%changelog
149* Wed Dec 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.9-1
150- new upstream release
151- add files in devel sub package for VineSeed
152 - girepository-1.0/IBus-1.0.typelib
153 - gir-1.0/IBus-1.0.gir
154
155* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.7-2
156- rebuilt with rpm-4.8.1 for pkg-config
157
158* Mon Aug  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.7-1
159- new upstream release
160- add support Vala on Vine Linux 5
161
162* Fri Jul  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
163- new upstream release
164
165* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
166- new upstream release
167- update GTK immodule dir option for configure
168- add vapi file for VineSeed
169- add Requires: vala for devel package, VineSeed
170
171* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
172- update Requires: notify-python librsvg2
173- execute gconftool-2 on {post,pre,preun}
174- add Requires: Gconf2 on {post,pre,preun}
175- update Requires: glib2-devel dbus-devel for ibus-devel package
176- execute update-desktop-database on {post,postun}
177- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
178- add Requires: coreutils, gtk2 on {post,postun}
179- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
180
181* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
182- new upstream release
183- stop 'make check'
184
185* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
186- s/python_sitearch/python_sitelib/
187
188* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
189- new upstream release
190- execute 'make check'
191- clean up:
192  - drop unused git_source and vine_ja_po
193
194* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
195- new upstream release
196- stop 'make check'
197
198* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
199- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
200
201* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
202- new upstream release
203
204* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
205- new upstream release
206
207* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
208- new upstream release
209
210* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
211- new upstream release
212- add fix POFILES.in patch (Patch0)
213- update file list in %%files section
214- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
215
216* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
217- new upstream release
218
219* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
220- new upstream release
221- update %%files section
222- update BuildRequires
223- drop obsoleted configure option: --disable-qt4-immodule
224
225* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
226- new upstream release
227
228* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
229- new upstream release
230- add Packager tag
231
232* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
233- new upstream release
234
235* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
236- new upstream release
237- update BuildRequires
238  - add dbus-devel, intltool >= 0.40.0
239  - drop qt4-devel
240
241* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
242- new upstream release
243- drop defined python_sitearch rpm macro
244
245* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
246- new upstream release
247
248* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
249- new upstream release
250- drop Vine ja.po (SOURCE1)
251
252* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
253- new upstream release
254- update ja.po (SOURCE1)
255
256* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
257- new upstream release
258
259* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
260- add ja.po (SOURCE1): update
261- add ibus.desktop file in xdg autostart
262- add ibus.schemas file
263
264* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
265- set python_sitearch to arch independent path
266
267* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
268- new upstream release
269- add dbus-python version ( 0.83.0 and more ) in Requires
270- add BuildRequires: dbus-python-devel >= 0.83.0
271
272* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
273- new upstream release
274- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
275- generate devel sub package
276- stop creating qt4 immodule
277- drop .la files
278
279* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
280- initial release
Note: See TracBrowser for help on using the repository browser.