source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 1546

Revision 1546, 7.9 KB checked in by iwaim, 14 years ago (diff)

ibus 1.3.7-1

Line 
1%define ver 1.3.7
2%define rel 1
3
4Summary: Intelligent Input Bus for Linux / Unix OS
5Name: ibus
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10URL: http://code.google.com/p/ibus/
11Source0: %{name}-%{version}.tar.gz
12Patch0: ibus-1.2.0.20091024-fixPOFILES.in.patch
13Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
14Requires: notify-python
15Requires: librsvg2
16Requires(pre): GConf2
17Requires(post): GConf2
18Requires(preun): GConf2
19Requires(post): glib2
20Requires(post,postun): coreutils, gtk2
21BuildRequires(install,check): desktop-file-utils
22BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
23BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
24BuildRequires: glib2-devel >= 2.0.0
25BuildRequires: GConf2-devel >= 2.12
26BuildRequires: perl >= 5.8.1 perl-XML-Parser
27Buildrequires: python >= 2.5
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29Provides: iBus
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: iwaim
34
35%description
36IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
37It provides full featured and user friendly input method user interface.
38It also may help developers to develop input method easily.
39
40%package devel
41Summary: Header files for iBus
42Group: Development/Libraries
43Requires: ibus == %{version}-%{release}
44Requires:   glib2-devel
45Requires:   dbus-devel
46Requires:   vala
47
48%description devel
49Header files for iBus.
50
51%prep
52%setup -q
53%patch0 -p1
54%configure --disable-static --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules
55
56%build
57make %{?_smp_mflags}
58
59%install
60rm -rf %{buildroot}
61make DESTDIR=%{buildroot} install
62
63rm -rf %{buildroot}%{_libdir}/libibus.la
64rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
65
66rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
67
68%find_lang %{name}
69
70%clean
71rm -rf %{buildroot}
72
73%check
74#make check
75%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
76%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
77
78
79%post
80/sbin/ldconfig
81if [ -x %{_bindir}/update-desktop-database ] ; then
82%{_bindir}/update-desktop-database %{_datadir}/applications
83fi
84%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
85export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
87# recreate icon cache
88touch --no-create %{_datadir}/icons/hicolor || :
89[ -x %{_bindir}/gtk-update-icon-cache ] && \
90  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
91
92
93%pre
94if [ "$1" -gt 1 ]; then
95    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
97fi
98
99
100%preun
101if [ "$1" -eq 0 ]; then
102    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
103    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
104fi
105
106
107%postun
108/sbin/ldconfig
109%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
110if [ -x %{_bindir}/update-desktop-database ] ; then
111%{_bindir}/update-desktop-database %{_datadir}/applications
112fi
113# recreate icon cache
114touch --no-create %{_datadir}/icons/hicolor || :
115[ -x %{_bindir}/gtk-update-icon-cache ] && \
116  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
117
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%doc AUTHORS COPYING ChangeLog NEWS README
122%{_bindir}/ibus*
123%{_libdir}/libibus.so.*
124%{_libdir}/gtk-2.0/immodules/im-ibus.so
125%{_libexecdir}/ibus-gconf
126%{_libexecdir}/ibus-ui-gtk
127%{_libexecdir}/ibus-x11
128#%{python_sitearch}/ibus
129%{python_sitelib}/ibus
130%{_datadir}/applications/*
131%{_datadir}/ibus
132%{_datadir}/gtk-doc/html/ibus
133%{_datadir}/icons/hicolor/*/apps/*
134#%{_sysconfdir}/xdg/autostart/ibus.desktop
135%{_sysconfdir}/gconf/schemas/ibus.schemas
136
137%files devel
138%defattr(-,root,root,-)
139%{_libdir}/pkgconfig/ibus-1.0.pc
140%{_libdir}/libibus.so
141%{_includedir}/ibus-1.0
142%{_datadir}/vala/vapi/ibus-1.0.vapi
143
144%changelog
145* Mon Aug  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.7-1
146- new upstream release
147- add support Vala on Vine Linux 5
148
149* Fri Jul  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
150- new upstream release
151
152* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
153- new upstream release
154- update GTK immodule dir option for configure
155- add vapi file for VineSeed
156- add Requires: vala for devel package, VineSeed
157
158* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
159- update Requires: notify-python librsvg2
160- execute gconftool-2 on {post,pre,preun}
161- add Requires: Gconf2 on {post,pre,preun}
162- update Requires: glib2-devel dbus-devel for ibus-devel package
163- execute update-desktop-database on {post,postun}
164- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
165- add Requires: coreutils, gtk2 on {post,postun}
166- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
167
168* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
169- new upstream release
170- stop 'make check'
171
172* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
173- s/python_sitearch/python_sitelib/
174
175* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
176- new upstream release
177- execute 'make check'
178- clean up:
179  - drop unused git_source and vine_ja_po
180
181* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
182- new upstream release
183- stop 'make check'
184
185* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
186- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
187
188* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
189- new upstream release
190
191* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
192- new upstream release
193
194* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
195- new upstream release
196
197* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
198- new upstream release
199- add fix POFILES.in patch (Patch0)
200- update file list in %%files section
201- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
202
203* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
204- new upstream release
205
206* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
207- new upstream release
208- update %%files section
209- update BuildRequires
210- drop obsoleted configure option: --disable-qt4-immodule
211
212* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
213- new upstream release
214
215* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
216- new upstream release
217- add Packager tag
218
219* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
220- new upstream release
221
222* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
223- new upstream release
224- update BuildRequires
225  - add dbus-devel, intltool >= 0.40.0
226  - drop qt4-devel
227
228* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
229- new upstream release
230- drop defined python_sitearch rpm macro
231
232* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
233- new upstream release
234
235* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
236- new upstream release
237- drop Vine ja.po (SOURCE1)
238
239* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
240- new upstream release
241- update ja.po (SOURCE1)
242
243* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
244- new upstream release
245
246* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
247- add ja.po (SOURCE1): update
248- add ibus.desktop file in xdg autostart
249- add ibus.schemas file
250
251* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
252- set python_sitearch to arch independent path
253
254* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
255- new upstream release
256- add dbus-python version ( 0.83.0 and more ) in Requires
257- add BuildRequires: dbus-python-devel >= 0.83.0
258
259* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
260- new upstream release
261- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
262- generate devel sub package
263- stop creating qt4 immodule
264- drop .la files
265
266* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
267- initial release
Note: See TracBrowser for help on using the repository browser.