source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 1301

Revision 1301, 8.0 KB checked in by iwaim, 14 years ago (diff)

ibus 1.3.6-1

Line 
1%define ver 1.3.6
2%define rel 1
3
4Summary: Intelligent Input Bus for Linux / Unix OS
5Name: ibus
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10URL: http://code.google.com/p/ibus/
11Source0: %{name}-%{version}.tar.gz
12#Source1: ibus-1.1.0.20090407-ja.po
13Patch0: ibus-1.2.0.20091024-fixPOFILES.in.patch
14Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
15Requires: notify-python
16Requires: librsvg2
17Requires(pre): GConf2
18Requires(post): GConf2
19Requires(preun): GConf2
20Requires(post): glib2
21Requires(post,postun): coreutils, gtk2
22BuildRequires(install,check): desktop-file-utils
23BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
24BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
25BuildRequires: glib2-devel >= 2.0.0
26BuildRequires: GConf2-devel >= 2.12
27BuildRequires: perl >= 5.8.1 perl-XML-Parser
28Buildrequires: python >= 2.5
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30Provides: iBus
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: iwaim
35
36%description
37IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
38It provides full featured and user friendly input method user interface.
39It also may help developers to develop input method easily.
40
41%package devel
42Summary: Header files for iBus
43Group: Development/Libraries
44Requires: ibus == %{version}-%{release}
45Requires:   glib2-devel
46Requires:   dbus-devel
47%if %{?_dist_release} != "vl5"
48Requires:   vala
49%endif
50
51%description devel
52Header files for iBus.
53
54%prep
55%setup -q
56%patch0 -p1
57%configure --disable-static --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules
58
59%build
60make %{?_smp_mflags}
61
62%install
63rm -rf %{buildroot}
64make DESTDIR=%{buildroot} install
65
66rm -rf %{buildroot}%{_libdir}/libibus.la
67rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
68
69rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
70
71%if %{?_dist_release} == "vl5"
72rm -rf %{buildroot}%{_datadir}/vala
73%endif
74
75%find_lang %{name}
76
77%clean
78rm -rf %{buildroot}
79
80%check
81#make check
82%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
83%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
84
85
86%post
87/sbin/ldconfig
88if [ -x %{_bindir}/update-desktop-database ] ; then
89%{_bindir}/update-desktop-database %{_datadir}/applications
90fi
91%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
92export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
94# recreate icon cache
95touch --no-create %{_datadir}/icons/hicolor || :
96[ -x %{_bindir}/gtk-update-icon-cache ] && \
97  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
98
99
100%pre
101if [ "$1" -gt 1 ]; then
102    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
103    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
104fi
105
106
107%preun
108if [ "$1" -eq 0 ]; then
109    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
110    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
111fi
112
113
114%postun
115/sbin/ldconfig
116%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
117if [ -x %{_bindir}/update-desktop-database ] ; then
118%{_bindir}/update-desktop-database %{_datadir}/applications
119fi
120# recreate icon cache
121touch --no-create %{_datadir}/icons/hicolor || :
122[ -x %{_bindir}/gtk-update-icon-cache ] && \
123  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
124
125
126%files -f %{name}.lang
127%defattr(-,root,root,-)
128%doc AUTHORS COPYING ChangeLog NEWS README
129%{_bindir}/ibus*
130%{_libdir}/libibus.so.*
131%{_libdir}/gtk-2.0/immodules/im-ibus.so
132%{_libexecdir}/ibus-gconf
133%{_libexecdir}/ibus-ui-gtk
134%{_libexecdir}/ibus-x11
135#%{python_sitearch}/ibus
136%{python_sitelib}/ibus
137%{_datadir}/applications/*
138%{_datadir}/ibus
139%{_datadir}/gtk-doc/html/ibus
140%{_datadir}/icons/hicolor/*/apps/*
141#%{_sysconfdir}/xdg/autostart/ibus.desktop
142%{_sysconfdir}/gconf/schemas/ibus.schemas
143
144%files devel
145%defattr(-,root,root,-)
146%{_libdir}/pkgconfig/ibus-1.0.pc
147%{_libdir}/libibus.so
148%{_includedir}/ibus-1.0
149%if %{?_dist_release} != "vl5"
150%{_datadir}/vala/vapi/ibus-1.0.vapi
151%endif
152
153%changelog
154* Fri Jul  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
155- new upstream release
156
157* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
158- new upstream release
159- update GTK immodule dir option for configure
160- add vapi file for VineSeed
161- add Requires: vala for devel package, VineSeed
162
163* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
164- update Requires: notify-python librsvg2
165- execute gconftool-2 on {post,pre,preun}
166- add Requires: Gconf2 on {post,pre,preun}
167- update Requires: glib2-devel dbus-devel for ibus-devel package
168- execute update-desktop-database on {post,postun}
169- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
170- add Requires: coreutils, gtk2 on {post,postun}
171- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
172
173* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
174- new upstream release
175- stop 'make check'
176
177* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
178- s/python_sitearch/python_sitelib/
179
180* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
181- new upstream release
182- execute 'make check'
183- clean up:
184  - drop unused git_source and vine_ja_po
185
186* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
187- new upstream release
188- stop 'make check'
189
190* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
191- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
192
193* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
194- new upstream release
195
196* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
197- new upstream release
198
199* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
200- new upstream release
201
202* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
203- new upstream release
204- add fix POFILES.in patch (Patch0)
205- update file list in %%files section
206- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
207
208* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
209- new upstream release
210
211* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
212- new upstream release
213- update %%files section
214- update BuildRequires
215- drop obsoleted configure option: --disable-qt4-immodule
216
217* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
218- new upstream release
219
220* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
221- new upstream release
222- add Packager tag
223
224* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
225- new upstream release
226
227* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
228- new upstream release
229- update BuildRequires
230  - add dbus-devel, intltool >= 0.40.0
231  - drop qt4-devel
232
233* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
234- new upstream release
235- drop defined python_sitearch rpm macro
236
237* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
238- new upstream release
239
240* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
241- new upstream release
242- drop Vine ja.po (SOURCE1)
243
244* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
245- new upstream release
246- update ja.po (SOURCE1)
247
248* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
249- new upstream release
250
251* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
252- add ja.po (SOURCE1): update
253- add ibus.desktop file in xdg autostart
254- add ibus.schemas file
255
256* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
257- set python_sitearch to arch independent path
258
259* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
260- new upstream release
261- add dbus-python version ( 0.83.0 and more ) in Requires
262- add BuildRequires: dbus-python-devel >= 0.83.0
263
264* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
265- new upstream release
266- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
267- generate devel sub package
268- stop creating qt4 immodule
269- drop .la files
270
271* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
272- initial release
Note: See TracBrowser for help on using the repository browser.