source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 1213

Revision 1213, 7.9 KB checked in by iwaim, 14 years ago (diff)

ibus 1.3.5-1

Line 
1%define ver 1.3.5
2%define rel 1
3
4Summary: Intelligent Input Bus for Linux / Unix OS
5Name: ibus
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10URL: http://code.google.com/p/ibus/
11Source0: %{name}-%{version}.tar.gz
12#Source1: ibus-1.1.0.20090407-ja.po
13Patch0: ibus-1.2.0.20091024-fixPOFILES.in.patch
14Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
15Requires: notify-python
16Requires: librsvg2
17Requires(pre): GConf2
18Requires(post): GConf2
19Requires(preun): GConf2
20Requires(post): glib2
21Requires(post,postun): coreutils, gtk2
22BuildRequires(install,check): desktop-file-utils
23BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
24BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
25BuildRequires: glib2-devel >= 2.0.0
26BuildRequires: GConf2-devel >= 2.12
27BuildRequires: perl >= 5.8.1 perl-XML-Parser
28Buildrequires: python >= 2.5
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30Provides: iBus
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: iwaim
35
36%description
37IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
38It provides full featured and user friendly input method user interface.
39It also may help developers to develop input method easily.
40
41%package devel
42Summary: Header files for iBus
43Group: Development/Libraries
44Requires: ibus == %{version}-%{release}
45Requires:   glib2-devel
46Requires:   dbus-devel
47%if %{?_dist_release} != "vl5"
48Requires:   vala
49%endif
50
51%description devel
52Header files for iBus.
53
54%prep
55%setup -q
56%patch0 -p1
57%configure --disable-static --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules
58
59%build
60make %{?_smp_mflags}
61
62%install
63rm -rf %{buildroot}
64make DESTDIR=%{buildroot} install
65
66rm -rf %{buildroot}%{_libdir}/libibus.la
67rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
68
69rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
70
71%if %{?_dist_release} == "vl5"
72rm -rf %{buildroot}%{_datadir}/vala
73%endif
74
75%find_lang %{name}
76
77%clean
78rm -rf %{buildroot}
79
80%check
81#make check
82%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
83%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
84
85
86%post
87/sbin/ldconfig
88if [ -x %{_bindir}/update-desktop-database ] ; then
89%{_bindir}/update-desktop-database %{_datadir}/applications
90fi
91%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
92export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
94# recreate icon cache
95touch --no-create %{_datadir}/icons/hicolor || :
96[ -x %{_bindir}/gtk-update-icon-cache ] && \
97  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
98
99
100%pre
101if [ "$1" -gt 1 ]; then
102    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
103    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
104fi
105
106
107%preun
108if [ "$1" -eq 0 ]; then
109    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
110    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
111fi
112
113
114%postun
115/sbin/ldconfig
116%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
117if [ -x %{_bindir}/update-desktop-database ] ; then
118%{_bindir}/update-desktop-database %{_datadir}/applications
119fi
120# recreate icon cache
121touch --no-create %{_datadir}/icons/hicolor || :
122[ -x %{_bindir}/gtk-update-icon-cache ] && \
123  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
124
125
126%files -f %{name}.lang
127%defattr(-,root,root,-)
128%doc AUTHORS COPYING ChangeLog NEWS README
129%{_bindir}/ibus*
130%{_libdir}/libibus.so.*
131%{_libdir}/gtk-2.0/immodules/im-ibus.so
132%{_libexecdir}/ibus-gconf
133%{_libexecdir}/ibus-ui-gtk
134%{_libexecdir}/ibus-x11
135#%{python_sitearch}/ibus
136%{python_sitelib}/ibus
137%{_datadir}/applications/*
138%{_datadir}/ibus
139%{_datadir}/gtk-doc/html/ibus
140%{_datadir}/icons/hicolor/*/apps/*
141#%{_sysconfdir}/xdg/autostart/ibus.desktop
142%{_sysconfdir}/gconf/schemas/ibus.schemas
143
144%files devel
145%defattr(-,root,root,-)
146%{_libdir}/pkgconfig/ibus-1.0.pc
147%{_libdir}/libibus.so
148%{_includedir}/ibus-1.0
149%if %{?_dist_release} != "vl5"
150%{_datadir}/vala/vapi/ibus-1.0.vapi
151%endif
152
153%changelog
154* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
155- new upstream release
156- update GTK immodule dir option for configure
157- add vapi file for VineSeed
158- add Requires: vala for devel package, VineSeed
159
160* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
161- update Requires: notify-python librsvg2
162- execute gconftool-2 on {post,pre,preun}
163- add Requires: Gconf2 on {post,pre,preun}
164- update Requires: glib2-devel dbus-devel for ibus-devel package
165- execute update-desktop-database on {post,postun}
166- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
167- add Requires: coreutils, gtk2 on {post,postun}
168- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
169
170* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
171- new upstream release
172- stop 'make check'
173
174* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
175- s/python_sitearch/python_sitelib/
176
177* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
178- new upstream release
179- execute 'make check'
180- clean up:
181  - drop unused git_source and vine_ja_po
182
183* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
184- new upstream release
185- stop 'make check'
186
187* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
188- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
189
190* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
191- new upstream release
192
193* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
194- new upstream release
195
196* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
197- new upstream release
198
199* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
200- new upstream release
201- add fix POFILES.in patch (Patch0)
202- update file list in %%files section
203- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
204
205* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
206- new upstream release
207
208* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
209- new upstream release
210- update %%files section
211- update BuildRequires
212- drop obsoleted configure option: --disable-qt4-immodule
213
214* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
215- new upstream release
216
217* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
218- new upstream release
219- add Packager tag
220
221* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
222- new upstream release
223
224* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
225- new upstream release
226- update BuildRequires
227  - add dbus-devel, intltool >= 0.40.0
228  - drop qt4-devel
229
230* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
231- new upstream release
232- drop defined python_sitearch rpm macro
233
234* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
235- new upstream release
236
237* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
238- new upstream release
239- drop Vine ja.po (SOURCE1)
240
241* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
242- new upstream release
243- update ja.po (SOURCE1)
244
245* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
246- new upstream release
247
248* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
249- add ja.po (SOURCE1): update
250- add ibus.desktop file in xdg autostart
251- add ibus.schemas file
252
253* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
254- set python_sitearch to arch independent path
255
256* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
257- new upstream release
258- add dbus-python version ( 0.83.0 and more ) in Requires
259- add BuildRequires: dbus-python-devel >= 0.83.0
260
261* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
262- new upstream release
263- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
264- generate devel sub package
265- stop creating qt4 immodule
266- drop .la files
267
268* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
269- initial release
Note: See TracBrowser for help on using the repository browser.