source: projects/specs/trunk/i/ibus-el/ibus-el-vl.spec @ 4868

Revision 4868, 3.3 KB checked in by munepi, 13 years ago (diff)

updated emacs24-vl.spec and ibus-el-vl.spec: supported emacs-24.0.90 (emacs-24.1 pretest)

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define origname ibus-el
4%define origver  0.2.1
5
6Summary:      a IBus client for GNU Emacs
7Summary(ja):  GNU Emacs 用 IBus クライアント
8Name:         %{origname}
9Version:      %{origver}
10Release:      3%{?_dist_release}
11
12# http://launchpad.net/ibus.el
13Source0:      ibus-el-%{version}.tar.gz
14Source1:      %{origname}-install.sh
15Source2:      %{origname}-remove.sh
16Source3:      vine-default-%{origname}.el
17Source4:      %{origname}-init.el
18
19#
20Patch0:       ibus-el-0.2.1-emacs-24.0.90.patch
21
22License:      GPLv3
23Group:        Applications/Editors/Emacs
24URL:          http://www11.atwiki.jp/s-irie/pages/21.html
25BuildRoot:    %{_tmppath}/%{name}-%{version}-root
26BuildArch:    noarch
27
28Requires:     emacsen
29PreReq:       emacsen
30%prereq_ge    emacsen-common
31Requires:     python >= 2.5
32Requires:     ibus >= 1.2
33Requires:     python-xlib
34
35Distribution: Vine Linux
36Vendor:       Project Vine
37Packager:     iwaim
38
39%description
40ibus.el is a IBus client for GNU Emacs. This program allows users
41on-the-spot style input with IBus. The input statuses are individually
42kept for each buffer, and prefix-keys such as C-x and C-c can be used
43even if IBus is active. So you can input various languages fast and
44comfortably by using it.
45
46%prep
47
48%setup -q -n %{origname}-%{origver}
49
50%patch0 -p1 -b .emacs24
51
52%build
53
54%install
55[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
56[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
57
58mkdir -p %{buildroot}%{_datadir}/%{name}
59install -m 0755 ibus-el-agent %{buildroot}%{_datadir}/%{name}
60
61mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
62mkdir -p %{buildroot}%{emacsen_pkgdir}/install
63mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
64
65#
66# install el files
67#
68
69cp -p *.el %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
70
71
72#
73# install script (bytecompile el and install elc , remove)
74#
75
76%_installemacsenscript %{origname} %{SOURCE1}
77
78%_removeemacsenscript  %{origname} %{SOURCE2}
79
80
81%clean
82[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
83
84%post
85#
86# bytecompile and install
87#
88if [ "$1" = 2 ]; then
89
90%_emacsenPackageRemove %{origname}
91
92fi
93
94%_addemacsenlist %{origname}
95
96%_emacsenPackageInstall %{origname}
97
98
99%preun
100if [ "$1" = 0 ]; then
101
102%_emacsenPackageRemove %{origname}
103
104%_removeemacsenlist %{origname}
105
106fi
107
108
109%files
110%defattr(-,root,root)
111%doc README doc/COPYING doc/ChangeLog
112%{_datadir}/emacs/site-lisp/%{origname}
113%{emacsen_pkgdir}/install/%{origname}
114%{emacsen_pkgdir}/remove/%{origname}
115%dir %{_datadir}/%{name}
116%{_datadir}/%{name}/ibus-el-agent
117
118%changelog
119* Mon Oct  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.1-3
120- supported emacs-24.0.90
121- updated ibus-el-init.el
122  - output "Loading vine-default-ibus-el ..." to the buffer *Messages*
123
124* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 0.2.1-2vl6
125- fix <BTS:VineLinux:1117>
126 - update vine-default-ibus-el.el (Source3): sync [VineSeed:22997]
127
128* Wed Nov 24 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
129- new upstream release
130
131* Tue Aug 31 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.0-1
132- new upstream release
133
134* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
135- new upstream release
136
137* Mon Jun  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
138- first release for Vine Linux
Note: See TracBrowser for help on using the repository browser.