source: projects/specs/trunk/h/hyperestraier/hyperestraier-vl.spec @ 10913

Revision 10913, 6.7 KB checked in by ara_t, 7 years ago (diff)

haskell-platform: update to 2016.8.0.1

Line 
1Summary: a full-text search system for communities
2Summary(ja): 全文検索システム
3Name: hyperestraier
4Version: 1.4.13
5Release: 9%{?_dist_release}
6License: LGPL 2.1
7Group: Applications/Text
8URL: http://fallabs.com/hyperestraier/
9
10Source0: http://fallabs.com/hyperestraier/%{name}-%{version}.tar.gz
11# extra filters
12Source10: estfxgunzip
13Source11: estfxmantohtml
14Patch0: hyperestraier-1.4.13-perl-vendordir.patch
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: qdbm-devel >= 1.8.75
18BuildRequires: zlib-devel >= 1.2.1
19BuildRequires: mecab-devel >= 0.92
20BuildRequires: perl
21Requires: qdbm >= 1.8.75
22Requires: zlib >= 1.2.1
23Requires: mecab >= 0.92
24Requires: mecab-ipadic >= 2.7.0
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: inagaki
29
30%description
31Hyper Estraier is a full-text search system. You can search lots of documents
32for some documents including specified words. If you run a web site, it is
33useful as your own search engine for pages in your site. Also, it is useful
34as search utilities of mail boxes and file servers.
35
36The characteristic of Hyper Estraier is the following.
37
38    * High performance of search
39    * High scalability of target documents
40    * Perfect recall ratio by N-gram method
41    * High precision by hybrid mechanism of N-gram and morphological analyzer
42    * Phrase search, regular expressions, attribute search, and similarity search
43    * Multilingualism with Unicode
44    * Independent of file format and repository
45    * Intelligent web crawler
46    * Simple and powerful API
47    * Supporting P2P architecture
48
49Hyper Estraier is an open-source software released under the terms of the
50GNU Lesser General Public License. It works on Linux, Windows, Mac OS X,
51and other UNIX-like systems.
52
53%description -l ja
54Hyper Estraierは全文検索システムです。たくさんの文書の中から、特定の語句を含むものを探して、該当するものの一覧を表示することができます。Web サイトを運営している方なら、自分のサイト専用の検索エンジンとして利用することができます。メールボックスやファイルサーバを対象とした検索ツールとして利用することもできます。
55
56Hyper Estraierには、次のような特徴があります。
57
58    * インデックスを使った高速な検索ができます。
59    * 大量の文書のインデックスを短時間で作成できます。
60    * N-gram方式による漏れのない検索ができます。
61    * 形態素解析とN-gramのハイブリッド機構で検索精度を向上させます。
62    * フレーズ検索や正規表現検索や属性検索や類似検索をサポートします。
63    * 世界各国の言語が扱えます。
64    * 対象文書の所在や形式に依存しません。
65    * 賢いWebクローラが付属しています。
66    * ライブラリとして各種製品に組み込めます。
67    * P2P連携機能をサポートします。
68
69Hyper EstraierはGNU Lesser General Public Licenseに基づいて配布されるフリーソフトウェアです。Linux、Windows、Mac OS Xおよびその他のUNIX系OSの上で動作します。
70
71%package devel
72Summary: Header files and libraries for developing apps which will using Hyper Estraier
73Summary(ja): Hyper Estraier を用いたアプリケーションの開発に必要なヘッダファイル、ライブラリ集
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: qdbm-devel >= 1.8.75
77Requires: zlib-devel >= 1.2.1
78
79%description devel
80Header files and libraries for developing apps which will using Hyper Estraier
81
82%package perl
83Summary: Perl module for Hyper Estraier
84Summary(ja): Hyper Estraier の Perl モジュール
85Group: Development/Libraries
86Requires: %{name} = %{version}-%{release}
87Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
88
89%description perl
90Perl module for Hyper Estraier
91
92%prep
93%setup -q
94%patch0 -p1 -b .perlvendordir
95
96%build
97%configure \
98    --enable-stable \
99    --enable-zlib \
100    --enable-mecab
101make
102
103pushd perlnative
104%configure
105make
106popd
107
108%install
109rm -rf %{buildroot}
110%makeinstall DESTDIR=%{buildroot}
111pushd perlnative
112%makeinstall DESTDIR=%{buildroot}
113popd
114
115## delete
116rm -rf %{buildroot}/usr/share/hyperestraier/doc
117rm -rf %{buildroot}/usr/share/hyperestraier/{COPYING,ChangeLog,THANKS}
118
119## install extra filters
120install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/hyperestraier/filter
121install -m755 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/hyperestraier/filter
122
123## for Perl
124perllocalfile=`find %{buildroot} -name perllocal.pod`
125echo "mv $perllocalfile ."
126mv $perllocalfile .
127
128sed -e "s@^%{buildroot}@@g" < %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist \
129       > .packlist
130mv -f .packlist %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist
131
132%clean
133rm -rf %{buildroot}
134
135%check
136make check
137
138%post -p /sbin/ldconfig
139
140%postun -p /sbin/ldconfig
141
142%files
143%defattr(-,root,root)
144%doc COPYING ChangeLog README THANKS doc example
145%{_bindir}/estbutler
146%{_bindir}/estcmd
147%{_bindir}/estconfig
148%{_bindir}/estmaster
149%{_bindir}/estwaver
150%{_bindir}/estcall
151%{_bindir}/estload
152%{_bindir}/estmttest
153%{_bindir}/estwolefind
154%{_mandir}/man1/*
155%{_libdir}/*.so.*
156%{_libexecdir}/*
157%{_datadir}/hyperestraier/*.*
158%{_datadir}/hyperestraier/filter
159%{_datadir}/hyperestraier/increm
160%{_datadir}/hyperestraier/locale
161
162%files devel
163%defattr(-,root,root)
164%{_mandir}/man3/estnode.3*
165%{_mandir}/man3/estraier.3*
166%{_libdir}/*.so
167%{_libdir}/*.a
168%{_libdir}/pkgconfig/hyperestraier.pc
169%{_includedir}/*.h
170
171%files perl
172%defattr(-,root,root)
173%doc perllocal.pod
174%{_bindir}/estcmd.pl
175%{perl_vendorarch}/Estraier.pm
176%{perl_vendorarch}/Estraier.pod
177%{perl_vendorarch}/auto/Estraier
178%{_mandir}/man3/Estraier.3pm*
179
180%changelog
181* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 1.4.13-2
182- rebuild with gcc-5.4.0
183
184* Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.13-8
185- rebuilt with perl 5.16.3
186- updated URL
187
188* Sat Dec 31 2011 IWAI <iwai@alib.jp> 1.4.13-7
189- build with mecab 0.99
190
191* Fri Apr  8 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.13-6vl6
192- build with perl 5.12.3
193- add Requires: perl(:MODULE_COMPAT_x.y.z) for perl subpackage
194
195* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.4.13-5
196- rebuilt with rpm-4.8.1 for pkg-config
197
198* Tue Apr  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-4
199- added Source10 and 11 for indexing JF, JM
200
201* Mon Mar 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-3
202- rebuilt with new toolchain
203
204* Sun May 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-2
205- added BR: qdbm-devel, zlib-devel to devel package
206
207* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.13-1vl5
208- applied new versioning policy, spec in utf-8
209- built with perl-5.10.0
210
211* Sat Jan 19 2008 IWAI, Masaharu <iwai@alib.jp> 1.4.13-0vl1
212- initial release
Note: See TracBrowser for help on using the repository browser.