source: projects/specs/trunk/h/http-parser/http-parser-vl.spec @ 10913

Revision 10913, 2.3 KB checked in by ara_t, 7 years ago (diff)

haskell-platform: update to 2016.8.0.1

Line 
1Summary:        http request/response parser for c
2Name:           http-parser
3Version:        2.4.2
4Release:        2%{?_dist_release}
5License:        MIT
6Group:          System Environment/Libraries
7URL:            https://github.com/joyent/http-parser
8
9# https://github.com/joyent/%{name}/archive/v%{version}.tar.gz
10Source0:        %{name}-%{version}.tar.gz
11
12# based on fedora
13Patch0:         http-parser-gyp-sharedlib.patch
14
15BuildRequires: gyp
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21Packager:       Takemikaduchi
22
23%description
24This is a parser for HTTP messages written in C. It parses both
25requests and responses. The parser is designed to be used in
26performance HTTP applications. It does not make any syscalls nor
27allocations, it does not buffer data, it can be interrupted at
28anytime. Depending on your architecture, it only requires about
2940 bytes of data per message stream
30(in a web server that is per connection).
31
32%package        devel
33Summary:        Development tools for %{name}
34Summary(ja):    %{name} の開発環境
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       pkgconfig
38
39%description    devel
40Header files and libraries for building a extension library for the %{name}.
41
42
43%prep
44%setup -q
45%patch0 -p1
46
47
48%build
49export CFLAGS='%{optflags} -fPIC'
50gyp -f make --depth=`pwd` http_parser.gyp
51make %{?_smp_mflags} BUILDTYPE=Release
52
53
54%install
55rm -rf ${RPM_BUILD_ROOT}
56
57mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}
58mkdir -p ${RPM_BUILD_ROOT}/%{_includedir}
59
60mv out/Release/lib.target/libhttp_parser.so.2 libhttp_parser.so.%{version}
61install -m 0755 libhttp_parser.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libhttp_parser.so.%{version}
62ln -sf libhttp_parser.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libhttp_parser.so.2
63install libhttp_parser.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libhttp_parser.so
64install -m 0644 http_parser.h ${RPM_BUILD_ROOT}%{_includedir}/
65
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70%post -p /sbin/ldconfig
71
72%postun -p /sbin/ldconfig
73
74
75%files
76%defattr(-,root,root,-)
77%doc LICENSE-MIT README.md
78%{_libdir}/libhttp_parser.so.*
79
80%files devel
81%defattr(-,root,root,-)
82%{_includedir}/http_parser.h
83%{_libdir}/libhttp_parser.so
84
85
86%changelog
87* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 2.4.2-2
88- rebuild with gcc-5.4.0
89
90* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-1
91- initial build based on fedora
92
Note: See TracBrowser for help on using the repository browser.