source: projects/specs/trunk/h/html-helper-mode/html-helper-mode-vl.spec @ 866

Revision 866, 5.3 KB checked in by iwaim, 14 years ago (diff)

html-helper-mode 2.19.1.1-7

Line 
1%define       _noVersionedDependencies        1
2%define       prereq_ge()   %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define       origname      html-helper-mode
4%define       origver       2.19.1.1
5%define       release       7
6%define       emacsen_pkgdir /usr/lib/emacsen-common/packages
7
8# Main
9Summary: Major mode for editing HTML (for Emacsen)
10Name: %{origname}
11Version: %{origver}
12Release: %{release}%{?_dist_release}
13License: GPLv2+
14Group: Applications/Editors/Emacs
15URL: http://www.santafe.edu/~nelson/tools/
16Source0: http://www.santafe.edu/~nelson/hhm-beta/html-helper-mode.el
17Source1: http://www.santafe.edu/~nelson/hhm-beta/tempo.el
18Source2: http://www.santafe.edu/~nelson/hhm-beta/index.html
19Source3: http://www.santafe.edu/~nelson/tools/configuring.html
20Source4: http://www.santafe.edu/~nelson/tools/differences.html
21Source5: http://www.santafe.edu/~nelson/tools/documentation.html
22Source6: http://www.santafe.edu/~nelson/tools/keybindings.html
23Source7: hhm.dot.emacs
24Source8: HHM-MK
25Source9: html-helper-mode-install.sh
26Source10: html-helper-mode-remove.sh
27Source11: vine-default-%{origname}.el
28Source12: %{origname}-init.el
29Buildroot: %{_tmppath}/%{name}-root
30PreReq:       emacsen
31Requires:     emacsen
32%prereq_ge emacsen-common
33
34BuildArchitectures: noarch
35#Obsoletes: %{name}-2.19.1.1-3
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40%description
41html-helper-mode makes it easier to write HTML documents.
42This mode handles inserting HTML codes in a variety of ways
43(keybindings, completion in the buffer).
44It also supports indentation, timestamps, skeletons for new documents,
45hilit19 patterns, and a variety of other things.
46
47Initialization
48===============
49Please refer the following file:
50  "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
51  "%{_docdir}/%{name}-%{version}/*.html"
52
53%description -l ja
54html-helper-mode は、HTML ドキュメントの作成を簡単にします。
55このモードでは、HTML コードの挿入に多様な方法が使えます。
56また、INDENTATION、タイムスタンプ等をサポートします。
57
58初期設定
59=========
60下記を参考にしてください:
61  "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
62  "%{_docdir}/%{name}-%{version}/*.html"
63
64# '
65%prep
66%setup -q -T -c %{name}-%{version}
67cp %SOURCE0 ./
68cp %SOURCE1 ./
69cp %SOURCE2 ./
70cp %SOURCE3 ./
71cp %SOURCE4 ./
72cp %SOURCE5 ./
73cp %SOURCE6 ./
74cp %SOURCE7 ./
75cp %SOURCE8 ./
76
77%build
78# byte-compile
79#emacs-%{emacsver} -batch -l HHM-MK
80
81%install
82[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
83[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
84
85mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
86mkdir -p %{buildroot}%{emacsen_pkgdir}/install
87mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
88
89#
90# install el files
91#
92cp -a html-helper-mode.el tempo.el HHM-MK %{SOURCE11} %{SOURCE12} \
93      ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
94
95#
96# install  script( bytecompile el and install elc , remove )   
97#
98%_installemacsenscript %{origname} %{SOURCE9}
99
100%_removeemacsenscript  %{origname} %{SOURCE10}
101
102%post
103#
104# bytecompile and install
105#
106
107if [ "$1" = 2 ]; then
108
109%_emacsenPackageRemove %{origname}
110
111fi
112
113%_addemacsenlist %{origname}
114
115%_emacsenPackageInstall %{origname}
116
117
118%preun
119if [ "$1" = 0 ]; then
120
121%_emacsenPackageRemove %{origname}
122
123%_removeemacsenlist %{origname}
124
125fi
126
127%clean
128[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
129
130rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
131
132
133%files
134%defattr(-,root,root)
135%doc *.html hhm.dot.emacs
136%{_datadir}/emacs/site-lisp/%{origname}
137%{emacsen_pkgdir}/install/%{origname}
138%{emacsen_pkgdir}/remove/%{origname}
139
140%changelog
141* Mon Apr 19 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-7
142- fix html-helper-mode-install.sh: installing vine-default file
143
144* Wed Apr  7 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-6
145- apply vine-default
146 - add vine-default (Source11)
147 - add init.el (Source12)
148 - update html-helper-mode-{install,removce}.sh for init.el file
149- using %%{emacsen_pkgdir} macro
150- update %%description
151
152* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.19.1.1-5
153- spec in utf8
154- applied new versioning policy
155
156* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19.1.1-4vl3
157- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
158- s/Copyright/License/
159
160* Wed Jan  2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.19.1.1-4vl2
161- emacsenize
162- rewrite Summary and %%description for emacesnize
163
164* Sun Oct 15 2000 Jun Nishii <jun@vinelinux.org>
165- 2.19.1.1-4vl1
166- rebuid for Vine Linux 2.1/emacs-20.7
167
168* Mon Apr 17 2000 Jun Nishii <jun@vinelinux.org>
169- rebuid for Vine Linux 2.0
170
171* Fri Dec 17 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
172- Released as version "html-helper-mode-emacs20-2.19.1.1-3".
173
174Changed from "html-helper-mode-emacs20-2.19.1.1-2".
175- Changed emacs version, "20.4" => "20.5".
176- Revised some, the definition part of data.
177 
178* Thu Dec  2 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
179- Released as version "html-helper-mode-emacs20-2.19.1.1-2".
180
181Changed from "html-helper-mode-emacs20-2.19.1.1-1".
182- Added source file, "HHM-MK".
183- Revised some, the definition part of data.
184- Revised some, part of "%description, %build".
185
186* Thu Nov 25 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
187- Released as version "html-helper-mode-emacs20-2.19.1.1-1".
188
189# $Id: html-helper-mode-emacs20-2.19.1.1.spec,v 1.7 1999-12-17 17:50:58+09 ushio Exp $
Note: See TracBrowser for help on using the repository browser.