source: projects/specs/trunk/h/html-helper-mode/html-helper-mode-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define       _noVersionedDependencies        1
2%define       prereq_ge()   %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define       origname      html-helper-mode
4%define       origver       2.19.1.1
5%define       release       5%{?_dist_release}
6
7# Main
8Summary: Major mode for editing HTML (for Emacsen)
9Name: %{origname}
10Version: %{origver}
11Release: %{release}
12License: GPL2
13Group: Applications/Editors/Emacs
14URL: http://www.santafe.edu/~nelson/tools/
15Source0: http://www.santafe.edu/~nelson/hhm-beta/html-helper-mode.el
16Source1: http://www.santafe.edu/~nelson/hhm-beta/tempo.el
17Source2: http://www.santafe.edu/~nelson/hhm-beta/index.html
18Source3: http://www.santafe.edu/~nelson/tools/configuring.html
19Source4: http://www.santafe.edu/~nelson/tools/differences.html
20Source5: http://www.santafe.edu/~nelson/tools/documentation.html
21Source6: http://www.santafe.edu/~nelson/tools/keybindings.html
22Source7: hhm.dot.emacs
23Source8: HHM-MK
24Source9: html-helper-mode-install.sh
25Source10: html-helper-mode-remove.sh
26Buildroot: %{_tmppath}/%{name}-root
27PreReq:       emacsen
28Requires:     emacsen
29%prereq_ge emacsen-common
30
31BuildArchitectures: noarch
32#Obsoletes: %{name}-2.19.1.1-3
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38NOTE:
39It require following,
40so please get and install them before to install it.
41=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
42Emacs:
43emacsen and emacsen-common
44=====================================================
45
46What's html-helper-mode
47========================
48html-helper-mode makes it easier to write HTML documents.
49This mode handles inserting HTML codes in a variety of ways
50(keybindings, completion in the buffer).
51It also supports indentation, timestamps, skeletons for new documents,
52hilit19 patterns, and a variety of other things.
53
54Initialization
55===============
56Please refer the following file:
57  "/usr/doc/%{name}-%{version}/hhm.dot.emacs"
58  "/usr/doc/%{name}-%{version}/*.html"
59
60%description -l ja
61注意:
62以下が必要ですので、
63インストール前にそれらをインストールして下さい。
64=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
65Emacs:
66emacsen と emacsen-common
67================================================
68
69html-helper-mode とは
70======================
71html-helper-mode は、HTML ドキュメントの作成を簡単にします。
72このモードでは、HTML コードの挿入に多様な方法が使えます。
73また、INDENTATION、タイムスタンプ等をサポートします。
74
75初期設定
76=========
77下記を参考にしてください:
78  "/usr/doc/%{name}-%{version}/hhm.dot.emacs"
79  "/usr/doc/%{name}-%{version}/*.html"
80
81# '
82%prep
83%setup -q -T -c %{name}-%{version}
84cp %SOURCE0 ./
85cp %SOURCE1 ./
86cp %SOURCE2 ./
87cp %SOURCE3 ./
88cp %SOURCE4 ./
89cp %SOURCE5 ./
90cp %SOURCE6 ./
91cp %SOURCE7 ./
92cp %SOURCE8 ./
93
94%build
95# byte-compile
96#emacs-%{emacsver} -batch -l HHM-MK
97
98%install
99[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
100[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
101
102mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
103mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
104mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
105
106#
107# install el files
108#
109cp -a html-helper-mode.el tempo.el HHM-MK \
110      ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
111
112#
113# install  script( bytecompile el and install elc , remove )   
114#
115%_installemacsenscript %{origname} %{SOURCE9}
116
117%_removeemacsenscript  %{origname} %{SOURCE10}
118
119%post
120#
121# bytecompile and install
122#
123
124if [ "$1" = 2 ]; then
125
126%_emacsenPackageRemove %{origname}
127
128fi
129
130%_addemacsenlist %{origname}
131
132%_emacsenPackageInstall %{origname}
133
134
135%preun
136if [ "$1" = 0 ]; then
137
138%_emacsenPackageRemove %{origname}
139
140%_removeemacsenlist %{origname}
141
142fi
143
144%clean
145[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
146
147rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
148
149
150%files
151%defattr(-,root,root)
152%doc *.html hhm.dot.emacs
153%{_datadir}/emacs/site-lisp/%{origname}/
154/usr/lib/emacsen-common/packages/install/%{origname}
155/usr/lib/emacsen-common/packages/remove/%{origname}
156
157
158%changelog
159* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.19.1.1-5
160- spec in utf8
161- applied new versioning policy
162
163* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19.1.1-4vl3
164- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
165- s/Copyright/License/
166
167* Wed Jan  2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.19.1.1-4vl2
168- emacsenize
169- rewrite Summary and %%description for emacesnize
170
171* Sun Oct 15 2000 Jun Nishii <jun@vinelinux.org>
172- 2.19.1.1-4vl1
173- rebuid for Vine Linux 2.1/emacs-20.7
174
175* Mon Apr 17 2000 Jun Nishii <jun@vinelinux.org>
176- rebuid for Vine Linux 2.0
177
178* Fri Dec 17 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
179- Released as version "html-helper-mode-emacs20-2.19.1.1-3".
180
181Changed from "html-helper-mode-emacs20-2.19.1.1-2".
182- Changed emacs version, "20.4" => "20.5".
183- Revised some, the definition part of data.
184 
185* Thu Dec  2 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
186- Released as version "html-helper-mode-emacs20-2.19.1.1-2".
187
188Changed from "html-helper-mode-emacs20-2.19.1.1-1".
189- Added source file, "HHM-MK".
190- Revised some, the definition part of data.
191- Revised some, part of "%description, %build".
192
193* Thu Nov 25 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
194- Released as version "html-helper-mode-emacs20-2.19.1.1-1".
195
196# $Id: html-helper-mode-emacs20-2.19.1.1.spec,v 1.7 1999-12-17 17:50:58+09 ushio Exp $
Note: See TracBrowser for help on using the repository browser.