source: projects/specs/trunk/h/html-helper-mode/html-helper-mode-vl.spec @ 5689

Revision 5689, 5.3 KB checked in by munepi, 12 years ago (diff)

updated html-helper-mode-vl.spec

Line 
1%define       _noVersionedDependencies        1
2%define       prereq_ge()   %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define       origname      html-helper-mode
4%define       origver       2.19.1.1
5%define       release       8
6
7# Main
8Summary: Major mode for editing HTML (for Emacsen)
9Name: %{origname}
10Version: %{origver}
11Release: %{release}%{?_dist_release}
12License: GPLv2+
13Group: Applications/Editors/Emacs
14URL: http://www.santafe.edu/~nelson/tools/
15Source0: http://www.santafe.edu/~nelson/hhm-beta/html-helper-mode.el
16Source1: http://www.santafe.edu/~nelson/hhm-beta/tempo.el
17Source2: http://www.santafe.edu/~nelson/hhm-beta/index.html
18Source3: http://www.santafe.edu/~nelson/tools/configuring.html
19Source4: http://www.santafe.edu/~nelson/tools/differences.html
20Source5: http://www.santafe.edu/~nelson/tools/documentation.html
21Source6: http://www.santafe.edu/~nelson/tools/keybindings.html
22Source7: hhm.dot.emacs
23Source8: HHM-MK
24Source9: html-helper-mode-install.sh
25Source10: html-helper-mode-remove.sh
26Source11: vine-default-%{origname}.el
27Source12: %{origname}-init.el
28Buildroot: %{_tmppath}/%{name}-root
29PreReq:       emacsen
30Requires:     emacsen
31%prereq_ge emacsen-common
32
33BuildArchitectures: noarch
34#Obsoletes: %{name}-2.19.1.1-3
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%description
40html-helper-mode makes it easier to write HTML documents.
41This mode handles inserting HTML codes in a variety of ways
42(keybindings, completion in the buffer).
43It also supports indentation, timestamps, skeletons for new documents,
44hilit19 patterns, and a variety of other things.
45
46Initialization
47===============
48Please refer the following file:
49  "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
50  "%{_docdir}/%{name}-%{version}/*.html"
51
52%description -l ja
53html-helper-mode は、HTML ドキュメントの作成を簡単にします。
54このモードでは、HTML コードの挿入に多様な方法が使えます。
55また、INDENTATION、タイムスタンプ等をサポートします。
56
57初期設定
58=========
59下記を参考にしてください:
60  "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
61  "%{_docdir}/%{name}-%{version}/*.html"
62
63# '
64%prep
65%setup -q -T -c %{name}-%{version}
66cp %SOURCE0 ./
67cp %SOURCE1 ./
68cp %SOURCE2 ./
69cp %SOURCE3 ./
70cp %SOURCE4 ./
71cp %SOURCE5 ./
72cp %SOURCE6 ./
73cp %SOURCE7 ./
74cp %SOURCE8 ./
75
76%build
77# byte-compile
78#emacs-%{emacsver} -batch -l HHM-MK
79
80%install
81[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
82[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
83
84mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
85mkdir -p %{buildroot}%{emacsen_pkgdir}/install
86mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
87
88#
89# install el files
90#
91cp -a html-helper-mode.el tempo.el HHM-MK %{SOURCE11} %{SOURCE12} \
92      ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
93
94#
95# install  script( bytecompile el and install elc , remove )   
96#
97%_installemacsenscript %{origname} %{SOURCE9}
98
99%_removeemacsenscript  %{origname} %{SOURCE10}
100
101%post
102#
103# bytecompile and install
104#
105
106if [ "$1" = 2 ]; then
107
108%_emacsenPackageRemove %{origname}
109
110fi
111
112%_addemacsenlist %{origname}
113
114%_emacsenPackageInstall %{origname}
115
116
117%preun
118if [ "$1" = 0 ]; then
119
120%_emacsenPackageRemove %{origname}
121
122%_removeemacsenlist %{origname}
123
124fi
125
126%clean
127[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
128
129rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
130
131
132%files
133%defattr(-,root,root)
134%doc *.html hhm.dot.emacs
135%{_datadir}/emacs/site-lisp/%{origname}
136%{emacsen_pkgdir}/install/%{origname}
137%{emacsen_pkgdir}/remove/%{origname}
138
139%changelog
140* Sun Feb 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.19.1.1-8
141- updated html-helper-mode-init.el
142
143* Mon Apr 19 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-7
144- fix html-helper-mode-install.sh: installing vine-default file
145
146* Wed Apr  7 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-6
147- apply vine-default
148 - add vine-default (Source11)
149 - add init.el (Source12)
150 - update html-helper-mode-{install,removce}.sh for init.el file
151- using %%{emacsen_pkgdir} macro
152- update %%description
153
154* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.19.1.1-5
155- spec in utf8
156- applied new versioning policy
157
158* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19.1.1-4vl3
159- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
160- s/Copyright/License/
161
162* Wed Jan  2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.19.1.1-4vl2
163- emacsenize
164- rewrite Summary and %%description for emacesnize
165
166* Sun Oct 15 2000 Jun Nishii <jun@vinelinux.org>
167- 2.19.1.1-4vl1
168- rebuid for Vine Linux 2.1/emacs-20.7
169
170* Mon Apr 17 2000 Jun Nishii <jun@vinelinux.org>
171- rebuid for Vine Linux 2.0
172
173* Fri Dec 17 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
174- Released as version "html-helper-mode-emacs20-2.19.1.1-3".
175
176Changed from "html-helper-mode-emacs20-2.19.1.1-2".
177- Changed emacs version, "20.4" => "20.5".
178- Revised some, the definition part of data.
179 
180* Thu Dec  2 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
181- Released as version "html-helper-mode-emacs20-2.19.1.1-2".
182
183Changed from "html-helper-mode-emacs20-2.19.1.1-1".
184- Added source file, "HHM-MK".
185- Revised some, the definition part of data.
186- Revised some, part of "%description, %build".
187
188* Thu Nov 25 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
189- Released as version "html-helper-mode-emacs20-2.19.1.1-1".
190
191# $Id: html-helper-mode-emacs20-2.19.1.1.spec,v 1.7 1999-12-17 17:50:58+09 ushio Exp $
Note: See TracBrowser for help on using the repository browser.