source: projects/specs/trunk/h/htdig/htdig-vl.spec @ 521

Revision 521, 10.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define vine4 1
2
3%define date 20030601
4%define buildweb 1
5%define beta b6
6
7%if %{vine4}
8%define contentdir /var/www
9%define apachebin %{_sbindir}/apache2
10%else
11%define contentdir /home/httpd
12%define apachebin %{_sbindir}/httpd
13%endif
14
15Summary: ht://Dig - Web search engine
16Name: htdig
17Version: 3.2.0
18#Release: 6.1vl1.%{beta}
19Release: 7.%{beta}%{?_dist_release}
20License: GPL
21Group: Applications/Internet
22Url: http://www.htdig.org/
23Source: http://www.htdig.org/files/%{name}-%{version}%{beta}.tar.bz2
24Source1: htdig.conf
25Patch0: htdig-3.1.5-rh.patch
26Patch1: htdig-3.2.0b3-glibc222.patch
27Patch2: htdig-3.2.0b4-xopen.patch
28Patch3: htdig-3.2.0b4-h_hash.patch
29Patch4: htdig-3.2.0b5-overflow.patch
30Patch5: htdig-3.2.0b5-expr.patch
31Patch6: htdig-3.2.0b5-destdir.patch
32Patch7: htdig-3.2.0b5-mktemp.patch
33# build for gcc4
34Patch100: htdig-3.2.0b6-gcc4.patch
35
36BuildRequires: flex >= 2.5.4a-13
37BuildRequires: zlib-devel
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40%package web
41Summary: Scripts and HTML code needed for using ht://Dig as a web search engine
42Group: Applications/Internet
43Requires: %{name} = %{version} webserver
44
45%description
46The ht://Dig system is a complete world wide web indexing and searching
47system for a small domain or intranet. This system is not meant to replace
48the need for powerful internet-wide search systems like Lycos, Infoseek,
49Webcrawler and AltaVista. Instead it is meant to cover the search needs for
50a single company, campus, or even a particular sub section of a web site. As
51opposed to some WAIS-based or web-server based search engines, ht://Dig can
52span several web servers at a site. The type of these different web servers
53doesn't matter as long as they understand the HTTP 1.0 protocol.
54ht://Dig is also used by KDE to search KDE's HTML documentation.
55
56ht://Dig was developed at San Diego State University as a way to search the
57various web servers on the campus network.
58
59%description web
60The ht://Dig system is a complete world wide web indexing and searching
61system for a small domain or intranet. This system is not meant to replace
62the need for powerful internet-wide search systems like Lycos, Infoseek,
63Webcrawler and AltaVista. Instead it is meant to cover the search needs for
64a single company, campus, or even a particular sub section of a web site. As
65opposed to some WAIS-based or web-server based search engines, ht://Dig can
66span several web servers at a site. The type of these different web servers
67doesn't matter as long as they understand the HTTP 1.0 protocol.
68
69The %{name}-web package includes CGI scripts and HTML code needed to use
70ht://Dig on a website.
71
72ht://Dig was developed at San Diego State University as a way to search the
73various web servers on the campus network.
74
75
76%prep
77%setup -q -n %{name}-%{version}%{beta}
78%patch -p1 -b .rh
79%patch1 -p1 -b .glibc222
80%patch2 -p1 -b .xopen
81%patch3 -p1 -b .h_hash
82%patch4 -p1 -b .overflow
83#patch5 -p1 -b .expr
84#patch6 -p1 -b .destdir
85#patch7 -p1 -b .mktemp
86
87%patch100 -p1 -b .gcc4
88
89# Fix the flex output file for glibc 2.2 compatibility
90cd htcommon
91flex -oconf_lexer.cxx conf_lexer.lxx
92cd ..
93
94cd htlib
95# This is a *VERY* dirty hack, until I figure out what's
96# causing this to break...
97for i in *.cc; do
98        mv $i $i.foo
99        cat >$i <<EOF
100#include <stdio.h>
101#include <string.h>
102EOF
103        cat $i.foo >>$i
104        rm -f $i.foo
105done
106for i in clib.h; do
107        mv $i $i.foo
108        cat >$i <<EOF
109#include "htconfig.h"
110EOF
111        cat $i.foo >>$i
112        rm -f $i.foo
113done
114
115%build
116%configure \
117        --enable-shared \
118        --enable-tests \
119        --enable-bigfile \
120        --with-config-dir=%{_sysconfdir}/htdig \
121        --with-common-dir=%{contentdir}/html/htdig \
122        --with-database-dir=/var/lib/htdig \
123        --localstatedir=/var/lib/htdig \
124        --with-cgi-bin-dir=%{contentdir}/cgi-bin \
125        --with-image-dir=%{contentdir}/html/htdig \
126        --with-search-dir=%{contentdir}/html/htdig \
127        --with-default-config-file=%{_sysconfdir}/htdig/htdig.conf \
128        --with-apache=%{apachebin} \
129        --with-zlib=%{_prefix}
130make
131
132%install
133rm -rf $RPM_BUILD_ROOT
134make install DESTDIR=$RPM_BUILD_ROOT
135
136ln $RPM_BUILD_ROOT%{contentdir}/cgi-bin/htsearch $RPM_BUILD_ROOT%{_bindir}
137
138chmod 644 $RPM_BUILD_ROOT%{contentdir}/html/htdig/*
139ln -sf search.html $RPM_BUILD_ROOT%{contentdir}/html/htdig/index.html
140# now get rid of the $RPM_BUILD_ROOT paths in the conf files
141for i in %{_sysconfdir}/htdig/htdig.conf /usr/bin/rundig ; do
142        perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT/$i
143done
144mkdir -p $RPM_BUILD_ROOT%{_prefix}/share
145mv $RPM_BUILD_ROOT%{contentdir}/html/htdig $RPM_BUILD_ROOT%{_prefix}/share
146mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
147install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/conf.d/htdig.conf
148
149rm -rf $RPM_BUILD_ROOT%{_includedir}
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%files
155%defattr(-,root,root)
156%doc htdoc/*
157%dir %{_sysconfdir}/htdig
158%config %{_sysconfdir}/htdig/htdig.conf
159%config %{_sysconfdir}/htdig/cookies.txt
160%{_sysconfdir}/htdig/HtFileType-magic.mime
161%{_sysconfdir}/htdig/mime.types
162%dir /var/lib/htdig
163%{_bindir}/*
164%{_libdir}/htdig
165%{_libdir}/htdig_db
166%{_mandir}/man1/*
167
168%if %buildweb
169%files web
170%defattr(-,root,root)
171%{contentdir}/cgi-bin/*
172%config %{_sysconfdir}/httpd/conf.d/htdig.conf
173%dir %{_datadir}/htdig
174%{_datadir}/htdig/*
175%{_mandir}/man8/*
176%endif
177
178%changelog
179* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.0-7.b6vl5
180- applied new versioning policy
181
182* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-6.1vl1.b6
183- new upstream release
184- added Patch100 for building with gcc4
185
186* Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl1.b5
187- rebuild for VineSeedPlus
188
189* Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl0.b5
190- build for VinePlus/2.6
191- remove commented lines
192- change configure options for apache of Vine
193
194* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
195- rebuilt
196
197* Thu Feb 26 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-6
198- Removed buildroot cruft from HtFileFype (#116442).
199- Use mktemp in HtFileFype to create temporary file (#116443).
200
201* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
202- rebuilt
203
204* Thu Jan 15 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-4
205- Fixed missing & in if clause.
206
207* Tue Jan 13 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-3
208- Fixed latin1 char translation (#71921).
209- Fixed overflow bug in WordDBPage.cc (#110802).
210
211* Mon Jan 12 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-2
212- Moved /usr/share/htdig files to web package (#111938).
213
214* Fri Dec 12 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-1
215- Update to latest stable upstream version htdig-3.2.0b5.
216
217* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
218- rebuilt
219
220* Wed Jun 04 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-18.20030601
221- Update to htdig-3.2.0b4-20030601 snapshot.
222- Fixed build problems.
223
224* Thu Mar 06 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-17.20030302
225- Update to htdig-3.2.0b4-20030302 snapshot.
226
227* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
228- rebuilt
229
230* Wed Jan  8 2003 Jeff Johnson <jbj@redhat.com> 3.2.0-15.20021103
231- don't include -debuginfo files in package.
232
233* Tue Dec 17 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-14.20021103
234- Forgot to create conf.d directory. Fixed.
235- Fixed wrong files section.
236
237* Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-13.20021103
238- Removed symlink from %{contentdir}/html and replaced it with httpd.d conf
239  file (#73518).
240
241* Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-12.20021103
242- Added webserver requirement for htdig-web package (#73986).
243
244* Wed Dec 04 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-11.20021103
245- Fix for autoFOO patch.
246- Fix x64_64 build.
247
248* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 3.2.0-9.20021103
249- rebuild on all arches
250
251* Fri Nov 08 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-8.20021103
252- Updated to htdig-3.2.0b4-20021103.
253- Fixed %files section errors.
254
255* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.2.0-7.20020505
256- rebuilt with gcc-3.2 (we hope)
257
258* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 3.2.0-6.20020505
259- build using gcc-3.2-0.1
260
261* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.2.0-5.20020505
262- automated rebuild
263
264* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-4.20020505
265- Don't forcibly strip binaries
266
267* Thu May 23 2002 Tim Powers <timp@redhat.com>
268- automated rebuild
269
270* Mon May  6 2002 Bernhard Rosenkraenzer <bero@linux-easy.com> 3.2.0-2.20020505
271- Fix build with current toolchain (automake 1.6, autoconf 2.53 changes)
272- Update snapshot, fixes some more problems
273
274* Thu Jan 24 2002 Phil Knirsch <pknirsch@redhat.com>
275- Updated to latest snapshot to fix several problems.
276- Fixed a problem with htdig segfaulting on s390 (#58202).
277
278* Fri Jul 20 2001 Philipp Knirsch <pknirsch@redhat.de>
279- Added missing BuildRequires: zlib-devel (#49500)
280
281* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
282- Bump release + rebuild.
283
284* Fri Apr 27 2001 Bill Nottingham <notting@redhat.com>
285- rebuild for C++ exception handling on ia64
286
287* Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.2.0-0.b3.4
288- move pictures etc. to base package and to a directory outside of
289  /var/www - The current KDevelop search function doesn't work without
290  them.
291
292* Mon Mar  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
293- Add htsearch to the base package, kdevelop needs it
294
295* Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
296- Move the web related files to a separate package
297
298* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
299- 3.2.0b2
300- fix build with glibc 2.2 and gcc 2.96
301
302* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
303- fix syntax error introduced in our patch (#16598)
304
305* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
306- fixed group to be a valid one
307
308* Mon Jul 24 2000 Prospector <prospector@redhat.com>
309- rebuilt
310
311* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
312- rebuild for Power Tools
313
314* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
315- rebuild for Power Tools
316
317* Sat Feb 26 2000 Nalin Dahyabhai <nalin@redhat.com>
318- 3.1.5
319
320* Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
321- 3.1.4
322- fix URL and source location
323
324* Tue Sep 28 1999 Preston Brown <pbrown@redhat.com>
325- 3.1.3 for SWS 3.1
326
327* Wed May 05 1999 Preston Brown <pbrown@redhat.com>
328- updates for SWS 3.0
329
330* Mon Aug 31 1998 Preston Brown <pbrown@redhat.com>
331- Updates for SWS 2.0
332
333* Sat Feb 07 1998 Cristian Gafton <gafton@redhat.com>
334- built against glibc
335- build all the fuzzy databases before packaging, because it is time
336  consuming operation and we don't want the user to be impatient
Note: See TracBrowser for help on using the repository browser.