source: projects/specs/trunk/h/htdig/htdig-vl.spec @ 10913

Revision 10913, 10.6 KB checked in by ara_t, 7 years ago (diff)

haskell-platform: update to 2016.8.0.1

Line 
1%define buildweb 1
2%define beta b6
3
4%define contentdir /var/www
5%define apachebin %{_sbindir}/apache2
6
7Name: htdig
8Summary: ht://Dig - Web search engine
9Summary(ja): ht://Dig Web 検索エンジン
10Version: 3.2.0
11Release: 10.%{beta}%{?_dist_release}
12
13License: GPLv2
14Group: Applications/Internet
15URL: http://www.htdig.org/
16
17Source: http://www.htdig.org/files/%{name}-%{version}%{beta}.tar.bz2
18Source1: htdig.conf
19Patch1: htdig-3.1.5-rh.patch
20Patch2: htdig-3.2.0b4-xopen.patch
21Patch4: htdig-3.2.0b5-overflow.patch
22Patch5: htdig-3.2.0b6-robots.patch
23Patch6: htdig-3.2.0b6-unescaped_output.patch
24Patch8: htdig-3.2.0b6-compile-fix.patch
25Patch9: htdig-3.2.0b6-opts.patch
26Patch11: htdig-3.2.0b6-incremental.patch
27Patch12: htdig-3.2-CVE-2007-6110.patch
28Patch13: htdig-3.2.0b6-htstat-segv.patch
29Patch14: htdig-3.2.0-external_parsers.patch
30Patch15: htdig-3.2.0-allow_numbers.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: flex >= 2.5.4a-13
34BuildRequires: zlib-devel
35BuildRequires: openssl-devel
36BuildRequires: apache2
37BuildRequires: autoconf automake libtool
38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%package web
43Summary: Scripts and HTML code needed for using ht://Dig as a web search engine
44Group: Applications/Internet
45Requires: %{name} = %{version}
46Requires: webserver
47
48%description
49The ht://Dig system is a complete world wide web indexing and searching
50system for a small domain or intranet. This system is not meant to replace
51the need for powerful internet-wide search systems like Lycos, Infoseek,
52Webcrawler and AltaVista. Instead it is meant to cover the search needs for
53a single company, campus, or even a particular sub section of a web site. As
54opposed to some WAIS-based or web-server based search engines, ht://Dig can
55span several web servers at a site. The type of these different web servers
56doesn't matter as long as they understand the HTTP 1.0 protocol.
57ht://Dig is also used by KDE to search KDE's HTML documentation.
58
59ht://Dig was developed at San Diego State University as a way to search the
60various web servers on the campus network.
61
62%description web
63The ht://Dig system is a complete world wide web indexing and searching
64system for a small domain or intranet. This system is not meant to replace
65the need for powerful internet-wide search systems like Lycos, Infoseek,
66Webcrawler and AltaVista. Instead it is meant to cover the search needs for
67a single company, campus, or even a particular sub section of a web site. As
68opposed to some WAIS-based or web-server based search engines, ht://Dig can
69span several web servers at a site. The type of these different web servers
70doesn't matter as long as they understand the HTTP 1.0 protocol.
71
72The %{name}-web package includes CGI scripts and HTML code needed to use
73ht://Dig on a website.
74
75ht://Dig was developed at San Diego State University as a way to search the
76various web servers on the campus network.
77#'
78
79%prep
80%setup -q -n %{name}-%{version}%{beta}
81%patch1 -p1 -b .rh
82%patch2 -p1 -b .xopen
83%patch4 -p1 -b .overflow
84%patch5 -p1 -b .robots
85%patch6 -p1 -b .unescaped_output
86%patch8 -p1 -b .compile-fix
87%patch9 -p1 -b .opts
88%patch11 -p1 -b .incremental
89%patch12 -p1 -b .CVE-2007-6110
90%patch13 -p1 -b .htstat-segv
91%patch14 -p1 -b .external_parsers
92%patch15 -p1 -b .allow_numbers
93
94autoreconf -fiv
95
96%build
97%configure \
98        --enable-shared \
99        --enable-tests \
100        --enable-bigfile \
101        --with-config-dir=%{_sysconfdir}/htdig \
102        --with-common-dir=%{contentdir}/html/htdig \
103        --with-database-dir=/var/lib/htdig \
104        --localstatedir=/var/lib/htdig \
105        --with-cgi-bin-dir=%{contentdir}/cgi-bin \
106        --with-image-dir=%{contentdir}/html/htdig \
107        --with-search-dir=%{contentdir}/html/htdig \
108        --with-default-config-file=%{_sysconfdir}/htdig/htdig.conf \
109        --with-apache=%{apachebin} \
110        --with-zlib=%{_prefix} \
111        --with-ssl
112make
113
114%install
115rm -rf $RPM_BUILD_ROOT
116make install DESTDIR=$RPM_BUILD_ROOT
117
118ln $RPM_BUILD_ROOT%{contentdir}/cgi-bin/htsearch $RPM_BUILD_ROOT%{_bindir}
119
120chmod 644 $RPM_BUILD_ROOT%{contentdir}/html/htdig/*
121ln -sf search.html $RPM_BUILD_ROOT%{contentdir}/html/htdig/index.html
122# now get rid of the $RPM_BUILD_ROOT paths in the conf files
123for i in %{_sysconfdir}/htdig/htdig.conf /usr/bin/rundig ; do
124        perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT/$i
125done
126mkdir -p $RPM_BUILD_ROOT%{_prefix}/share
127mv $RPM_BUILD_ROOT%{contentdir}/html/htdig $RPM_BUILD_ROOT%{_prefix}/share
128mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
129install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/conf.d/htdig.conf
130
131rm -rf $RPM_BUILD_ROOT%{_includedir}
132rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.a
133rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.la
134rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.a
135rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.la
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%files
141%defattr(-,root,root)
142%doc htdoc/*
143%dir %{_sysconfdir}/htdig
144%config %{_sysconfdir}/htdig/htdig.conf
145%config %{_sysconfdir}/htdig/cookies.txt
146%{_sysconfdir}/htdig/HtFileType-magic.mime
147%{_sysconfdir}/htdig/mime.types
148%dir /var/lib/htdig
149%{_bindir}/*
150%{_libdir}/htdig
151%{_libdir}/htdig_db
152%{_mandir}/man1/*
153
154%if %buildweb
155%files web
156%defattr(-,root,root)
157%{contentdir}/cgi-bin/*
158%config %{_sysconfdir}/httpd/conf.d/htdig.conf
159%dir %{_datadir}/htdig
160%{_datadir}/htdig/*
161%{_mandir}/man8/*
162%endif
163
164%changelog
165* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 3.2.0-10.b6
166- rebuild with gcc-5.4.0
167
168* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-9.b6
169- rebuild with VineSeed environment
170
171* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-8.b6
172- rebuilt with current VineSeed
173- replaced Patch100 to Patch8
174- added --with-ssl option to %%configure
175
176* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.0-7.b6vl5
177- applied new versioning policy
178
179* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-6.1vl1.b6
180- new upstream release
181- added Patch100 for building with gcc4
182
183* Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl1.b5
184- rebuild for VineSeedPlus
185
186* Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl0.b5
187- build for VinePlus/2.6
188- remove commented lines
189- change configure options for apache of Vine
190
191* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
192- rebuilt
193
194* Thu Feb 26 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-6
195- Removed buildroot cruft from HtFileFype (#116442).
196- Use mktemp in HtFileFype to create temporary file (#116443).
197
198* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
199- rebuilt
200
201* Thu Jan 15 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-4
202- Fixed missing & in if clause.
203
204* Tue Jan 13 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-3
205- Fixed latin1 char translation (#71921).
206- Fixed overflow bug in WordDBPage.cc (#110802).
207
208* Mon Jan 12 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-2
209- Moved /usr/share/htdig files to web package (#111938).
210
211* Fri Dec 12 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-1
212- Update to latest stable upstream version htdig-3.2.0b5.
213
214* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
215- rebuilt
216
217* Wed Jun 04 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-18.20030601
218- Update to htdig-3.2.0b4-20030601 snapshot.
219- Fixed build problems.
220
221* Thu Mar 06 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-17.20030302
222- Update to htdig-3.2.0b4-20030302 snapshot.
223
224* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
225- rebuilt
226
227* Wed Jan  8 2003 Jeff Johnson <jbj@redhat.com> 3.2.0-15.20021103
228- don't include -debuginfo files in package.
229
230* Tue Dec 17 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-14.20021103
231- Forgot to create conf.d directory. Fixed.
232- Fixed wrong files section.
233
234* Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-13.20021103
235- Removed symlink from %{contentdir}/html and replaced it with httpd.d conf
236  file (#73518).
237
238* Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-12.20021103
239- Added webserver requirement for htdig-web package (#73986).
240
241* Wed Dec 04 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-11.20021103
242- Fix for autoFOO patch.
243- Fix x64_64 build.
244
245* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 3.2.0-9.20021103
246- rebuild on all arches
247
248* Fri Nov 08 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-8.20021103
249- Updated to htdig-3.2.0b4-20021103.
250- Fixed %files section errors.
251
252* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.2.0-7.20020505
253- rebuilt with gcc-3.2 (we hope)
254
255* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 3.2.0-6.20020505
256- build using gcc-3.2-0.1
257
258* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.2.0-5.20020505
259- automated rebuild
260
261* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-4.20020505
262- Don't forcibly strip binaries
263
264* Thu May 23 2002 Tim Powers <timp@redhat.com>
265- automated rebuild
266
267* Mon May  6 2002 Bernhard Rosenkraenzer <bero@linux-easy.com> 3.2.0-2.20020505
268- Fix build with current toolchain (automake 1.6, autoconf 2.53 changes)
269- Update snapshot, fixes some more problems
270
271* Thu Jan 24 2002 Phil Knirsch <pknirsch@redhat.com>
272- Updated to latest snapshot to fix several problems.
273- Fixed a problem with htdig segfaulting on s390 (#58202).
274
275* Fri Jul 20 2001 Philipp Knirsch <pknirsch@redhat.de>
276- Added missing BuildRequires: zlib-devel (#49500)
277
278* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
279- Bump release + rebuild.
280
281* Fri Apr 27 2001 Bill Nottingham <notting@redhat.com>
282- rebuild for C++ exception handling on ia64
283
284* Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.2.0-0.b3.4
285- move pictures etc. to base package and to a directory outside of
286  /var/www - The current KDevelop search function doesn't work without
287  them.
288
289* Mon Mar  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
290- Add htsearch to the base package, kdevelop needs it
291
292* Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
293- Move the web related files to a separate package
294
295* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
296- 3.2.0b2
297- fix build with glibc 2.2 and gcc 2.96
298
299* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
300- fix syntax error introduced in our patch (#16598)
301
302* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
303- fixed group to be a valid one
304
305* Mon Jul 24 2000 Prospector <prospector@redhat.com>
306- rebuilt
307
308* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
309- rebuild for Power Tools
310
311* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
312- rebuild for Power Tools
313
314* Sat Feb 26 2000 Nalin Dahyabhai <nalin@redhat.com>
315- 3.1.5
316
317* Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
318- 3.1.4
319- fix URL and source location
320
321* Tue Sep 28 1999 Preston Brown <pbrown@redhat.com>
322- 3.1.3 for SWS 3.1
323
324* Wed May 05 1999 Preston Brown <pbrown@redhat.com>
325- updates for SWS 3.0
326
327* Mon Aug 31 1998 Preston Brown <pbrown@redhat.com>
328- Updates for SWS 2.0
329
330* Sat Feb 07 1998 Cristian Gafton <gafton@redhat.com>
331- built against glibc
332- build all the fuzzy databases before packaging, because it is time
333  consuming operation and we don't want the user to be impatient
Note: See TracBrowser for help on using the repository browser.