source: projects/specs/trunk/h/hscolour/hscolour-vl.spec @ 10232

Revision 10232, 1.9 KB checked in by ara_t, 8 years ago (diff)

rebuild without cabal-install

Line 
1%define pkg_name    hscolour
2%define pkg_version 1.24
3%define pkg_release 4%{?_dist_release}
4
5Summary: A small Haskell script to colourise Haskell code
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv2
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13Source0: http://hackage.haskell.org/package/%{pkg_name}-%{pkg_version}/%{pkg_name}-%{pkg_version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
16
17BuildRequires: ghc-bootstrap
18BuildRequires: gmp-devel
19BuildRequires: libffi-devel
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: ara_t
24
25
26%description
27hscolour is a small Haskell script to colourise Haskell code.
28It currently has six output formats: ANSI terminal codes
29(optionally XTerm-256colour codes), HTML 3.2 with font tags,
30HTML 4.01 with CSS, HTML 4.01 with CSS and mouseover annotations,
31XHTML 1.0 with inline CSS styling, LaTeX, and mIRC chat codes.
32
33
34%prep
35%{__rm} -rf ${RPM_BUILD_ROOT}
36%setup -q
37
38%build
39ghc -threaded --make Setup
40./Setup configure \
41        --disable-shared \
42        --prefix=%{_prefix} \
43        --libsubdir=%{_libdir}/ghc-lib/%{name}-%{version} \
44        --datasubdir=%{_docdir}/%{name}-%{version} \
45        --docdir=%{_docdir}/%{name}-%{version}
46./Setup build
47
48%install
49./Setup copy --destdir=${RPM_BUILD_ROOT}
50
51cd ${RPM_BUILD_ROOT}%{_bindir}
52%{__ln_s} HsColour hscolour
53
54
55%clean
56%{__rm} -rf ${RPM_BUILD_ROOT}
57
58
59%files
60%defattr(-, root, root)
61%{_bindir}/
62%{_libdir}/ghc-lib/
63%{_datadir}/
64
65
66%changelog
67* Mon May 02 2016 Toshiaki Ara <ara_t@384.jp> 1.24-4
68- rebuilt under ghc-bootstrap only (without haskell-platform)
69- delete Requires: ghc
70
71* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.24-3
72- correct SPEC file
73
74* Sat Feb 20 2016 Toshiaki Ara <ara_t@384.jp> 1.24-2
75- rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
76
77* Tue Feb 09 2016 Toshiaki Ara <ara_t@384.jp> 1.24-1
78- new package
79
Note: See TracBrowser for help on using the repository browser.