source: projects/specs/trunk/h/hscolour/hscolour-vl.spec @ 10155

Revision 10155, 1.8 KB checked in by ara_t, 8 years ago (diff)

A small Haskell script to colourise Haskell code

Line 
1%define pkg_name    hscolour
2%define pkg_version 1.24
3%define pkg_release 3%{?_dist_release}
4
5%define ghc_version 7.10.3
6
7%ifarch %{ix86}
8%define rpmarch i386
9%endif
10%ifarch x86_64
11%define rpmarch x86_64
12%endif
13
14
15Summary: A small Haskell script to colourise Haskell code
16Name:    %{pkg_name}
17Version: %{pkg_version}
18Release: %{pkg_release}
19
20License: GPLv2
21Group:   Applications/Text
22URL:     http://hackage.haskell.org
23Source0: http://hackage.haskell.org/package/%{name}-%{pkg_version}/%{name}-%{pkg_version}.tar.gz
24
25BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
26
27BuildRequires: ghc
28BuildRequires: haskell-platform-base cabal-install
29BuildRequires: gmp-devel libffi-devel
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: ara_t
34
35
36%description
37hscolour is a small Haskell script to colourise Haskell code.
38It currently has six output formats: ANSI terminal codes
39(optionally XTerm-256colour codes), HTML 3.2 with font tags,
40HTML 4.01 with CSS, HTML 4.01 with CSS and mouseover annotations,
41XHTML 1.0 with inline CSS styling, LaTeX, and mIRC chat codes.
42
43
44%prep
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%setup -q
47
48%build
49cabal configure \
50      --prefix=%{_prefix} \
51      --libsubdir=%{_libdir}/ghc-lib/%{name}-%{version} \
52      --datasubdir=%{_docdir}/%{name}-%{version} \
53      --docdir=%{_docdir}/%{name}-%{version}
54cabal build
55
56%install
57cabal copy --destdir=${RPM_BUILD_ROOT}
58
59cd ${RPM_BUILD_ROOT}%{_bindir}
60%{__ln_s} HsColour hscolour
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66
67%files
68%defattr(-, root, root)
69%{_bindir}/
70%{_libdir}/ghc-lib/
71%{_datadir}/
72
73
74%changelog
75* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.24-3
76- correct SPEC file
77
78* Sat Feb 20 2016 Toshiaki Ara <ara_t@384.jp> 1.24-2
79- rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
80
81* Tue Feb 09 2016 Toshiaki Ara <ara_t@384.jp> 1.24-1
82- new package
Note: See TracBrowser for help on using the repository browser.