source: projects/specs/trunk/h/hplip/hplip-vl.spec @ 5701

Revision 5701, 10.7 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1# %define python_platlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2Summary:        HP printer drivers & utilities for Linux
3Summary(ja):    HP プリンタ用の Linux 向けドライバとユーティリティ
4Name:           hplip
5Version:        3.11.5
6Release:        4%{?_dist_release}
7Source0:        %{name}-%{version}.tar.gz
8Source1:        hplip.desktop.vine
9Patch0:         hplip-3.11.5-gksu.patch
10Patch1:         hplip-udev-rules.patch
11License:        GPL/MIT
12Group:          Applications/Publishing
13URL:            http://hplipopensource.com/hplip-web/index.html
14
15Requires:       cups
16Requires:       dbus
17Requires:       foomatic
18Requires:       ghostscript
19Requires:       libjpeg
20Requires:       openssl
21Requires:       python-imaging
22Requires:       dbus-python
23Requires:       %{name}-libs = %{version}-%{release}
24Requires:       gksu
25BuildRequires:  cups-devel
26BuildRequires:  dbus-devel
27BuildRequires:  libusb-devel
28BuildRequires:  libjpeg-devel
29BuildRequires:  net-snmp-devel
30BuildRequires:  openssl-devel
31BuildRequires:  python-devel >= 2.3
32BuildRequires:  sane-devel
33BuildRequires:  PyQt4
34# to force to use PyQt4
35BuildConflicts: PyQt
36
37Provides:       hpijs
38Obsoletes:      hpijs < 3.10
39
40BuildRoot:      %{_tmppath}/%{name}-%{version}-root
41
42Packager:       kazutaka
43
44# When below files are included in %files section,
45# find-requires shows strange error.
46#  %{_datadir}/hplip/base/kirbybase.py and pexpect.py
47# So, below option is added to aboid this.
48#AutoReq:       False
49
50%description
51HPLIP is an HP developed solution for printing, scanning, and
52faxing with HP inkjet and laser based printers in Linux.
53
54The HPLIP project provides printing support for 1,151 printer
55models, including Deskjet, Officejet, Photosmart, PSC (Print Scan
56Copy), Business Inkjet, LaserJet, Edgeline MFP, and LaserJet MFP.
57
58%description -l ja
59HPLIP は HP が開発した HP インクジェット及びレーザープリンタ向けの、
60プリンタ/スキャナ/FAX 機能を Linux 上で利用する為のソリューション
61です。
62
63HPLIP プロジェクトでは1,151種類のプリンタをサポートしています。
64これには Deskjet、 Officejet、 Photosmart、 PSC (Print Scan Copy)、
65Business Inkjet、 LaserJet、 Edgeline MFP 及び LaserJet MFP が
66含まれます。
67
68#---------------------------------------------------------------------
69
70%package libs
71Summary:        HPLIP libraries
72Summary(ja):    HPLIP ライブラリ
73Group:          System Environment/Libraries
74License:        GPL/MIT
75
76%description libs
77Libraries needed by HPLIP.
78
79%description libs -l ja
80HPLIP 用のライブラリです。
81
82#---------------------------------------------------------------------
83
84%package gui
85Summary:        HPLIP graphical tools
86Summary(ja):    HPLIP 用 GUI ツール
87Group:          Applications/System
88License:        GPL/MIT
89Requires:       %{name} = %{version}-%{release}
90Requires:       PyQt4
91Requires:       notify-python
92
93%description gui
94HP Device manager (toolbox) is a graphical utility including
95maintenance tools, supplies levels, and status information.
96
97%description gui -l ja
98HP デバイスマネージャ (toolbox) は、各種設定やインクや紙の残量確
99認、ステータス情報の確認が行える HPLIP 用の GUI ユーティリティです。
100
101#---------------------------------------------------------------------
102
103%package -n libsane-hpaio
104Summary:        SANE driver for scanners in HP's multi-function devices
105Summary(ja):    HP 複合機のスキャナ用 SANE ドライバ
106Group:          System Environment/Libraries
107License:        GPL/MIT
108Requires:       %{name}-libs = %{version}-%{release}
109Requires:       sane
110
111%description -n libsane-hpaio
112SANE driver for scanners in HP inkjet and laser based multi-function
113printers.
114
115%description -n libsane-hpaio -l ja
116HP インクジェット及びレーザープリンタ複合機のスキャナ機能を利用する
117為の SANE ドライバです。
118
119#---------------------------------------------------------------------
120
121%prep
122%setup -q
123%patch0 -p1 -b .gksu
124%patch1 -p1 -b .udev-rules
125
126%build
127%configure --enable-doc-build \
128           --enable-network-build \
129           --disable-pp-build \
130           --enable-scan-build \
131           --enable-gui-build \
132           --enable-fax-build \
133           --enable-dbus-build \
134           --enable-qt4 \
135           --disable-qt3 \
136           --enable-hpijs-install \
137           --enable-hpcups-install \
138           --enable-cups-drv-install \
139           --enable-foomatic-drv-install \
140           --disable-cups-ppd-install \
141           --disable-foomatic-ppd-install \
142           --with-cupsbackenddir=%{_libdir}/cups/backend \
143           --with-cupsfilterdir=%{_libdir}/cups/filter \
144           --with-hpppddir=%{_datadir}/foomatic/db/source/PPD/HP
145%{__make}
146
147
148%install
149%{__rm} -rf ${RPM_BUILD_ROOT}
150%{__make} install DESTDIR=${RPM_BUILD_ROOT}
151
152# install modified .desktop
153%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/applications/hplip.desktop
154
155# remove unpacked files.
156%{__rm} -rf ${RPM_BUILD_ROOT}/%{_sysconfdir}/sane.d
157
158# remove unnecessary files.
159%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libhpip.la
160%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libhpmud.la
161%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/cupsext.la
162%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/hpmudext.la
163%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/pcardext.la
164%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/scanext.la
165%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/sane/libsane-hpaio.la
166
167%clean
168%__rm -rf ${RPM_BUILD_ROOT}
169
170
171%post libs
172/sbin/ldconfig
173
174%postun libs
175/sbin/ldconfig
176
177%post gui
178/usr/bin/update-desktop-database &>/dev/null ||:
179
180%postun gui
181/usr/bin/update-desktop-database &>/dev/null ||:
182
183%post -n libsane-hpaio
184/sbin/ldconfig
185if [ -f /etc/sane.d/dll.conf ] && \
186   ! grep ^hpaio /etc/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
187        echo hpaio >> /etc/sane.d/dll.conf; \
188fi
189
190%files
191%defattr(-,root,root)
192%doc %{_datadir}/doc/%{name}-%{version}
193%{_bindir}/hp-align
194%{_bindir}/hp-check
195%{_bindir}/hp-clean
196%{_bindir}/hp-colorcal
197%{_bindir}/hp-devicesettings
198%{_bindir}/hp-fab
199%{_bindir}/hp-faxsetup
200%{_bindir}/hp-firmware
201%{_bindir}/hp-info
202%{_bindir}/hp-levels
203%{_bindir}/hp-linefeedcal
204%{_bindir}/hp-makecopies
205%{_bindir}/hp-makeuri
206%{_bindir}/hp-mkuri
207%{_bindir}/hp-plugin
208%{_bindir}/hp-pqdiag
209%{_bindir}/hp-pkservice
210%{_bindir}/hp-printsettings
211%{_bindir}/hp-probe
212%{_bindir}/hp-query
213%{_bindir}/hp-scan
214%{_bindir}/hp-sendfax
215%{_bindir}/hp-setup
216%{_bindir}/hp-systray
217%{_bindir}/hp-testpage
218%{_bindir}/hp-timedate
219%{_bindir}/hp-unload
220%{_bindir}/hp-wificonfig
221%{_bindir}/hpijs
222%{_datadir}/hal/fdi/preprobe/10osvendor/20-hplip-devices.fdi
223%{_datadir}/hplip/__init__.py
224%{_datadir}/hplip/align.py
225%{_datadir}/hplip/base
226%{_datadir}/hplip/check.py
227%{_datadir}/hplip/clean.py
228%{_datadir}/hplip/colorcal.py
229%{_datadir}/hplip/copier
230%{_datadir}/hplip/data/ldl
231%{_datadir}/hplip/data/models
232%{_datadir}/hplip/data/pcl
233%{_datadir}/hplip/data/ps
234%{_datadir}/hplip/devicesettings.py
235%{_datadir}/hplip/fax
236%{_datadir}/hplip/faxsetup.py
237%{_datadir}/hplip/firmware.py
238%{_datadir}/hplip/hpdio.py
239%{_datadir}/hplip/hpssd.py
240%{_datadir}/hplip/info.py
241%{_datadir}/hplip/installer
242%{_datadir}/hplip/levels.py
243%{_datadir}/hplip/linefeedcal.py
244%{_datadir}/hplip/makecopies.py
245%{_datadir}/hplip/makeuri.py
246%{_datadir}/hplip/pcard
247%{_datadir}/hplip/pkservice.py
248%{_datadir}/hplip/plugin.py
249%{_datadir}/hplip/pqdiag.py
250%{_datadir}/hplip/printsettings.py
251%{_datadir}/hplip/prnt
252%{_datadir}/hplip/probe.py
253%{_datadir}/hplip/query.py
254%{_datadir}/hplip/scan
255%{_datadir}/hplip/testpage.py
256%{_datadir}/hplip/timedate.py
257%{_datadir}/hplip/unload.py
258%{_datadir}/hplip/wificonfig.py
259%{_datadir}/cups/drv/hp/hpcups.drv
260%{_datadir}/cups/drv/hp/hpijs.drv
261%{_datadir}/foomatic/db/source/PPD/HP
262%{_libdir}/cups/backend/hp
263%{_libdir}/cups/backend/hpfax
264%{_libdir}/cups/filter/hpcups
265%{_libdir}/cups/filter/hpcac
266%{_libdir}/cups/filter/hpcupsfax
267%{_libdir}/cups/filter/hplipjs
268%{_libdir}/cups/filter/hpps
269%{_libdir}/cups/filter/pstotiff
270%config(noreplace) %{_sysconfdir}/hp/hplip.conf
271%{_sysconfdir}/cups/pstotiff.convs
272%{_sysconfdir}/cups/pstotiff.types
273%{_sysconfdir}/udev/rules.d/55-hpmud.rules
274%{_sysconfdir}/udev/rules.d/56-hpmud_support.rules
275%{_localstatedir}/lib/hp
276
277%files libs
278%defattr(-,root,root)
279%{_libdir}/libhpip.so*
280%{_libdir}/libhpmud.so*
281%{python_sitearch}/cupsext.so
282%{python_sitearch}/hpmudext.so
283%{python_sitearch}/pcardext.so
284%{python_sitearch}/scanext.so
285
286%files gui
287%defattr(-,root,root)
288%{_bindir}/hp-fab
289%{_bindir}/hp-print
290%{_bindir}/hp-scan
291%{_bindir}/hp-sendfax
292%{_bindir}/hp-setup
293%{_bindir}/hp-toolbox
294%{_datadir}/hplip/data/images
295%{_datadir}/hplip/data/localization
296%{_datadir}/hplip/fab.py
297%{_datadir}/hplip/print.py
298%{_datadir}/hplip/scan.py
299%{_datadir}/hplip/sendfax.py
300%{_datadir}/hplip/setup.py
301%{_datadir}/hplip/systray.py
302%{_datadir}/hplip/toolbox.py
303%{_datadir}/hplip/ui4
304%{_datadir}/applications/hplip.desktop
305%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
306
307%files -n libsane-hpaio
308%defattr(-,root,root)
309%{_libdir}/sane/libsane-hpaio*
310
311
312%changelog
313* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.11.5-4
314- rebuild with python-2.7.2
315
316* Mon Jun 13 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-3
317- add Obsoletes: hpijs < 3.10
318
319* Sun Jun 12 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-2
320- change configure option to --enable-hpijs-install
321- add Provides: hpijs
322- change ppd installation path to %{_datadir}/foomatic/db/source/PPD/HP
323- update Source1 (hplip.desktop.vine)
324- update Patch0 (hplip-3.11.5-gksu.patch)
325- add Patch1 to fix udev old syntax (hplip-udev-rules.patch)
326
327* Tue Mar 15 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-1
328- new upstream release
329- change configure option: disable qt3 and enable qt4
330- add configure option: --enable-foomatic-drv-install
331- add BuildRequires: openssl-devel
332- add Requires: dbus-python
333- add Requires: notify-python (gui)
334- change Requires: PyQt to PyQt4 (gui)
335- add BuildConflicts: PyQt
336- add ppds below %{_datadir}/cups/model/foomatic/hp-*
337  because foomatic (>= 4.0.3) drop PPDs for HP printers.
338
339* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-3
340- add Patch0 to require root privilege (via gksu) when adding printer
341- add Requires: gksu
342
343* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 3.9.4b-2
344- added --with-cupsfilterdir to configure option
345- use python_sitearch macro instead of python_platlib
346
347* Sun Jun 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-1
348- new upstream release
349- split libraries to -libs sub package
350- update configure option
351  add --enable-dbus-build, --enable-qt3, --disable-qt4
352
353* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-1vl5
354- rebuilt with python-2.5.2
355- added python_platlib macro
356- applied new versioning policy and spec in utf-8
357
358* Sun Jan  6 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-0vl2
359- added --with-cupsbackenddir=%%{_libdir}/cups/backend to configure
360
361* Thu Jan  3 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.12-0vl1
362- new upstream release
363- build with net-snmp-5.4.1
364
365* Thu Jun 28 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.6-0vl1
366- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.