source: projects/specs/trunk/h/hplip/hplip-vl.spec @ 4127

Revision 4127, 10.5 KB checked in by kazutaka, 13 years ago (diff)

hplip 諸々更新
%changelog

  • change configure option to --enable-hpijs-install
  • add Provides: hpijs
  • change ppd installation path to %{_datadir}/foomatic/db/source/PPD/HP
  • update Source1 (hplip.desktop.vine)
  • update Patch0 (hplip-3.11.5-gksu.patch)
  • add Patch1 to fix udev old syntax (hplip-udev-rules.patch)
Line 
1# %define python_platlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2Summary:        HP printer drivers & utilities for Linux
3Summary(ja):    HP プリンタ用の Linux 向けドライバとユーティリティ
4Name:           hplip
5Version:        3.11.5
6Release:        2%{?_dist_release}
7Source0:        %{name}-%{version}.tar.gz
8Source1:        hplip.desktop.vine
9Patch0:         hplip-3.11.5-gksu.patch
10Patch1:         hplip-udev-rules.patch
11License:        GPL/MIT
12Group:          Applications/Publishing
13URL:            http://hplipopensource.com/hplip-web/index.html
14
15Provides:       hpijs
16
17Requires:       cups
18Requires:       dbus
19Requires:       foomatic
20Requires:       ghostscript
21Requires:       libjpeg
22Requires:       openssl
23Requires:       python-imaging
24Requires:       dbus-python
25Requires:       %{name}-libs = %{version}-%{release}
26Requires:       gksu
27BuildRequires:  cups-devel
28BuildRequires:  dbus-devel
29BuildRequires:  libusb-devel
30BuildRequires:  libjpeg-devel
31BuildRequires:  net-snmp-devel
32BuildRequires:  openssl-devel
33BuildRequires:  python-devel >= 2.3
34BuildRequires:  sane-devel
35BuildRequires:  PyQt4
36# to force to use PyQt4
37BuildConflicts: PyQt
38BuildRoot:      %{_tmppath}/%{name}-%{version}-root
39
40Packager:       kazutaka
41
42# When below files are included in %files section,
43# find-requires shows strange error.
44#  %{_datadir}/hplip/base/kirbybase.py and pexpect.py
45# So, below option is added to aboid this.
46#AutoReq:       False
47
48%description
49HPLIP is an HP developed solution for printing, scanning, and
50faxing with HP inkjet and laser based printers in Linux.
51
52The HPLIP project provides printing support for 1,151 printer
53models, including Deskjet, Officejet, Photosmart, PSC (Print Scan
54Copy), Business Inkjet, LaserJet, Edgeline MFP, and LaserJet MFP.
55
56%description -l ja
57HPLIP は HP が開発した HP インクジェット及びレーザープリンタ向けの、
58プリンタ/スキャナ/FAX 機能を Linux 上で利用する為のソリューション
59です。
60
61HPLIP プロジェクトでは1,151種類のプリンタをサポートしています。
62これには Deskjet、 Officejet、 Photosmart、 PSC (Print Scan Copy)、
63Business Inkjet、 LaserJet、 Edgeline MFP 及び LaserJet MFP が
64含まれます。
65
66#---------------------------------------------------------------------
67
68%package libs
69Summary:        HPLIP libraries
70Summary(ja):    HPLIP ライブラリ
71Group:          System Environment/Libraries
72License:        GPL/MIT
73
74%description libs
75Libraries needed by HPLIP.
76
77%description libs -l ja
78HPLIP 用のライブラリです。
79
80#---------------------------------------------------------------------
81
82%package gui
83Summary:        HPLIP graphical tools
84Summary(ja):    HPLIP 用 GUI ツール
85Group:          Applications/System
86License:        GPL/MIT
87Requires:       %{name} = %{version}-%{release}
88Requires:       PyQt4
89Requires:       notify-python
90
91%description gui
92HP Device manager (toolbox) is a graphical utility including
93maintenance tools, supplies levels, and status information.
94
95%description gui -l ja
96HP デバイスマネージャ (toolbox) は、各種設定やインクや紙の残量確
97認、ステータス情報の確認が行える HPLIP 用の GUI ユーティリティです。
98
99#---------------------------------------------------------------------
100
101%package -n libsane-hpaio
102Summary:        SANE driver for scanners in HP's multi-function devices
103Summary(ja):    HP 複合機のスキャナ用 SANE ドライバ
104Group:          System Environment/Libraries
105License:        GPL/MIT
106Requires:       %{name}-libs = %{version}-%{release}
107Requires:       sane
108
109%description -n libsane-hpaio
110SANE driver for scanners in HP inkjet and laser based multi-function
111printers.
112
113%description -n libsane-hpaio -l ja
114HP インクジェット及びレーザープリンタ複合機のスキャナ機能を利用する
115為の SANE ドライバです。
116
117#---------------------------------------------------------------------
118
119%prep
120%setup -q
121%patch0 -p1 -b .gksu
122%patch1 -p1 -b .udev-rules
123
124%build
125%configure --enable-doc-build \
126           --enable-network-build \
127           --disable-pp-build \
128           --enable-scan-build \
129           --enable-gui-build \
130           --enable-fax-build \
131           --enable-dbus-build \
132           --enable-qt4 \
133           --disable-qt3 \
134           --enable-hpijs-install \
135           --enable-hpcups-install \
136           --enable-cups-drv-install \
137           --enable-foomatic-drv-install \
138           --disable-cups-ppd-install \
139           --disable-foomatic-ppd-install \
140           --with-cupsbackenddir=%{_libdir}/cups/backend \
141           --with-cupsfilterdir=%{_libdir}/cups/filter \
142           --with-hpppddir=%{_datadir}/foomatic/db/source/PPD/HP
143%{__make}
144
145
146%install
147%{__rm} -rf ${RPM_BUILD_ROOT}
148%{__make} install DESTDIR=${RPM_BUILD_ROOT}
149
150# install modified .desktop
151%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/applications/hplip.desktop
152
153# remove unpacked files.
154%{__rm} -rf ${RPM_BUILD_ROOT}/%{_sysconfdir}/sane.d
155
156# remove unnecessary files.
157%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libhpip.la
158%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libhpmud.la
159%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/cupsext.la
160%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/hpmudext.la
161%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/pcardext.la
162%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/scanext.la
163%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/sane/libsane-hpaio.la
164
165%clean
166%__rm -rf ${RPM_BUILD_ROOT}
167
168
169%post libs
170/sbin/ldconfig
171
172%postun libs
173/sbin/ldconfig
174
175%post gui
176/usr/bin/update-desktop-database &>/dev/null ||:
177
178%postun gui
179/usr/bin/update-desktop-database &>/dev/null ||:
180
181%post -n libsane-hpaio
182/sbin/ldconfig
183if [ -f /etc/sane.d/dll.conf ] && \
184   ! grep ^hpaio /etc/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
185        echo hpaio >> /etc/sane.d/dll.conf; \
186fi
187
188%files
189%defattr(-,root,root)
190%doc %{_datadir}/doc/%{name}-%{version}
191%{_bindir}/hp-align
192%{_bindir}/hp-check
193%{_bindir}/hp-clean
194%{_bindir}/hp-colorcal
195%{_bindir}/hp-devicesettings
196%{_bindir}/hp-fab
197%{_bindir}/hp-faxsetup
198%{_bindir}/hp-firmware
199%{_bindir}/hp-info
200%{_bindir}/hp-levels
201%{_bindir}/hp-linefeedcal
202%{_bindir}/hp-makecopies
203%{_bindir}/hp-makeuri
204%{_bindir}/hp-mkuri
205%{_bindir}/hp-plugin
206%{_bindir}/hp-pqdiag
207%{_bindir}/hp-pkservice
208%{_bindir}/hp-printsettings
209%{_bindir}/hp-probe
210%{_bindir}/hp-query
211%{_bindir}/hp-scan
212%{_bindir}/hp-sendfax
213%{_bindir}/hp-setup
214%{_bindir}/hp-systray
215%{_bindir}/hp-testpage
216%{_bindir}/hp-timedate
217%{_bindir}/hp-unload
218%{_bindir}/hp-wificonfig
219%{_bindir}/hpijs
220%{_datadir}/hal/fdi/preprobe/10osvendor/20-hplip-devices.fdi
221%{_datadir}/hplip/__init__.py
222%{_datadir}/hplip/align.py
223%{_datadir}/hplip/base
224%{_datadir}/hplip/check.py
225%{_datadir}/hplip/clean.py
226%{_datadir}/hplip/colorcal.py
227%{_datadir}/hplip/copier
228%{_datadir}/hplip/data/ldl
229%{_datadir}/hplip/data/models
230%{_datadir}/hplip/data/pcl
231%{_datadir}/hplip/data/ps
232%{_datadir}/hplip/devicesettings.py
233%{_datadir}/hplip/fax
234%{_datadir}/hplip/faxsetup.py
235%{_datadir}/hplip/firmware.py
236%{_datadir}/hplip/hpdio.py
237%{_datadir}/hplip/hpssd.py
238%{_datadir}/hplip/info.py
239%{_datadir}/hplip/installer
240%{_datadir}/hplip/levels.py
241%{_datadir}/hplip/linefeedcal.py
242%{_datadir}/hplip/makecopies.py
243%{_datadir}/hplip/makeuri.py
244%{_datadir}/hplip/pcard
245%{_datadir}/hplip/pkservice.py
246%{_datadir}/hplip/plugin.py
247%{_datadir}/hplip/pqdiag.py
248%{_datadir}/hplip/printsettings.py
249%{_datadir}/hplip/prnt
250%{_datadir}/hplip/probe.py
251%{_datadir}/hplip/query.py
252%{_datadir}/hplip/scan
253%{_datadir}/hplip/testpage.py
254%{_datadir}/hplip/timedate.py
255%{_datadir}/hplip/unload.py
256%{_datadir}/hplip/wificonfig.py
257%{_datadir}/cups/drv/hp/hpcups.drv
258%{_datadir}/cups/drv/hp/hpijs.drv
259%{_datadir}/foomatic/db/source/PPD/HP
260%{_libdir}/cups/backend/hp
261%{_libdir}/cups/backend/hpfax
262%{_libdir}/cups/filter/hpcups
263%{_libdir}/cups/filter/hpcac
264%{_libdir}/cups/filter/hpcupsfax
265%{_libdir}/cups/filter/hplipjs
266%{_libdir}/cups/filter/hpps
267%{_libdir}/cups/filter/pstotiff
268%config(noreplace) %{_sysconfdir}/hp/hplip.conf
269%{_sysconfdir}/cups/pstotiff.convs
270%{_sysconfdir}/cups/pstotiff.types
271%{_sysconfdir}/udev/rules.d/55-hpmud.rules
272%{_sysconfdir}/udev/rules.d/56-hpmud_support.rules
273%{_localstatedir}/lib/hp
274
275%files libs
276%defattr(-,root,root)
277%{_libdir}/libhpip.so*
278%{_libdir}/libhpmud.so*
279%{python_sitearch}/cupsext.so
280%{python_sitearch}/hpmudext.so
281%{python_sitearch}/pcardext.so
282%{python_sitearch}/scanext.so
283
284%files gui
285%defattr(-,root,root)
286%{_bindir}/hp-fab
287%{_bindir}/hp-print
288%{_bindir}/hp-scan
289%{_bindir}/hp-sendfax
290%{_bindir}/hp-setup
291%{_bindir}/hp-toolbox
292%{_datadir}/hplip/data/images
293%{_datadir}/hplip/data/localization
294%{_datadir}/hplip/fab.py
295%{_datadir}/hplip/print.py
296%{_datadir}/hplip/scan.py
297%{_datadir}/hplip/sendfax.py
298%{_datadir}/hplip/setup.py
299%{_datadir}/hplip/systray.py
300%{_datadir}/hplip/toolbox.py
301%{_datadir}/hplip/ui4
302%{_datadir}/applications/hplip.desktop
303%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
304
305%files -n libsane-hpaio
306%defattr(-,root,root)
307%{_libdir}/sane/libsane-hpaio*
308
309
310%changelog
311* Sun Jun 12 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-2
312- change configure option to --enable-hpijs-install
313- add Provides: hpijs
314- change ppd installation path to %{_datadir}/foomatic/db/source/PPD/HP
315- update Source1 (hplip.desktop.vine)
316- update Patch0 (hplip-3.11.5-gksu.patch)
317- add Patch1 to fix udev old syntax (hplip-udev-rules.patch)
318
319* Tue Mar 15 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-1
320- new upstream release
321- change configure option: disable qt3 and enable qt4
322- add configure option: --enable-foomatic-drv-install
323- add BuildRequires: openssl-devel
324- add Requires: dbus-python
325- add Requires: notify-python (gui)
326- change Requires: PyQt to PyQt4 (gui)
327- add BuildConflicts: PyQt
328- add ppds below %{_datadir}/cups/model/foomatic/hp-*
329  because foomatic (>= 4.0.3) drop PPDs for HP printers.
330
331* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-3
332- add Patch0 to require root privilege (via gksu) when adding printer
333- add Requires: gksu
334
335* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 3.9.4b-2
336- added --with-cupsfilterdir to configure option
337- use python_sitearch macro instead of python_platlib
338
339* Sun Jun 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-1
340- new upstream release
341- split libraries to -libs sub package
342- update configure option
343  add --enable-dbus-build, --enable-qt3, --disable-qt4
344
345* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-1vl5
346- rebuilt with python-2.5.2
347- added python_platlib macro
348- applied new versioning policy and spec in utf-8
349
350* Sun Jan  6 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-0vl2
351- added --with-cupsbackenddir=%%{_libdir}/cups/backend to configure
352
353* Thu Jan  3 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.12-0vl1
354- new upstream release
355- build with net-snmp-5.4.1
356
357* Thu Jun 28 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.6-0vl1
358- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.