source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 7751

Revision 7751, 4.3 KB checked in by miyabi, 11 years ago (diff)
Line 
1%define         base_name       hostapd
2%define         pkg_version     2.0
3%define         pkg_release     1%{?_dist_release}
4
5Summary:        IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
6Summary(ja):    IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
7Name:           %{base_name}
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10Source0:        %{base_name}-%{version}.tar.gz
11Source1:        %{base_name}-init.sh
12Source2:        %{base_name}-%{version}.config
13Patch0:         %{base_name}-%{version}.patch
14License:        GPL2
15Group:          System Environment/Daemons
16URL:            http://hostap.epitest.fi/hostapd/
17
18Requires:       openssl, libnl >= 1.1
19Requires(post): %{_syssbindir}/chkconfig
20Requires(preun): %{_syssbindir}/chkconfig
21BuildRequires:  openssl-devel, libnl-devel
22BuildRoot:      %{_tmppath}/%{base_name}-%{version}-root
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       miyabi
27
28%description
29hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
30IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
31The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
32
33%description -l ja
34hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
35IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
36最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
37
38%prep
39%setup -q
40%patch0 -p1
41cp %{SOURCE1} .
42cp %{SOURCE2} ./%{base_name}/.config
43
44%build
45cd %{base_name}
46%{__make} %{?_smp_mflags}
47
48%install
49[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
50
51pushd %{base_name}
52%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
53popd
54
55mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
56
57install %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
58
59%post
60if ! /sbin/chkconfig %{base_name}; then
61  /sbin/chkconfig --add %{base_name}
62fi
63
64if [ "$1" -eq "2" ]; then
65  %{_initdir}/%{base_name} condrestart
66fi
67
68%preun
69if [ "$1" -eq "0" ]; then
70  %{_initdir}/%{base_name} stop
71  /sbin/chkconfig --del %{base_name}
72fi
73
74%clean
75[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
76
77%files
78%defattr(-, root, root)
79
80# Directory
81%dir %{_sysconfdir}/%{base_name}/
82
83# Program Files
84%attr(0755, root, root) %{_sbindir}/%{base_name}
85%attr(0755, root, root) %{_bindir}/hostapd_cli
86
87%attr(0755, root, root) %{_initdir}/%{base_name}
88
89# Config Files
90%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
91
92# Document Files
93%doc %{base_name}/ChangeLog COPYING README
94%{_mandir}/man8/%{base_name}.8.gz
95%{_mandir}/man1/hostapd_cli.1.gz
96
97%changelog
98* Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
99- new upstream release
100- change filename hostapd.conf -> hostapd.conf.sample
101- change .config
102  - add WPS support
103
104* Sun Dec  2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
105- new upstream release
106
107* Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
108- new upstream release
109- add Summary(ja)
110- add section - %description -l ja
111- add parameter noreplace to %config
112- change spec file
113
114* Tue Oct  9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
115- add patch100 for fix CVE-2012-4445 (EPA-TLS message)
116
117* Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
118- fix daemon script
119- change spec file
120- separation from patch file
121  - daemon script
122  - .config
123- add Source1 - hostapd-init.sh
124- add Source2 - hostapd-0.7.3.config
125- add Requires(post) - chkconfig
126- add Requires(preun) - chkconfig
127
128* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
129- rebuild with openssl-1.0.0c
130
131* Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
132- new upstream release
133
134* Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
135- new upstream release
136
137* Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
138- new upstream release
139
140* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
141- new upstream release
142
143* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
144- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.