source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 6961

Revision 6961, 4.1 KB checked in by miyabi, 12 years ago (diff)

new upstream release.
etc

Line 
1%define         base_name       hostapd
2%define         pkg_version     1.0
3%define         pkg_release     1%{?_dist_release}
4
5Summary:        IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
6Summary(ja):    IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
7Name:           %{base_name}
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10Source0:        %{base_name}-%{version}.tar.gz
11Source1:        %{base_name}-init.sh
12Source2:        %{base_name}-%{version}.config
13Patch0:         %{base_name}-%{version}.patch
14Patch100:       %{base_name}-%{version}_CVE-2012-4445.pacth
15License:        GPL2
16Group:          System Environment/Daemons
17URL:            http://hostap.epitest.fi/hostapd/
18
19Requires:       openssl, libnl >= 1.1
20Requires(post): %{_syssbindir}/chkconfig
21Requires(preun): %{_syssbindir}/chkconfig
22BuildRequires:  openssl-devel, libnl-devel
23BuildRoot:      %{_tmppath}/%{base_name}-%{version}-root
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27Packager:       miyabi
28
29%description
30hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
31IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
32The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
33
34%description -l ja
35hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
36IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
37最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
38
39%prep
40%setup -q
41%patch0 -p1
42%patch100 -p1
43cp %{SOURCE1} .
44cp %{SOURCE2} ./%{base_name}/.config
45
46%build
47cd %{base_name}
48%{__make} %{?_smp_mflags}
49
50%install
51[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
52
53pushd %{base_name}
54%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
55popd
56
57mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
58
59install %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
60
61%post
62if ! /sbin/chkconfig %{base_name}; then
63  /sbin/chkconfig --add %{base_name}
64fi
65
66if [ "$1" -eq "2" ]; then
67  %{_initdir}/%{base_name} condrestart
68fi
69
70%preun
71if [ "$1" -eq "0" ]; then
72  %{_initdir}/%{base_name} stop
73  /sbin/chkconfig --del %{base_name}
74fi
75
76%clean
77[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
78
79%files
80%defattr(-, root, root)
81
82# Directory
83%dir %{_sysconfdir}/%{base_name}/
84
85# Program Files
86%attr(0755, root, root) %{_sbindir}/%{base_name}
87%attr(0755, root, root) %{_bindir}/hostapd_cli
88
89%attr(0755, root, root) %{_initdir}/%{base_name}
90
91# Config Files
92%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf
93
94# Document Files
95%doc %{base_name}/ChangeLog COPYING README
96%{_mandir}/man8/%{base_name}.8.gz
97%{_mandir}/man1/hostapd_cli.1.gz
98
99%changelog
100* Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
101- new upstream release
102- add Summary(ja)
103- add section - %description -l ja
104- add parameter noreplace to %config
105- change spec file
106
107* Tue Oct  9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
108- add patch100 for fix CVE-2012-4445 (EPA-TLS message)
109
110* Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
111- fix daemon script
112- change spec file
113- separation from patch file
114  - daemon script
115  - .config
116- add Source1 - hostapd-init.sh
117- add Source2 - hostapd-0.7.3.config
118- add Requires(post) - chkconfig
119- add Requires(preun) - chkconfig
120
121* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
122- rebuild with openssl-1.0.0c
123
124* Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
125- new upstream release
126
127* Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
128- new upstream release
129
130* Mon Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
131- new upstream release
132
133* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
134- new upstream release
135
136* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
137- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.