source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 2732

Revision 2732, 3.0 KB checked in by miyabi, 13 years ago (diff)
Line 
1%define pkg_version 0.7.3
2%define pkg_release 3%{?_dist_release}
3
4Summary:       IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
5Name:          hostapd
6Version:       %{pkg_version}
7Release:       %{pkg_release}
8Source0:       %{name}-%{version}.tar.gz
9Source1:       %{name}-init.sh
10Source2:       %{name}-%{version}.config
11Patch0:        %{name}-%{version}.patch
12License:       GPL2
13Group:         System Environment/Daemons
14URL:           http://hostap.epitest.fi/hostapd/
15
16Requires:      openssl, libnl >= 1.1
17Requires(post): chkconfig
18Requires(preun): chkconfig
19BuildRequires: openssl-devel, libnl-devel
20BuildRoot:     %{_tmppath}/%{name}-%{version}-root
21
22Vendor:        Project Vine
23Distribution:  Vine Linux
24Packager:      miyabi
25
26%description
27hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
28IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
29The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
30
31%prep
32%setup -q -n %{name}-%{version}
33%patch0 -p1
34cp %{SOURCE1} .
35cp %{SOURCE2} ./%{name}/.config
36
37%build
38cd %{name}
39%{__make}
40
41%install
42[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
43
44mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
45
46pushd %{name}
47%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
48popd
49
50install %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{name}
51
52%post
53if ! /sbin/chkconfig %{name}; then
54  /sbin/chkconfig --add %{name}
55fi
56
57if [ $1 -eq 2 ]; then
58  %{_initdir}/%{name} condrestart
59fi
60
61%preun
62if [ $1 -eq 0 ]; then
63  %{_initdir}/%{name} stop
64  /sbin/chkconfig --del %{name}
65fi
66
67%clean
68[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
69
70%files
71%defattr(-, root, root)
72%doc hostapd/ChangeLog COPYING README
73%dir %{_sysconfdir}/hostapd/
74%attr(0755, root, root) %{_sbindir}/hostapd
75%attr(0755, root, root) %{_bindir}/hostapd_cli
76%{_mandir}/man8/hostapd.8.gz
77%{_mandir}/man1/hostapd_cli.1.gz
78%attr(0644, root, root) %config %{_sysconfdir}/hostapd/hostapd.conf
79%attr(0755, root, root) %{_sysconfdir}/rc.d/init.d/hostapd
80
81%changelog
82* Mon Feb 21 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-3
83- merge spec file
84
85* Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
86- fix daemon script
87- change spec file
88- separation from patch file
89  - daemon script
90  - .config
91- add Source1 - hostapd-init.sh
92- add Source2 - hostapd-0.7.3.config
93- add Requires(post) - chkconfig
94- add Requires(preun) - chkconfig
95
96* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
97- rebuild with openssl-1.0.0c
98
99* Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
100- new upstream release
101
102* Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
103- new upstream release
104
105* Mon Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
106- new upstream release
107
108* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
109- new upstream release
110
111* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
112- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.