source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 521

Revision 521, 1.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkg_version 0.5.11
2%define pkg_release 1%{?_dist_release}
3
4Summary:     IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
5Name:        hostapd
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.gz
9Patch0:      %{name}-%{version}.patch
10License:     GPL2
11Group:       System Environment/Daemons
12URL:         http://hostap.epitest.fi/hostapd/
13
14BuildRequires: openssl-devel
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16
17%description
18hostapd  is a user space daemon for access point and authentication servers.  It implements IEEE 802.11 access point management,
19IEEE 802.1X/WPA/WPA2/EAP Authenticators and RADIUS authentication server.  The current version supports Linux (Host AP, madwifi,
20Prism54 drivers) and FreeBSD (net80211).
21
22%prep
23%setup -q -n %{name}-%{version}
24%patch -p1
25
26%build
27%{__make}
28
29%install
30%{__rm} -rf ${RPM_BUILD_ROOT}
31%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
32
33%post
34if [ $1 = 1 ] ; then
35    /sbin/chkconfig --add hostapd
36fi
37
38%preun
39if [ $1 = 0 ] ; then
40    /etc/rc.d/init.d/hostapd stop
41    /sbin/chkconfig --del hostapd
42fi
43
44%clean
45%__rm -rf ${RPM_BUILD_ROOT}
46
47%files
48%defattr(-, root, root)
49%doc ChangeLog COPYING README
50%dir %{_sysconfdir}/hostapd/
51%{_sbindir}/hostapd
52%{_bindir}/hostapd_cli
53%{_mandir}/man8/hostapd.8.gz
54%{_mandir}/man1/hostapd_cli.1.gz
55%attr(0644, root, root) %config %{_sysconfdir}/hostapd/hostapd.conf
56%attr(0755, root, root) %{_sysconfdir}/rc.d/init.d/hostapd
57
58%changelog
59* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
60- new upstream release
61
62* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
63- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.