source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 12004

Revision 12004, 5.5 KB checked in by miyabi, 5 years ago (diff)

new upstream release

Line 
1%define         base_name       hostapd
2%define         pkg_version     2.7
3%define         pkg_release     1%{?_dist_release}
4
5Summary:        IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
6Summary(ja):    IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
7Name:           %{base_name}
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10Source0:        %{base_name}-%{version}.tar.gz
11Source1:        %{base_name}-init.sh
12Source2:        %{base_name}-%{version}.config
13License:        GPL2
14Group:          System Environment/Daemons
15URL:            http://hostap.epitest.fi/hostapd/
16
17Requires:       openssl, libnl >= 1.1
18Requires(post): %{_syssbindir}/chkconfig
19Requires(preun): %{_syssbindir}/chkconfig
20BuildRequires:  openssl-devel, libnl-devel
21BuildRoot:      %{_tmppath}/%{base_name}-%{version}-root
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       miyabi
26
27%description
28hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
29IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
30The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
31
32%description -l ja
33hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
34IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
35最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
36
37%prep
38%setup -q
39cp %{SOURCE1} .
40cp %{SOURCE2} ./%{base_name}/.config
41
42%build
43cd %{base_name}
44%{__make} %{?_smp_mflags}
45
46%install
47[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
48
49pushd %{base_name}
50%{__make} install DESTDIR="${RPM_BUILD_ROOT}" BINDIR="%{_sbindir}"
51popd
52
53%{__install} -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
54
55%{__install} -D %{base_name}/hostapd.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
56%{__install} -D %{base_name}/hostapd.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/hostapd.8
57%{__install} -D %{base_name}/hostapd_cli.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/hostapd_cli.1
58
59%post
60if ! /sbin/chkconfig %{base_name}; then
61  /sbin/chkconfig --add %{base_name}
62fi
63
64if [ "$1" -eq "2" ]; then
65  %{_initdir}/%{base_name} condrestart
66fi
67
68%preun
69if [ "$1" -eq "0" ]; then
70  %{_initdir}/%{base_name} stop
71  /sbin/chkconfig --del %{base_name}
72fi
73
74%clean
75[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
76
77%files
78%defattr(-, root, root)
79
80# Directory
81%dir %{_sysconfdir}/%{base_name}/
82
83# Program Files
84%attr(0755, root, root) %{_sbindir}/hostapd
85%attr(0755, root, root) %{_sbindir}/hostapd_cli
86
87%attr(0755, root, root) %{_initdir}/%{base_name}
88
89# Config Files
90%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
91
92# Document Files
93%doc %{base_name}/ChangeLog COPYING README
94%{_mandir}/man8/%{base_name}.8.gz
95%{_mandir}/man1/hostapd_cli.1.gz
96
97%changelog
98* Wed Jan 02 2019 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.7-1
99- new upstream release
100
101* Fri Oct 20 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6-2
102- add patch11-18 for fix "KRACK" issue
103
104* Sat Feb 04 2017 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.6-1
105- new upstream release
106
107* Sat Jan 02 2016 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.5-1
108- new upstream release
109
110* Sat Mar 21 2015 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.4-1
111- new upstream release
112- change hostapd_cli install path /usr/bin -> /usr/sbin
113
114* Sat Dec 06 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.3-1
115- new upstream release
116
117* Wed Jul 09 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.2-1
118- new upstream release
119
120* Wed Apr 23 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-2
121- add patch - hostapd-2.1.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
122  - fix segfault
123
124* Sat Mar 15 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-1
125- new upstream release
126- change .config
127  - add ACS support(Supported ACS drivers: ath5k, ath9k, ath10k)
128
129* Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
130- new upstream release
131- change filename hostapd.conf -> hostapd.conf.sample
132- change .config
133  - add WPS support
134
135* Sun Dec  2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
136- new upstream release
137
138* Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
139- new upstream release
140- add Summary(ja)
141- add section - %description -l ja
142- add parameter noreplace to %config
143- change spec file
144
145* Tue Oct  9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
146- add patch100 for fix CVE-2012-4445 (EPA-TLS message)
147
148* Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
149- fix daemon script
150- change spec file
151- separation from patch file
152  - daemon script
153  - .config
154- add Source1 - hostapd-init.sh
155- add Source2 - hostapd-0.7.3.config
156- add Requires(post) - chkconfig
157- add Requires(preun) - chkconfig
158
159* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
160- rebuild with openssl-1.0.0c
161
162* Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
163- new upstream release
164
165* Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
166- new upstream release
167
168* Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
169- new upstream release
170
171* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
172- new upstream release
173
174* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
175- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.